Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Skype crashes (/usr/lib/ladspa/caps.so required) [Solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
alius-miles
n00b
n00b


Joined: 25 Dec 2010
Posts: 9

PostPosted: Mon Jan 30, 2012 12:53 pm    Post subject: Skype crashes (/usr/lib/ladspa/caps.so required) [Solved] Reply with quote

Skype crashes few second after starting, with message in console: Failed to load plugin "/usr/lib/ladspa/caps.so"

I was trying to emerge caps-pulgins, but then skype crashes with message: /usr/lib/ladspa/caps.so: wrong ELF class: ELFCLASS64

skype-2.2.0.35-r1, ~amd64. Any suggestions?


Last edited by alius-miles on Wed Feb 01, 2012 7:53 am; edited 1 time in total
Back to top
View user's profile Send private message
Kaso_da_Zmok
Apprentice
Apprentice


Joined: 19 Aug 2004
Posts: 189
Location: Zurich, Switzerland

PostPosted: Mon Jan 30, 2012 5:52 pm    Post subject: ~/.Skype/Logs Reply with quote

Can you check if this folder does exist on yourfs?
Code:
~/.Skype/Logs

if not create it.
cause i had skype crash about 3-5 seconds after i logged in and creating the Logs folder did help me.
Back to top
View user's profile Send private message
alius-miles
n00b
n00b


Joined: 25 Dec 2010
Posts: 9

PostPosted: Tue Jan 31, 2012 9:56 am    Post subject: Reply with quote

Creatded Logs, didn't help. Still crashes with error:

Quote:
Failed to load plugin "/usr/lib/ladspa/caps.so": /usr/lib/ladspa/caps.so: cannot open shared object file: No such file or directory
Aborted


I don't really understand, wtf? Earlier skype was working unstable, but working nevertheless.

I have an idea, I'd like to test. Can somebody with x86/~x86 system emerge caps-plugins and sent me /usr/lib/ladspa/caps.so? I want to put it in /usr/lib/ and try to start Skype, see what happend, but I'm on ~amd64 and have no x86 gentoo nearby.
Back to top
View user's profile Send private message
alius-miles
n00b
n00b


Joined: 25 Dec 2010
Posts: 9

PostPosted: Wed Feb 01, 2012 7:50 am    Post subject: problem was in .asoundrc Reply with quote

problem was in .asoundrc
There were some old configuration, so I just delete it, and skype is working now.
Back to top
View user's profile Send private message
aCOSwt
Bodhisattva
Bodhisattva


Joined: 19 Oct 2007
Posts: 2537
Location: Hilbert space

PostPosted: Wed Feb 01, 2012 2:35 pm    Post subject: Re: ~/.Skype/Logs Reply with quote

Kaso_da_Zmok wrote:
Can you check if this folder does exist on yourfs?
Code:
~/.Skype/Logs

if not create it.

Hey ! Thank you very much for the tip ! It actually helps a lot ! 8)
I had given up trying 2.2, sticking with 2.1 because of the crash immediatly after login.
_________________
Back to top
View user's profile Send private message
alius-miles
n00b
n00b


Joined: 25 Dec 2010
Posts: 9

PostPosted: Wed Feb 01, 2012 4:40 pm    Post subject: Reply with quote

Size of skype's logs are rather discouraging. 3 hours uptime and 6Mb. o_O
So I make .Skype/Logs as simlink to /dev/shm/SkypeLogs and just recreate it during startup.
Back to top
View user's profile Send private message
alexandrecss
n00b
n00b


Joined: 21 Mar 2012
Posts: 1
Location: Brazil

PostPosted: Wed Mar 21, 2012 1:08 pm    Post subject: Re: problem was in .asoundrc Reply with quote

alius-miles wrote:
problem was in .asoundrc
There were some old configuration, so I just delete it, and skype is working now.


Thanks! I had the same problem and solved it by just deleting the .asoundrc. 8)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum