Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gcc] emerge -s system
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
bdouxx
Tux's lil' helper
Tux's lil' helper


Joined: 28 Dec 2009
Posts: 116

PostPosted: Sun Jan 22, 2012 4:29 pm    Post subject: [gcc] emerge -s system Reply with quote

salut

J'ai un petit truc que je ne comprend pas... J'ai installé il y a un moment gcc 4.5.3-r2 et 4.6.2

Code:
# eix -sve gcc
* sys-devel/gcc
     Available versions: 
        (2.95)  *2.95.3-r9 ~*2.95.3-r10!s
        (3.1)   *3.1.1-r2
        (3.2)   **3.2.2!s *3.2.3-r4
        (3.3)   ~3.3.6-r1!s
        (3.4)   3.4.6-r2!s
        (4.0)   ~*4.0.4!s
        (4.1)   4.1.2!s
        (4.2)   ~4.2.4-r1!s
        (4.3)   ~4.3.3-r2!s 4.3.4!s ~4.3.5!s ~4.3.6-r1!s
        (4.4)   ~4.4.2!s ~4.4.3-r3!s 4.4.4-r2!s 4.4.5!s ~4.4.6-r1!s
        (4.5)   (~)4.5.1-r1!s (~)4.5.2!s 4.5.3-r1!s (~)4.5.3-r2!s
        (4.6)   {M}**4.6.0!s {M}**4.6.1-r1!s {M}(**)4.6.2!s
        {altivec bootstrap boundschecking build cxx d doc fixed-point fortran gcj go graphite gtk hardened ip28 ip32r10k java libffi libssp lto mudflap multilib multislot n32 n64 nls nocxx nopie nossp nptl objc objc++ objc-gc openmp static test vanilla}                                                                     
     Installed versions:  Version: 4.5.3-r2(4.5)!s
                          Date:    20:22:12 14/12/2011
                          USE:     cxx fortran gcj gtk mudflap multilib nls nptl openmp -altivec -bootstrap -build -doc -fixed-point -graphite -hardened -libffi -libssp -lto -multislot -nocxx -nopie -nossp -objc -objc++ -objc-gc -test -vanilla                                                                               
                          Version: 4.6.2(4.6)!s
                          Date:    15:07:41 22/01/2012
                          USE:     cxx fortran gcj gtk mudflap multilib nls nptl openmp -altivec -bootstrap -build -doc -fixed-point -go -graphite -hardened -libffi -libssp -multislot -nocxx -nopie -nossp -objc -objc++ -objc-gc -test -vanilla                                                                               
     Best versions/slot:  3.4.6-r2(3.4)!s 4.1.2(4.1)!s 4.3.4(4.3)!s 4.4.5(4.4)!s (~)4.5.3-r2(4.5)!s {M}(**)4.6.2(4.6)!s
     Package sets:        system
     Homepage:            http://gcc.gnu.org/
     Description:         The GNU Compiler Collection
     License:             GPL-3 LGPL-3 || ( GPL-3 libgcc libstdc++ gcc-runtime-library-exception-3.1 ) FDL-1.2



le gcc actif est le 4.5.3
Code:
ordi_# gcc-config -l
 [1] x86_64-pc-linux-gnu-4.5.3 *
 [2] x86_64-pc-linux-gnu-4.6.2


pourtant quand je veux faire un emerge -e sytem, c'est le 4.6.2 qu'il veut recompiler
Code:
# emerge -pe system |grep gcc
[ebuild   R   ~] sys-devel/gcc-config-1.5-r2
[ebuild   R   #] sys-devel/gcc-4.6.2


Et cela ne me semble pas normal...
Back to top
View user's profile Send private message
guilc
Bodhisattva
Bodhisattva


Joined: 15 Nov 2003
Posts: 3326
Location: Paris - France

PostPosted: Sun Jan 22, 2012 4:39 pm    Post subject: Reply with quote

Cela me semble normal : le SET "system" ne précise pas de slot, donc portage prend ce qu'il trouve de plus récent, donc la 4.6. portage n'a que faire de savoir quelle est la version active !
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Tue Jan 24, 2012 1:11 pm    Post subject: Reply with quote

Tu dois faire ceci :

Code:

# gcc-config set 2
# gcc-config -l
# env-update && source /etc/profile


Si tu veux vraiment, tu peux tout recompiler, mais le choix final te reviens.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum