Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Network keeps on dropping constantly
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
johanpretorius
n00b
n00b


Joined: 20 May 2011
Posts: 4

PostPosted: Sat Jan 21, 2012 12:14 am    Post subject: Network keeps on dropping constantly Reply with quote

My network connection keeps on dropping constantly. I might sit whole day with no problem then I might have to every minute or so have to restart eth0.
There does not seem to be any pattern for the drop in connection.

lspci
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 661FX/M661FX/M661MX Host (rev 11)
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] SiS AGP Port (virtual PCI-to-PCI bridge)
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS964 [MuTIOL Media IO] (rev 36)
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev 01)
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] AC'97 Sound Controller (rev a0)
00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.2 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.3 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] SiS900 PCI Fast Ethernet (rev 91)
00:05.0 IDE interface: Silicon Integrated Systems [SiS] RAID bus controller 180 SATA/PATA [SiS] (rev 01)
00:0b.0 Multimedia audio controller: Creative Labs CA0106 Soundblaster
01:00.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5500] (rev a1)

lsmod
Module Size Used by
it87 17326 0
hwmon_vid 2304 1 it87
nvidia 7030971 24
gspca_spca561 7012 0
gspca_main 15149 1 gspca_spca561
videodev 69227 1 gspca_main
sis900 15365 0
mii 3047 1 sis900



Jan 21 01:50:03 localhost dhcpcd[3581]: version 5.2.12 starting
Jan 21 01:50:03 localhost dhcpcd[3581]: eth0: rebinding lease of 10.0.0.104
Jan 21 01:50:05 localhost kernel: [ 319.779103] eth0: Media Link On 100mbps full-duplex
Jan 21 01:50:06 localhost dhcpcd[3581]: eth0: acknowledged 10.0.0.104 from 10.0.0.2 `router'
Jan 21 01:50:06 localhost dhcpcd[3581]: eth0: checking for 10.0.0.104
Jan 21 01:50:11 localhost dhcpcd[3581]: eth0: leased 10.0.0.104 for 86400 seconds
Jan 21 01:50:11 localhost dhcpcd[3581]: forked to background, child pid 3606
Jan 21 01:50:12 localhost start-stop-daemon: pam_unix(start-stop-daemon:session): session opened for user nobody by (uid=0)
Jan 21 01:51:15 localhost kernel: [ 390.000039] eth0: Transmit timeout, status 00000005 00000000
Jan 21 01:51:23 localhost kernel: [ 398.000040] eth0: Transmit timeout, status 00000005 00000000
Jan 21 01:51:31 localhost kernel: [ 406.000067] eth0: Transmit timeout, status 00000005 00000000
Jan 21 01:51:39 localhost kernel: [ 414.000031] eth0: Transmit timeout, status 00000005 00000000
Jan 21 01:51:47 localhost kernel: [ 422.000038] eth0: Transmit timeout, status 00000005 00000000
Jan 21 01:51:55 localhost kernel: [ 430.000043] eth0: Transmit timeout, status 00000005 00000000
Jan 21 01:51:56 localhost dhcpcd[3606]: received SIGTERM, stopping
Jan 21 01:51:56 localhost dhcpcd[3606]: eth0: removing interface
Jan 21 01:51:57 localhost /etc/init.d/net.eth0[3963]: You are using a bash array for config_eth0.
Jan 21 01:51:57 localhost /etc/init.d/net.eth0[3964]: This feature will be removed in the future.
Jan 21 01:51:57 localhost /etc/init.d/net.eth0[3965]: Please see net.example for the correct format for config_eth0.
Jan 21 01:51:57 localhost dhcpcd[3976]: version 5.2.12 starting
Jan 21 01:51:57 localhost dhcpcd[3976]: eth0: rebinding lease of 10.0.0.104
Jan 21 01:51:59 localhost kernel: [ 433.485142] eth0: Media Link On 100mbps full-duplex
Jan 21 01:52:01 localhost dhcpcd[3976]: eth0: acknowledged 10.0.0.104 from 10.0.0.2 `router'
Jan 21 01:52:01 localhost dhcpcd[3976]: eth0: checking for 10.0.0.104
Jan 21 01:52:07 localhost dhcpcd[3976]: eth0: leased 10.0.0.104 for 86400 seconds
Jan 21 01:52:07 localhost dhcpcd[3976]: forked to background, child pid 4010
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2665
Location: Slovenia

PostPosted: Sat Jan 21, 2012 12:31 am    Post subject: Reply with quote

Wow, I'm not the only one who still has a SiS machine? That is just cool. Can't help you though, my SiS900 card works fine.

Edit: Ok, a google search did find something: Add acpi=ht to the kernel line in grub.conf. No idea if it'll actually work though. Other stuff to try: add irqpoll or pci=routeirq to the kernel line in grub.conf
Back to top
View user's profile Send private message
wjb
Guru
Guru


Joined: 10 Jul 2005
Posts: 446
Location: Fife, Scotland

PostPosted: Sat Jan 21, 2012 2:15 pm    Post subject: Reply with quote

Whats in your /etc/conf.d/net? - its just that the log is complaining about use of bash array for config_eth0. The format of the file changed last year sometime - baselayout2?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum