Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] X not working with GT440 graphics
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
LostInGentoo
Apprentice
Apprentice


Joined: 27 Jun 2002
Posts: 269
Location: Denmark

PostPosted: Mon Jan 16, 2012 9:56 pm    Post subject: [Solved] X not working with GT440 graphics Reply with quote

Hi

I can't get my Nvidia GT 440 (developed by ASUS) to run on my computer, however, the 2012 livedvd have no issues.

I've followed three different guides and compiled the kernel multiple times with these different settings and none seem to work. The error I get, when starting Xorg is:
Code:
X.Org X Server 1.11.2
Release Date: 2011-11-04
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.1.6-gentoo x86_64 Gentoo
Current Operating System: Linux dc7700p 3.1.6-gentoo #2 SMP Mon Jan 16 21:09:43 CET 2012 x86_64
Kernel command line: root=/dev/sda3 video=uvesafb:mtrr:3,ywrap,2560x1440-32@60
Build Date: 12 January 2012  03:47:50PM
 
Current version of pixman: 0.24.0
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Jan 16 21:16:50 2012
(++) Using config file: "xorg.conf.new"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
(EE) NVIDIA(0):     log file that the GLX module has been loaded in your X
(EE) NVIDIA(0):     server, and that the module is the NVIDIA GLX module.  If
(EE) NVIDIA(0):     you continue to encounter problems, Please try
(EE) NVIDIA(0):     reinstalling the NVIDIA driver.
Server terminated successfully (0). Closing log file.


Hope someone can pin point what I did wrong. The module called "nvidia" is loaded automatically.

I generated an xorg.config file with "X -configure" and also tried nvidia-xconfig. Both give the above error.
Withtout any config file the X-server is trying to load the nouveau, nv or vesa drivers (unsuccessfully).

What have I done wrong?

I'll add my kernel-configuration in the next post.


Regards
Preben


Last edited by LostInGentoo on Mon Jan 16, 2012 11:17 pm; edited 1 time in total
Back to top
View user's profile Send private message
LostInGentoo
Apprentice
Apprentice


Joined: 27 Jun 2002
Posts: 269
Location: Denmark

PostPosted: Mon Jan 16, 2012 10:05 pm    Post subject: Reply with quote

Configuration files and errors:

http://jobc.dk/nvidia/.config
http://jobc.dk/nvidia/xorg.conf.new
http://jobc.dk/nvidia/nvidia-Xorg-error.txt
Output from compilation of nvidia-drivers


Regards,
Preben
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2665
Location: Slovenia

PostPosted: Mon Jan 16, 2012 10:47 pm    Post subject: Reply with quote

Replace your xorg.conf with just these lines:
Code:
Section "Device"
    Identifier  "Nvidia Card"
    Driver      "nvidia"
EndSection

Also run "eselect opengl set nvidia" and check with "eselect opengl list" that it is actually set to nvidia.
Back to top
View user's profile Send private message
LostInGentoo
Apprentice
Apprentice


Joined: 27 Jun 2002
Posts: 269
Location: Denmark

PostPosted: Mon Jan 16, 2012 11:03 pm    Post subject: Reply with quote

Well, now the errors have changed:

Code:
(EE) Failed to load module "dri" (module does not exist, 0)
(EE) Failed to load module "dri2" (module does not exist, 0)
(EE) NVIDIA: Failed to load module "dri2" (module does not exist, 0)


Reading about this issue on the gentoo forums seems that people claim this should not be happening! What is the solution to this problem?


Regards,
Preben
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2665
Location: Slovenia

PostPosted: Mon Jan 16, 2012 11:09 pm    Post subject: Reply with quote

LostInGentoo wrote:
Reading about this issue on the gentoo forums seems that people claim this should not be happening!

Actually, this *should* be happening. Nvidia doesn't use dri. Is that the only thing, does X work now?
Back to top
View user's profile Send private message
LostInGentoo
Apprentice
Apprentice


Joined: 27 Jun 2002
Posts: 269
Location: Denmark

PostPosted: Mon Jan 16, 2012 11:11 pm    Post subject: Reply with quote

LostInGentoo wrote:
Reading about this issue on the gentoo forums seems that people claim this should not be happening! What is the solution to this problem?


Forgot to tell, that the solution suggested previously to write:
Code:
Section "Module"
    Disable        "dri"
    Disable        "dri2"
EndSection


does not work for me. It removes the two first error-lines but not the last one.
Back to top
View user's profile Send private message
LostInGentoo
Apprentice
Apprentice


Joined: 27 Jun 2002
Posts: 269
Location: Denmark

PostPosted: Mon Jan 16, 2012 11:17 pm    Post subject: Reply with quote

Hmm... gdm seems to work (even though the Xorg itself shows nothing - as far as I recall, I should get a mouse curser on an ugly gray background).

But gdm starts gnome and that seems to be enough ;-)

Thanks alot.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum