Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Ntp[solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
BrummieJim
l33t
l33t


Joined: 22 Jul 2005
Posts: 666

PostPosted: Sun Jan 15, 2012 11:11 pm    Post subject: Ntp[solved] Reply with quote

Hi,
I'm having a problem setting up NTP, when I start the service I get the following error,

/etc/init.d/ntpd start
| * Starting ntpd ...
ntpd |/usr/sbin/ntpd: The ``user'' option has been disabled -- built without --enable-clockctl or --enable-linuxcaps
ntpd |ntpd - NTP daemon program - Ver. 4.2.6p3
ntpd |USAGE: ntpd [ -<flag> [<val>] | --<name>[{=| }<val>] ]...
ntpd | * start-stop-daemon: failed to start `/usr/sbin/ntpd'
ntpd | * Failed to start ntpd [ !! ]
ntpd | * ERROR: ntpd failed to start


Any ideas why this is happening,
Jim


Last edited by BrummieJim on Mon Jan 16, 2012 11:41 pm; edited 1 time in total
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 15985

PostPosted: Sun Jan 15, 2012 11:13 pm    Post subject: Reply with quote

You used the user option in your configuration, but installed net-misc/ntp[-caps]. You should reinstall net-misc/ntp with USE=caps.
Back to top
View user's profile Send private message
BrummieJim
l33t
l33t


Joined: 22 Jul 2005
Posts: 666

PostPosted: Mon Jan 16, 2012 11:41 pm    Post subject: Reply with quote

Thanks very much, all fixed now!
James
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum