Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Conflict between xorg-server-1.11 and nVidia legacy drivers
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
depontius
Advocate
Advocate


Joined: 05 May 2004
Posts: 3456

PostPosted: Wed Jan 11, 2012 1:56 pm    Post subject: Conflict between xorg-server-1.11 and nVidia legacy drivers Reply with quote

I've had a problem showing up for the past bit, since xorg-server-1.11.x went stable on x86:
Code:
WARNING: One or more updates have been skipped due to a dependency conflict:

x11-base/xorg-server:0

  (x11-base/xorg-server-1.11.2-r2::gentoo, ebuild scheduled for merge) conflicts with
    <x11-base/xorg-server-1.11 required by (x11-drivers/nvidia-drivers-173.14.31::gentoo, installed)

I have a system that, though it has a new enough cart, an nVidia 7300GT, doesn't reliably run anything other than nvidia-drivers-173.x. It won't reliably run newer nvidia-drivers, and it won't reliably run nouveau. (Actually I haven't tried newer nvidia-drivers in some time, though I spent a lot of time trying, a year or two back. I tried nouveau just last week, staying up less than an hour or so.)

Maybe I need to try the newest stable nvidia-drivers, while masking xorg-server-1.11. But it's possible that it's going to be necessary to keep xorg-1.10 around as long as the legacy nvidia-drivers are around. This system is a bit of an odd duck, and old IBM M-Pro that uses Rambus. Getting video running on it has always been a bit dicey.
_________________
.sigs waste space and bandwidth
Back to top
View user's profile Send private message
dwbowyer
Apprentice
Apprentice


Joined: 18 Apr 2008
Posts: 154

PostPosted: Wed Jan 11, 2012 2:55 pm    Post subject: Reply with quote

I have an Nvidia 7300GS. I was stuck on the 173.x driver series for a while when 27x series was being stabilised. From 28x. onward, I haven't had any problems using mainline, but yes you might want to mask xorg-server until you are sure the driver work for you. BUT.. that means that you have to test <284.x (I think, verify in either gentoo or nvidia forums), more recent versions of the driver are ONLY for xorg > 1.10.

I'm on nvida-drivers-290.06 and Xorg-server-1.11.2-r2. The only issue is compiz won't run and that is actually a dbus <-> xorg <-> driver stack issue.
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2665
Location: Slovenia

PostPosted: Wed Jan 11, 2012 4:27 pm    Post subject: Reply with quote

dwbowyer wrote:
more recent versions of the driver are ONLY for xorg > 1.10.

Are you sure? I kinda find that hard to believe.
Back to top
View user's profile Send private message
dwbowyer
Apprentice
Apprentice


Joined: 18 Apr 2008
Posts: 154

PostPosted: Wed Jan 11, 2012 5:48 pm    Post subject: Reply with quote

Ok maybe I got it backwards. Misremembering things I thought I knew is my speciality. But I seem to recall trying to upgrade to xorg 1.11 and being told I couldn't when keeping a version of nvidia-drivers I had frozen in /etc/portage/package.mask.
from the change log wrote:
*nvidia-drivers-290.06 (04 Nov 2011)

04 Nov 2011; Doug Goldstein <cardoe@gentoo.org>
+nvidia-drivers-290.06.ebuild:
Version bump the latest beta drivers which provide xorg-server-1.11 support.

05 Oct 2011; Doug Goldstein <cardoe@gentoo.org>
nvidia-drivers-285.05.09.ebuild:
Due to a regression in X that requires a deprecated function to be copied
into the nvidia-drivers binary component, there is a significant performance
degradation with xorg-server-1.11. As a result I'm re-marking this release as
not supporting xorg-server-1.11. bug #385669

*nvidia-drivers-275.28 (14 Sep 2011)

14 Sep 2011; Doug Goldstein <cardoe@gentoo.org>
+nvidia-drivers-275.28.ebuild:
Add the extremely buggy 275.28 version which claims to have xorg-server-1.11
support to statisfy users desire for the latest and greatest, even if its
broken.


Which means if the driver don't upgrade, you don't get the xorg-server upgrade, which is all that matters to the OP. Why I remembered that latest drivers were exclusively for newer xorg, I can't say.
Back to top
View user's profile Send private message
evoweiss
Veteran
Veteran


Joined: 07 Sep 2003
Posts: 1678
Location: Edinburgh, UK

PostPosted: Wed Jan 11, 2012 9:14 pm    Post subject: Reply with quote

Hi all,

I'm stuck in this same dilemma as I have an older (FX5200) nVidia card and thus no ability to upgrade to the latest drivers (they don't work). I am thus stuck in the 173 series. Any idea if this is going to be fixed in Xorg? It seems odd to have such breakage after all this time.

Best,

Alex
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2665
Location: Slovenia

PostPosted: Wed Jan 11, 2012 9:33 pm    Post subject: Reply with quote

It's not for X to fix. Nvidia needs to release a new driver. And such breakage isn't new nor is it odd, it happens every time X bumps ABI. When they bump ABI, the X folks also update all open drivers, but they of course can't update a closed driver.
Back to top
View user's profile Send private message
dwbowyer
Apprentice
Apprentice


Joined: 18 Apr 2008
Posts: 154

PostPosted: Wed Jan 11, 2012 9:41 pm    Post subject: Reply with quote

Nvidia most likely will update legacy drivers for such ABI changes though, so long as they continue to support the legacy drivers. They just did the same for xorg-server-1.10 last July or so, according to x11-drivers/nvidia-drivers/Changelog. But the 96.x and 173.x legacy drivers will likely always lag behind the current series.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum