Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
XFCE4 - screenlock CTRL-ALT-DEL not working
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Joseph_sys
Advocate
Advocate


Joined: 08 Jun 2004
Posts: 2571
Location: Edmonton, AB

PostPosted: Wed Jan 11, 2012 3:56 am    Post subject: XFCE4 - screenlock CTRL-ALT-DEL not working Reply with quote

How is "screen-lock" link to CTRL-ALT-DEL in XFCE4
It is not working.
xscreensaver is running:
Code:
ps aux |grep xscreensaver
joseph    5030  0.0  0.0  58784  3352 ?        S    Jan09   0:04 xscreensaver -no-splash

$ xflock4 - working as well.
_________________
#Thelma
Back to top
View user's profile Send private message
Hypnos
Advocate
Advocate


Joined: 18 Jul 2002
Posts: 2889
Location: Omnipresent

PostPosted: Wed Jan 11, 2012 4:05 am    Post subject: Reply with quote

Your post is incomprehensible to me, so I don't think I can help until you rewrite it.

FWIW, screenlocking in XFCE4 works fine on my system. In Settings->Keyboard->Application Shortcuts I have XF86ScreenSaver mapped to xflock4, which then invokes xlock .
_________________
Personal overlay | Simple backup scheme
Back to top
View user's profile Send private message
Joseph_sys
Advocate
Advocate


Joined: 08 Jun 2004
Posts: 2571
Location: Edmonton, AB

PostPosted: Wed Jan 11, 2012 4:17 am    Post subject: Reply with quote

Hypnos wrote:
Your post is incomprehensible to me, so I don't think I can help until you rewrite it.

FWIW, screenlocking in XFCE4 works fine on my system. In Settings->Keyboard->Application Shortcuts I have XF86ScreenSaver mapped to xflock4, which then invokes xlock .


Well, what I mean to say is that when I press: CTRL-ALT-Delete the screen does not go into the lock mode.
Under:
Settings->Keyboard->Application Shortcuts
I do have it linked to:
xflock4 <Control><ALT>Delete
_________________
#Thelma
Back to top
View user's profile Send private message
Hypnos
Advocate
Advocate


Joined: 18 Jul 2002
Posts: 2889
Location: Omnipresent

PostPosted: Wed Jan 11, 2012 4:21 am    Post subject: Reply with quote

Can you try a different key combination just as a test? I wonder if ctl-alt-delete is being trapped by something else on your desktop.
_________________
Personal overlay | Simple backup scheme
Back to top
View user's profile Send private message
Joseph_sys
Advocate
Advocate


Joined: 08 Jun 2004
Posts: 2571
Location: Edmonton, AB

PostPosted: Wed Jan 11, 2012 4:41 am    Post subject: Reply with quote

Hypnos wrote:
Can you try a different key combination just as a test? I wonder if ctl-alt-delete is being trapped by something else on your desktop.


I've tried:
ctl-alt-backsspace
ctl-alt-esc
Nothing works. I restarted the xorg as well.
_________________
#Thelma
Back to top
View user's profile Send private message
Hypnos
Advocate
Advocate


Joined: 18 Jul 2002
Posts: 2889
Location: Omnipresent

PostPosted: Wed Jan 11, 2012 5:03 am    Post subject: Reply with quote

So the situation is:

1) If you return xflock4 from the commandline, it works

2) When setting up your keyboard shortcuts, "ctl-alt-delete" registers in the Shortcut field.

3) However, "ctl-alt-delete" does nothing when invoked from the root screen.

Since #2 works, X is recognizing the key combination (this can be verified with the utility xev). Thus, the only possibility I can think of is that something else is trapping the key combo.

If this is indeed the case, you have to hunt down whatever else is running on your root screen that has keyboard shortcuts. The obvious candidate is your window manager or something like compiz.
_________________
Personal overlay | Simple backup scheme
Back to top
View user's profile Send private message
Joseph_sys
Advocate
Advocate


Joined: 08 Jun 2004
Posts: 2571
Location: Edmonton, AB

PostPosted: Wed Jan 11, 2012 5:16 am    Post subject: Reply with quote

Yes, something is not as it suppose to.
I did reset it to default and did not add any shortcuts combinations.
_________________
#Thelma
Back to top
View user's profile Send private message
Hypnos
Advocate
Advocate


Joined: 18 Jul 2002
Posts: 2889
Location: Omnipresent

PostPosted: Wed Jan 11, 2012 5:21 am    Post subject: Reply with quote

I would go through the list of shortcuts in the window manager config, and then set the screenlock shortcut to something not on that list that is also very simple, e.g. "ctl-escape" (not "ctl-alt-escape").
_________________
Personal overlay | Simple backup scheme
Back to top
View user's profile Send private message
antpillage
n00b
n00b


Joined: 26 Jan 2012
Posts: 1

PostPosted: Thu Jan 26, 2012 6:09 pm    Post subject: Reply with quote

I had the same issue. To resolve it, I went to:

Applications Menu -> Settings -> Keyboard (Applications Shortcuts tab)

- reset key bindings to defaults
- manually configure xflock4 to ctrl+alt+l

and the key binding worked.

Note: ("l" is a lowercase L)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum