Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Disabling Wireless-N
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
cessman4life
Tux's lil' helper
Tux's lil' helper


Joined: 14 Apr 2005
Posts: 141

PostPosted: Thu Jan 05, 2012 4:59 pm    Post subject: Disabling Wireless-N Reply with quote

I was having problems connecting wirelessly with my laptop where there was either no connection or it was just ridiculously slow. By disabling wireless-N and leaving modes B/G enabled I have it working like a champ. The problem is I have to disable wireless-N everytime the machine reboots. Is there a startup script I can run to have it disabled on boot? I found out how to disable the driver from another post https://forums.gentoo.org/viewtopic-t-881681-start-0.html:

Code:

rmmod iwlagn
modprobe iwlagn 11n_disable=1
Back to top
View user's profile Send private message
Logicien
Veteran
Veteran


Joined: 16 Sep 2005
Posts: 1404
Location: Montréal

PostPosted: Thu Jan 05, 2012 5:54 pm    Post subject: Reply with quote

Hello,
you can, as example, create /etc/modprobe.d/iwlagn.conf and write in
Code:
options iwlagn 11n_disable=1

Then the option should be activated any time the module iwlagn is loaded. You can verify if the parameter is at 1 by
Code:
cat /sys/module/iwlagn/parameters/11n_disable

Note, if the iwlagn is compiled hard in the kernel, you need to pass at boot time to the kernel the parameter
Code:
iwlagn.11n_disable=1

If it is compiled as a module and you use an initrd, it can be needed to integrate the /etc/modprobe.d/iwlagn.conf file in the initrd if the module is loaded before the real root filesystem is accessed by the kernel.

Personnaly, I put all my modules parameters in /etc/modprobe.d/modprobe.conf who do not exist by default after Gentoo installation. I check if every module option I change from default already exist and his value with the command
Code:
modprobe -c | less

It is important that the same option with a different value do not overwrite my change. If it is, the files in /etc/modprobe.d/ need to be edited to remove the opposite option from the one I add. I have been force to use this option with one AGN wireless AP (Access Point). The bandwidth speed increased a lot after that. Most of the time for me, this option do not change anything else than disable 11n functionality.
_________________
Paul
Back to top
View user's profile Send private message
cessman4life
Tux's lil' helper
Tux's lil' helper


Joined: 14 Apr 2005
Posts: 141

PostPosted: Thu Jan 12, 2012 6:26 am    Post subject: Reply with quote

I tried that and

Code:
cat /sys/module/iwlagn/parameters/11n_disable

returns
Code:
0


instead of 1

When I reboot the wireless does not connect so I assume N is still enabled.
Back to top
View user's profile Send private message
cach0rr0
Bodhisattva
Bodhisattva


Joined: 13 Nov 2008
Posts: 4123
Location: Houston, Republic of Texas

PostPosted: Thu Jan 12, 2012 6:54 am    Post subject: Reply with quote

you might have to do the module parameter bit in /etc/conf.d/modules in order for it to persist on reboot
not sure if that (old?) path still works now that everything is baselayout-2/openrc
_________________
Lost configuring your system?
dump lspci -n here | see Pappy's guide | Link Stash
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum