Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]itself - gVim No valid fonts found
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
modsRule
n00b
n00b


Joined: 19 Oct 2009
Posts: 38
Location: Bucks, UK

PostPosted: Sun Nov 01, 2009 12:10 pm    Post subject: [SOLVED]itself - gVim No valid fonts found Reply with quote

I am unable to start gVim. Starting from KDE, the icon just bounces up and down then disappears, when I try to start it from the terminal (emulator) I get the following error message and vim starts instead.
Code:

   E665: Cannot start GUI, no valid font found
 Hit ENTER or type command to continue


Here is my /etc/fonts/local.conf
Code:

,?xml version="1.0"?>
 <!DOCTYPE fontconfig SYSTEM "fonts.dtd">
 <!-- /etc/fonts/local.conf file for local customizations -->
 <fontconfig>
 <!--
   Enable sub-pixel rendering
         <dir>/usr/share/fonts</dir>
        <match target="font">
                 <edit name="rgba" mode="assign"><const>rgb</const></edit>
         </match>
 -->
         <dir>/usr/share/fonts/corefonts/</dir>
         <dir>/usr/share/fonts/unifont/</dir>
         <dir>/usr/share/fonts/terminus/</dir>
         <dir>/usr/share/fonts/Type1/</dir>
         <dir>/usr/share/fonts/freefont/</dir>
         <dir>/usr/share/fonts/artwiz/</dir>
         <dir>/usr/share/fonts/local/</dir>
         <dir>/usr/share/fonts/misc/</dir>
         <dir>/usr/share/fonts/Speedo/</dir>
         <dir>/usr/share/fonts/CID/</dir>
         <dir>/usr/share/fonts/ttf-bitstream-vera/</dir>
         <dir>/usr/share/fonts/util/</dir>
         <dir>/usr/share/fonts/sharefont/</dir>
         <dir>/usr/share/fonts/lfp-fix/</dir>
         <dir>/usr/share/fonts/TTF/</dir>
         <dir>/usr/share/fonts/75dpi/</dir>
         <dir>/usr/share/fonts/100dpi/</dir>
         <dir>/usr/share/fonts/lfp-var/</dir>
         <dir>/usr/share/fonts/cyrillic/</dir>
         <dir>/usr/share/fonts/encodings/</dir>
         <dir>/usr/share/fonts/ukr/</dir>
 </fontconfig>


and appropriate part of Xorg.conf:
Code:

Section "Files"
        ModulePath   "/usr/lib64/xorg/modules"
        FontPath    "/usr/share/fonts/corefonts"
     FontPath    "/usr/share/fonts/terminus"
     FontPath    "/usr/share/fonts/unifont"
     FontPath    "/usr/share/fonts/Type1"
     FontPath    "/usr/share/fonts/freefont"
     FontPath    "/usr/share/fonts/artwiz"
     FontPath    "/usr/share/fonts/local"
     FontPath    "/usr/share/fonts/misc"
     FontPath    "/usr/share/fonts/Speedo"
     FontPath    "/usr/share/fonts/CID"
     FontPath    "/usr/share/fonts/ttf-bitstream-vera"
     FontPath    "/usr/share/fonts/util"
     FontPath    "/usr/share/fonts/75dpi:unscaled"
     FontPath    "/usr/share/fonts/100dpi:unscaled"
     FontPath    "/usr/share/fonts/lfp-fix"
     FontPath    "/usr/share/fonts/lfp-var"
     FontPath    "/usr/share/fonts/TTF"
     FontPath    "/usr/share/fonts/cyrillic"
     FontPath    "/usr/share/fonts/encodings"
     FontPath    "/usr/share/fonts/ukr"
     FontPath    "/usr/local/share/fonts"
     FontPath    "/usr/share/fonts"
     FontPath    "/usr/X11R6/lib/X11/fonts"
     FontPath    "/usr/share/fonts/baekmuk"
     FontPath    "/usr/share/fonts/sharefonts"
     FontPath    "/usr/share/fonts/ttf"
     FontPath    "/usr/X11R6/lib/X11/fonts/truetype"
EndSection


I have already tried the suggestions in this thread, to no success.

fc-cache runs without errrors.

gVim still does not work. Any suggestions appreciated (other than use emacs :) )


Last edited by modsRule on Thu Nov 12, 2009 10:52 pm; edited 1 time in total
Back to top
View user's profile Send private message
gigel
Guru
Guru


Joined: 14 Jan 2003
Posts: 369
Location: .se/.ro

PostPosted: Thu Nov 05, 2009 8:54 pm    Post subject: Reply with quote

remove ~/.viminfo
I've had some errors that god fixed with that. but I doubt your problem will be solved. but who knows :D
_________________
$emerge sux
:D
Back to top
View user's profile Send private message
modsRule
n00b
n00b


Joined: 19 Oct 2009
Posts: 38
Location: Bucks, UK

PostPosted: Thu Nov 05, 2009 9:36 pm    Post subject: Reply with quote

If only it was something that simple.

Unfortunately, that hasn't helped. Same error, still no idea, and neither apparently does any one else!
Back to top
View user's profile Send private message
modsRule
n00b
n00b


Joined: 19 Oct 2009
Posts: 38
Location: Bucks, UK

PostPosted: Thu Nov 12, 2009 10:52 pm    Post subject: Reply with quote

No idea on the cause of this, but having just done a re-emerge of gvim, all is now working.
Back to top
View user's profile Send private message
Cayennes
n00b
n00b


Joined: 01 Oct 2004
Posts: 33

PostPosted: Fri Dec 30, 2011 3:21 pm    Post subject: Reply with quote

For me, the problem was that gvim needed to be compiled with the gtk use flag.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum