Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
lxpolkit and polkit-gnome are blocking each other. (SOLVED)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Featherfoot
Veteran
Veteran


Joined: 28 Dec 2002
Posts: 1061
Location: Stuart, Florida

PostPosted: Tue Dec 20, 2011 9:09 pm    Post subject: lxpolkit and polkit-gnome are blocking each other. (SOLVED) Reply with quote

I am trying to clean up my system with

emerge --update --newuse --deep --with-bdeps=y @world

and I am having lxpolkit and polkit-gnome block each other and I don't know how to resolve it.


    bopper jc # emerge --update --newuse --deep --with-bdeps=y @world
    Calculating dependencies... done!
    [ebuild N ] lxde-base/lxpolkit-0.1.0
    [ebuild N ] gnome-extra/polkit-gnome-0.101-r1 USE="examples introspection -doc"
    [ebuild UD ] net-libs/libsoup-2.34.3 [2.36.1]
    [blocks B ] lxde-base/lxpolkit ("lxde-base/lxpolkit" is blocking gnome-extra/polkit-gnome-0.101-r1)
    [blocks B ] gnome-extra/polkit-gnome ("gnome-extra/polkit-gnome" is blocking lxde-base/lxpolkit-0.1.0)


I have tried to emerge the latest versions of the packages with no change:

    bopper jc # ACCEPT_KEYWORDS="~amd64" emerge lxpolkit polkit-gnome -p

    These are the packages that would be merged, in order:

    Calculating dependencies... done!
    [ebuild N ] lxde-base/lxpolkit-0.1.0-r1
    [ebuild N ] gnome-extra/polkit-gnome-0.105
    [blocks B ] gnome-extra/polkit-gnome ("gnome-extra/polkit-gnome" is blocking lxde-base/lxpolkit-0.1.0-r1)
    [blocks B ] lxde-base/lxpolkit ("lxde-base/lxpolkit" is blocking gnome-extra/polkit-gnome-0.105)

    * Error: The above package list contains packages which cannot be
    * installed at the same time on the same system.

    (gnome-extra/polkit-gnome-0.105::gentoo, ebuild scheduled for merge) pulled in by
    polkit-gnome

    (lxde-base/lxpolkit-0.1.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    lxpolkit


    For more information about Blocked Packages, please refer to the following
    section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

    http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked



Your help would be appreciated.


Last edited by Featherfoot on Fri Dec 23, 2011 2:15 pm; edited 1 time in total
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Wed Dec 21, 2011 2:08 pm    Post subject: Reply with quote

Hi, which WM are you using ?

Gnome, Lxde or Openbox ?

You cannot have both packages at the same time on your system(lxpolkit or polkit-gnome).
Back to top
View user's profile Send private message
Featherfoot
Veteran
Veteran


Joined: 28 Dec 2002
Posts: 1061
Location: Stuart, Florida

PostPosted: Wed Dec 21, 2011 4:32 pm    Post subject: Reply with quote

I normally run KDE, but gnome is in my system, too. Maybe I experimented with lxde, too.
Back to top
View user's profile Send private message
Featherfoot
Veteran
Veteran


Joined: 28 Dec 2002
Posts: 1061
Location: Stuart, Florida

PostPosted: Thu Dec 22, 2011 12:26 am    Post subject: Reply with quote

I should have said that I have several environments on my system. KDE, Gnome, XFCE 4, among others.
Back to top
View user's profile Send private message
derk
Guru
Guru


Joined: 10 Mar 2003
Posts: 347
Location: St Thomas Ontario

PostPosted: Thu Dec 22, 2011 12:38 am    Post subject: Reply with quote

as they are mutually exclusive ..one or the other is needed not both .. remove one or install only one and then upgrade
Back to top
View user's profile Send private message
Featherfoot
Veteran
Veteran


Joined: 28 Dec 2002
Posts: 1061
Location: Stuart, Florida

PostPosted: Thu Dec 22, 2011 12:47 am    Post subject: Reply with quote

LXDE is not on my system. Perhaps you could suggest something to remove that uses lxpolkit.
Back to top
View user's profile Send private message
derk
Guru
Guru


Joined: 10 Mar 2003
Posts: 347
Location: St Thomas Ontario

PostPosted: Thu Dec 22, 2011 1:11 am    Post subject: Reply with quote

if lxpolkit is installed do: (but from your original post it does not seem to be)
emerge -C lxpolkit

then just do:
emerge -1 polkit-gnome

only one is required but gnome .. prefers the latter
Back to top
View user's profile Send private message
Featherfoot
Veteran
Veteran


Joined: 28 Dec 2002
Posts: 1061
Location: Stuart, Florida

PostPosted: Thu Dec 22, 2011 9:48 pm    Post subject: Reply with quote

I did that, but I still have what appears to be some problems:

Portage is unhappy that lxpolkit is not in the system, and libsoup is alternating between wanting two different versions to be in the system.

As noted, LXDE is not in my system. I don't know what is pulling in lxpolkit.


    bopper etc # emerge --update --newuse --deep --with-bdeps=y @world
    Calculating dependencies... done!
    [ebuild N ] lxde-base/lxpolkit-0.1.0
    [ebuild U ~] net-libs/libsoup-2.36.1 [2.34.3] USE="samba%*"
    [blocks B ] lxde-base/lxpolkit ("lxde-base/lxpolkit" is blocking gnome-extra/polkit-gnome-0.101-r1)
    [blocks B ] gnome-extra/polkit-gnome ("gnome-extra/polkit-gnome" is blocking lxde-base/lxpolkit-0.1.0)

    !!! Multiple package instances within a single package slot have been pulled
    !!! into the dependency graph, resulting in a slot conflict:

    net-libs/libsoup:2.4

    (net-libs/libsoup-2.36.1::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

    (net-libs/libsoup-2.34.3::gentoo, installed) pulled in by
    ~net-libs/libsoup-2.34.3 required by (net-libs/libsoup-gnome-2.34.3::gentoo, installed)


    It may be possible to solve this problem by using package.mask to
    prevent one of those packages from being selected. However, it is also
    possible that conflicting dependencies exist such that they are
    impossible to satisfy simultaneously. If such a conflict exists in
    the dependencies of two different packages, then those packages can
    not be installed simultaneously. You may want to try a larger value of
    the --backtrack option, such as --backtrack=30, in order to see if
    that will solve this conflict automatically.

    For more information, see MASKED PACKAGES section in the emerge man
    page or refer to the Gentoo Handbook.

    bopper etc #
Back to top
View user's profile Send private message
derk
Guru
Guru


Joined: 10 Mar 2003
Posts: 347
Location: St Thomas Ontario

PostPosted: Fri Dec 23, 2011 5:01 am    Post subject: Reply with quote

mask off lxpolkit and do emerge -auDvN --keep-going world or do a revdep-rebuild first .. probably an installed program pulls in lxpolkit " due to history .. an older ebuild .. once the new ebuild is installed it will no-longer ask for lxpolkit " ..

You could try: equery depends lxpolkit
to find installs depending on it currently .. maybe you found a bug .. a non-converted ebuild
Back to top
View user's profile Send private message
SamuliSuominen
Retired Dev
Retired Dev


Joined: 30 Sep 2005
Posts: 2133
Location: Finland

PostPosted: Fri Dec 23, 2011 5:26 am    Post subject: Reply with quote

The only way such issues might come up if...

- Some version of GTK+ is masked in /etc/portage/package.mask
- Some version of polkit-gnome is masked in /etc/portage/package.mask

Or in stable system if...

- Not both of polkit-gnome and polkit are unkeyworded in package.keywords at the same time

Code:

# emerge -C polkit-gnome lxpolkit
# emerge -v ">=x11-libs/gtk+-3" ">=polkit-0.103" ">=polkit-gnome-0.105"
Back to top
View user's profile Send private message
Featherfoot
Veteran
Veteran


Joined: 28 Dec 2002
Posts: 1061
Location: Stuart, Florida

PostPosted: Fri Dec 23, 2011 2:15 pm    Post subject: Reply with quote

This is an odd result:


    bopper etc # equery depends lxpolkit
    * These packages depend on lxpolkit:
    sys-auth/polkit-0.103 (gtk ? lxde-base/lxpolkit)


Nevertheless, setting the ~amd64 keyword on polkit-gnome fixed the problem.

Thank you!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum