Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
problema unmask vlc
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
system-infet
n00b
n00b


Joined: 10 Sep 2010
Posts: 22

PostPosted: Mon Dec 19, 2011 11:00 am    Post subject: problema unmask vlc Reply with quote

salve a tutti , avrei un altro problema.. quando cerco di installare vlc mi dice che devo smascherare la libreria zlib e di usare l' opzione --autounmask-write io l' ho usata dando il comando: emerge --autounmask-write vlc ma mi dice che quest opzione non esiste quindi dove la devo mettere quest' opzione? ho cercato sia nella documentazione che su google ma non ho trovato niente.
Back to top
View user's profile Send private message
k01
Arch/Herd Tester
Arch/Herd Tester


Joined: 13 Feb 2008
Posts: 617
Location: Milano

PostPosted: Mon Dec 19, 2011 11:18 am    Post subject: Re: problema unmask vlc Reply with quote

innanzitutto bravo che hai capito che dovevi aprire un nuovo topic, quindi cancella la dicitura "altro problema" del vecchio topic e rimetti "Risolto". 1 topic -> 1 problema

emerge --help --verbose wrote:

--autounmask [ y | n ]
Automatically unmask packages and generate package.use
settings as necessary to satisfy dependencies. This option is
enabled by default. If any configuration changes are
required, then they will be displayed after the merge list
and emerge will immediately abort. If the displayed
configuration changes are satisfactory, you should copy and
paste them into the specified configuration file(s), or
enable the --autounmask-write option. The EMERGE_DEFAULT_OPTS
variable may be used to disable this option by default in
make.conf(5).

--autounmask-write [ y | n ]
If --autounmask is enabled, changes are written to config
files, respecting CONFIG_PROTECT and --ask.


quindi controlla di scrivere la sintassi corretta, perchè il comando esiste. ovviamente dopo autounmask-write devi dare etc-update per aggiornare i file in /etc/portage. inoltre considera anche le alternative di modificare a mano i file in /etc/portage oppure utilizzare il tool app-portage/autounmask
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Mon Dec 19, 2011 11:48 am    Post subject: Reply with quote

quindi comportati da vero eroe ed aggiungi a manina al file di configurazione la giusta riga, usando sed da linea di comando non vie facili come nano. :twisted:
Scherzi a parte è una delle poche cose che conviene fare manualmente, od almeno verificare bene quel che si fa e se è il caso di applicarsi.
Ad esempio se il pacchetto ha più slot potrebbe essere utile smascherare l'intero slot o tener conto della possibilità di successive revisioni.
esempio:
#base - autounmask
=categoria/pacchetto-versione ~arch
categoria/pacchetto ~arch
#per slot
categoria/pacchetto:slot ~arch
#fino ad una x versione
<categoria/pacchetto-versione ~arch
#comprendendo le revisioni (le -rx)
=categoria/pacchetto-versione(senza -r)* ~arch


Sempre per aggiungere, i pacchetti sono mascherati per una ragione. Può essere che semplicemente non siano stati verificati o che ci siano dei bug aperti.
Capisco che un crash di vlc non sia una cosa importante ma potrebbe avere ripercussioni anche in altre applicazioni.
Verifica il profilo, l'aggiornamento di portage e le use che hai attivato, poi se ci sono bug aperti per capire cosa comporta usare quel pacchetto instabile.

Già che ti chieda zlib instabile è strano.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
system-infet
n00b
n00b


Joined: 10 Sep 2010
Posts: 22

PostPosted: Mon Dec 19, 2011 2:38 pm    Post subject: Re: problema unmask vlc Reply with quote

ho sistemato il vecchio topic :) , il comando c' è ho studiato la sintassi e ho dato:

Code:
emerge --autounmask-write zlib


e sembra che lo installi ma quando dopo ho cercato di installare vlc mi da sempre lo stesso errore:

Code:
[ebuild  N     ] media-video/vlc-1.1.12-r2  USE="X a52 aac alsa cdda dbus dts dvd ffmpeg flac gcrypt libnotify mmx mp3 mpeg ncurses ogg opengl png qt4 sdl sse svg truetype udev vorbis x264 xcb xml xv -aalib (-altivec) -atmo -avahi -bidi -cddb -dc1394 -debug -dirac -directfb -dvb -fbcon -fluidsynth -fontconfig -ggi -gme -gnome -gnutls -httpd -id3tag -ieee1394 -jack -kate -kde -libass -libcaca -libproxy -libtiger -libv4l -libv4l2 -lirc -live -lua -matroska -modplug -mtp -musepack -nsplugin -optimisememory -oss -projectm -pulseaudio -pvr -remoteosd -rtsp -run-as-root -samba -schroedinger -sdl-image -shine -shout -skins -speex -sqlite -stream (-svga) -taglib -theora -twolame -upnp -v4l -vaapi -vcdx -vlm (-win32codecs) -wma-fixed -xosd -zvbi"

The following USE changes are necessary to proceed:
#required by media-video/vlc-1.1.12-r2, required by vlc (argument)
>=sys-libs/zlib-1.2.5.1-r2 minizip

Use --autounmask-write to write changes to config files (honoring CONFIG_PROTECT).


djinnZ ho provato ad inserire sys-libs/zlib ~ amd64 nel file /etc/portage/package.unmask ma da lo stesso errore
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Mon Dec 19, 2011 5:06 pm    Post subject: Re: problema unmask vlc Reply with quote

system-infet wrote:

Code:
emerge --autounmask-write zlib


Questo funziona (ti installa zlib), ma è concettualmente sbagliato perchè aggiunge zlib al world file, cioè ai pacchetti che tu esplicitamente vuoi che siano installati, mentre, al contrario, è una dipendenza di vlc. Niente di grave, intendiamoci, ma alla lunga rischi di sporcarti (e parecchio) il sistema.
La soluzione è, ad esempio, utilizzare l'opzione -1 di emerge quando si emergono delle dipendenze. Per riparare (senza re-installare) basta
Code:
# emerge --deselect sys-libs/zlib


system-infet wrote:
mi da sempre lo stesso errore:
[ebuild N ] media-video/vlc-1.1.12-r2 USE="X a52 aac alsa cdda dbus dts dvd ffmpeg flac gcrypt libnotify mmx mp3 mpeg ncurses ogg opengl png qt4 sdl sse svg truetype udev vorbis x264 xcb xml xv -aalib (-altivec) -atmo -avahi -bidi -cddb -dc1394 -debug -dirac -directfb -dvb -fbcon -fluidsynth -fontconfig -ggi -gme -gnome -gnutls -httpd -id3tag -ieee1394 -jack -kate -kde -libass -libcaca -libproxy -libtiger -libv4l -libv4l2 -lirc -live -lua -matroska -modplug -mtp -musepack -nsplugin -optimisememory -oss -projectm -pulseaudio -pvr -remoteosd -rtsp -run-as-root -samba -schroedinger -sdl-image -shine -shout -skins -speex -sqlite -stream (-svga) -taglib -theora -twolame -upnp -v4l -vaapi -vcdx -vlm (-win32codecs) -wma-fixed -xosd -zvbi"

The following USE changes are necessary to proceed:
#required by media-video/vlc-1.1.12-r2, required by vlc (argument)
>=sys-libs/zlib-1.2.5.1-r2 minizip


leggi bene, devi aggiustare le USE di zlib, non smascherarlo.
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
system-infet
n00b
n00b


Joined: 10 Sep 2010
Posts: 22

PostPosted: Mon Dec 19, 2011 6:40 pm    Post subject: Reply with quote

grazie :) dovevo solo aggiungere minizip al file /etc/make.profile/make.defaults :) però ora c' è un errore che non riesco a capire:

Code:
 * Messages for package gnome-base/librsvg-2.34.2:

 * ERROR: gnome-base/librsvg-2.34.2 failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of 'emerge --info =gnome-base/librsvg-2.34.2',
 * the complete build log and the output of 'emerge -pqv =gnome-base/librsvg-2.34.2'.
 * The complete build log is located at '/var/tmp/portage/gnome-base/librsvg-2.34.2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/gnome-base/librsvg-2.34.2/temp/environment'.
 * S: '/var/tmp/portage/gnome-base/librsvg-2.34.2/work/librsvg-2.34.2'
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Mon Dec 19, 2011 7:32 pm    Post subject: Reply with quote

system-infet wrote:
aggiungere minizip al file /etc/make.profile/make.defaults
leggi il manuale, questa è una cavolata pazzesca
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
Massimog
Apprentice
Apprentice


Joined: 04 Nov 2011
Posts: 151
Location: Osimo(AN)

PostPosted: Mon Dec 19, 2011 11:19 pm    Post subject: Reply with quote

devi dare da root
Code:
echo ">=sys-libs/zlib-1.2.5.1-r2 minizip " >> /etc/portage/package.use
se la directory portage non c'è la devi creare
leggi il manuale
Back to top
View user's profile Send private message
Massimog
Apprentice
Apprentice


Joined: 04 Nov 2011
Posts: 151
Location: Osimo(AN)

PostPosted: Mon Dec 19, 2011 11:25 pm    Post subject: Reply with quote

system-infet wrote:
grazie :) dovevo solo aggiungere minizip al file /etc/make.profile/make.defaults :) però ora c' è un errore che non riesco a capire:

Code:
 * Messages for package gnome-base/librsvg-2.34.2:

 * ERROR: gnome-base/librsvg-2.34.2 failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of 'emerge --info =gnome-base/librsvg-2.34.2',
 * the complete build log and the output of 'emerge -pqv =gnome-base/librsvg-2.34.2'.
 * The complete build log is located at '/var/tmp/portage/gnome-base/librsvg-2.34.2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/gnome-base/librsvg-2.34.2/temp/environment'.
 * S: '/var/tmp/portage/gnome-base/librsvg-2.34.2/work/librsvg-2.34.2'


se posti i log forse qualcosa si capisce :roll:
Back to top
View user's profile Send private message
system-infet
n00b
n00b


Joined: 10 Sep 2010
Posts: 22

PostPosted: Tue Dec 20, 2011 10:34 am    Post subject: Reply with quote

ora ho risolto tutto il problema era che usavo il branch unstable e c' era un bug nella libreria quindi ho modificato il make.conf e mi sono messo sul branch stable togliendo il segno ~ prima di amd64 e ho dato emerge -avuDN world e poi ho dato emerge --depclean ed è tutto ok :)
grazie a tutti :)
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Tue Dec 20, 2011 10:57 am    Post subject: Reply with quote

8O ti consiglio per il futuro di ponderare meglio le tue scelte e di non procedere a casaccio.
Hai fatto tutte le cose che non vanno fatte: albero instabile, smascherare senza ritegno, modificare il profilo, passaggio da albero instabile a stabile etc.
Segno che non hai letto la documentazione attentamente e sistematicamente.
Per inciso ti è andata bene ma il passaggio da ~amd64 a amd64 non è una cosa da fare perchè implica un downgrade delle librerie principali.
Citando un vecchio vecchio film "hai più Qlo che anima". :lol:

In generale (invito a riflettere per tutti) quando si smaschera una libreria oltre alle verifiche già dette per bug e problemi è una buona idea lanciare un qdepends -Q e verificare se le librerie od i pacchetti critici richiedo anche loro il passaggio alla branca instabile (casomai provando a ricompilarli, non necessariamente installarli ma ricompilarli).
Nel caso specifico zlib è una dipendenza di roba come qt-core, kdelibs, glib, ssh etc. Non è una cosa da prendere alla leggera, si rischia di bloccare il sistema.

Sempre nel caso specifico di zlib non mi pare che ci sono problemi gravi noti ma... l'ultima riga della mia "firma" dovrebbe esser chiara. :wink:
Meglio perdere un'oretta a verificare che passare un paio di giorni d'angoscia pregando che qualcuno sul forum od in chat sappia indirizzarvi al recupero del sistema (o doverlo ricostruire ex novo). Uomo avvisato... :twisted: Ricordate che ogni watt che sprecate va in fumo nell'atmosfera ... etc.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
system-infet
n00b
n00b


Joined: 10 Sep 2010
Posts: 22

PostPosted: Tue Dec 20, 2011 12:52 pm    Post subject: Reply with quote

djinnZ il mio Qlo pultroppo è finito :( dovrò reinstallare tutto da capo perche ho fatto danni ricompilando il kernel per mettere alsa :( comunque in quest installazione leggerò bene la documentazione e non vi disturberò più con domande stupide e non farò sciocchezze :).
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Tue Dec 20, 2011 1:16 pm    Post subject: Reply with quote

guarda che stai continuando. Non devi reinstallare perchè il kernel è andato a donnine allegre, solo ricompilare il kernel (da chroot).

Anche se non so quanto possa essere affidabile una installazione che ha subito un downgrade radicale quindi non fai male.

Procedi passo per passo, sistematicamente.

E non è questione di fare domande stupide ma scelte poco ragionevoli e non riflettere su quello che si legge. Cerca di capire bene quali sono le implicazioni prima di fare una cosa.
Se poi non capisci chiedi.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Tue Dec 20, 2011 1:48 pm    Post subject: Reply with quote

aggiungo la mia:

non è questione di domande stupide o non stupide, è questione di fare le cose come vanno fatte o meno. Gentoo è bella, buona e cara, ma se inizi a paciugare dove e come non è pensato rischi di ritrovarti a piedi.
Rimarco il consiglio di djinnZ: leggi bene e cerca di capire prima di fare. Se non si è capito un argomento domandare non è mai stupido.
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum