Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Another day, Another compile error with KDE
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
FizzyWidget
Veteran
Veteran


Joined: 21 Nov 2008
Posts: 1133
Location: 127.0.0.1

PostPosted: Fri Dec 16, 2011 9:52 am    Post subject: Another day, Another compile error with KDE Reply with quote

Today i'm mostly getting this one:


Code:
-- Performing Test _OFFT_IS_64BIT
-- Performing Test _OFFT_IS_64BIT - Success
-- Performing Test HAVE_FPIE_SUPPORT
-- Performing Test HAVE_FPIE_SUPPORT - Success
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL - Success
-- Performing Test __KDE_HAVE_GCC_VISIBILITY
-- Performing Test __KDE_HAVE_GCC_VISIBILITY - Success
-- Found KDE 4.7 include dir: /usr/include
-- Found KDE 4.7 library dir: /usr/lib64
-- Found the KDE4 kconfig_compiler preprocessor: /usr/bin/kconfig_compiler
-- Found automoc4: /usr/bin/automoc4
CMake Error at cmake/modules/FindPolkitQt-1.cmake:53 (message):
  PolkitQt-1 version 0.103.0 was found, but it is too old.  Please install
  0.98.1 or newer.
Call Stack (most recent call first):
  CMakeLists.txt:19 (find_package)


-- Configuring incomplete, errors occurred!
 * ERROR: kde-misc/polkit-kde-kcmodules-0.98_pre20101127 failed (configure phase):
 *   cmake failed
 *
 * Call stack:
 *     ebuild.sh, line   75:  Called src_configure
 *   environment, line 3748:  Called kde4-base_src_configure
 *   environment, line 2896:  Called cmake-utils_src_configure
 *   environment, line 1078:  Called _execute_optionaly 'src_configure'
 *   environment, line  496:  Called enable_cmake-utils_src_configure
 *   environment, line 1419:  Called die
 * The specific snippet of code:
 *       "${CMAKE_BINARY}" "${cmakeargs[@]}" "${CMAKE_USE_DIR}" || die "cmake failed";


Which is strange why is it saying the newest version is too old? Does a dev need to update an ebuild somewhere - simple work a round for now is to mask the new version and downgrade :/
_________________
I know 43 ways to kill with a SKITTLE, so taste my rainbow bitch.
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4547

PostPosted: Fri Dec 16, 2011 11:59 am    Post subject: Reply with quote

The error is inside the FindPolkitQt-1.cmake shipped by the polkit-kde-kcmodules-package. They simply do string-compare "0.98.1" and "0.103.0" - the last string is less then the first string.
This should be reported upstream and at bugs.gentoo.org (they probably could patch this, untl there is a new release).
To get things compiled, you should mask the latest version of polkit-qt.
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4547

PostPosted: Fri Dec 16, 2011 2:03 pm    Post subject: Reply with quote

There is already a bug opened in bugs.gentoo.org, including a patch:
https://bugs.gentoo.org/show_bug.cgi?id=394921
(I did not try the patch)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum