Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Wondershaper help
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
Akaihiryuu
l33t
l33t


Joined: 08 May 2003
Posts: 751
Location: Columbus, OH

PostPosted: Sat Mar 31, 2012 2:55 am    Post subject: Wondershaper help Reply with quote

Ok, for some bizarre reason tonight, Wondershaper started absolutely destroying my network performance, to the point where internet is pretty much unuseable when it's enabled. I have no idea what's going on...I've been using it for years without any issues. Nothing's changed in my settings...I've been on the same ISP with the same bandwidth for 4 years now.

I've been looking at the statistics, but until tonight I never had any need to look at them so I don't know if any of this is out of the ordinary or not. (This is after approximately 5 minutes of being on.)

Code:
triforce ~ # tc -s qdisc show dev eth1
qdisc htb 1: root refcnt 2 r2q 10 default 20 direct_packets_stat 0
 Sent 3432126 bytes 8220 pkt (dropped 0, overlimits 1456 requeues 0)
 backlog 0b 0p requeues 0
qdisc sfq 10: parent 1:10 limit 127p quantum 1514b perturb 10sec
 Sent 185592 bytes 3263 pkt (dropped 0, overlimits 0 requeues 0)
 backlog 0b 0p requeues 0
qdisc sfq 20: parent 1:20 limit 127p quantum 1514b perturb 10sec
 Sent 3233364 bytes 4930 pkt (dropped 0, overlimits 0 requeues 0)
 backlog 0b 0p requeues 0
qdisc sfq 30: parent 1:30 limit 127p quantum 1514b perturb 10sec
 Sent 13170 bytes 27 pkt (dropped 0, overlimits 0 requeues 0)
 backlog 0b 0p requeues 0
qdisc ingress ffff: parent ffff:fff1 ----------------
 Sent 5556202 bytes 17588 pkt (dropped 287, overlimits 0 requeues 0)
 backlog 0b 0p requeues 0


If anyone is curious here are my settings. But like I said, nothing has changed for 4 years. Does anyone have any idea what the problem could be? Or better yet, an alternative? I played around with the uplink and downlink speeds when I first set it up to fine tune it - but once again nothing's changed. I confirmed with a speed test that my download speeds are about 10% higher than what I have listed in downlink.

EDIT: I temporarily worked around the problem by commenting out the last part in the script (that's using ingress policing). So it appears the ingress policing is what's causing the problem. But I don't understand why it never did before. I suppose I can live without ingress...downloads have never caused me an issue. I started using wondershaper because my ISP gives me extremely slow upload speeds relative to my download.

Code:
DOWNLINK=18432
UPLINK=691
DEV=eth1

# low priority OUTGOING traffic - you can leave this blank if you want
# low priority source netmasks
NOPRIOHOSTSRC=

# low priority destination netmasks
NOPRIOHOSTDST=

# low priority source ports
NOPRIOPORTSRC='1069 8008 8443 8888'

# low priority destination ports
NOPRIOPORTDST='80 443'
Back to top
View user's profile Send private message
PaulBredbury
Watchman
Watchman


Joined: 14 Jul 2005
Posts: 7310

PostPosted: Sat Mar 31, 2012 9:12 am    Post subject: Reply with quote

Here's an alternative.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum