Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] delayed logout xfce4. lxpolkit segf. dbus probl
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
salmonix
Guru
Guru


Joined: 16 Jul 2006
Posts: 410

PostPosted: Tue Dec 13, 2011 8:34 am    Post subject: [SOLVED] delayed logout xfce4. lxpolkit segf. dbus probl Reply with quote

Hi there,
I have the symptoms described at https://forums.gentoo.org/viewtopic-t-885662-start-0.html unresolved post though *kits configured matching https://forums.gentoo.org/viewtopic-t-858965-postdays-0-postorder-asc-start-0.html - at my best...

In short: at logout I have the logout window delayed and responsiveness suffers penalty. I can only log out, but can not reboot or halt. Trying the latters I am prompted to enter a password but that is always rejected. I can not suspend or hybernate.

note: I tried emerging xfce4-session USE='-consolekit' at least 'solved' the stall at logout but not the logout-reboot button problem. now consolekit is back. .
Checking out messages I caught
Quote:
Dec 13 10:16:37 [kernel] [ 1701.463891] lxpolkit[3288]: segfault at 7f7f962c83d0 ip 00007f7f951fb10d sp 00007fffddaa35a0 error 4 in libc-2.13.so[7f7f95185000+181000]


Replacing lxpolkit with polkit-gnome the segfault message is gone. Now a different comes when trying to log out.
Quote:

Dec 13 10:28:37 [sudo] pam_unix(sudo:auth): conversation failed
Dec 13 10:28:37 [sudo] pam_unix(sudo:auth): auth could not identify password for [salmonix]
Dec 13 10:28:37 [sudo] salmonix : pam_authenticate: Conversation error ; TTY=unknown ; PWD=/home/salmonix ; USER=root ; COMMAND=/usr/lib64/xfce4/session/xfsm-shutdown-helper
Dec 13 10:31:30 [dbus] [system] Activating service name='org.freedesktop.UPower' (using servicehelper)
Dec 13 10:31:30 [dbus] [system] Activated service 'org.freedesktop.UPower' failed: Failed to execute program /usr/libexec/dbus-daemon-launch-helper: Success
Dec 13 10:31:30 [console-kit-daemon] CRITICAL: polkit_authority_check_authorization: assertion `POLKIT_IS_AUTHORITY (authority)' failed_
Dec 13 10:31:59 [sudo] salmonix : user NOT authorized on host ; TTY=unknown ; PWD=/home/salmonix ; USER=root ; COMMAND=/usr/lib64/xfce4/session/xfsm-shutdown-helper


ck-list-session says:
Quote:
Session4:
unix-user = '1001'
realname = '(null)'
seat = 'Seat1'
session-type = ''
active = TRUE
x11-display = ':0.0'
x11-display-device = '/dev/tty7'
display-device = ''
remote-host-name = ''
is-local = TRUE
on-since = '2011-12-13T09:11:08.803421Z'
login-session-id = '7'
Session3:
unix-user = '1001'
realname = '(null)'
seat = 'Seat3'
session-type = ''
active = FALSE
x11-display = ':0.0'
x11-display-device = ''
display-device = ''
remote-host-name = ''
is-local = TRUE
on-since = '2011-12-13T09:11:07.556133Z'
login-session-id = '7'


I also have problem with automounting pendrive etc., perhaps related to this problem. upower -d is complaining:
Quote:
Dec 13 10:45:37 [dbus] [system] Activating service name='org.freedesktop.UPower' (using servicehelper)
Dec 13 10:45:37 [dbus] [system] Activated service 'org.freedesktop.UPower' failed: Failed to execute program /usr/libexec/dbus-daemon-launch-helper: Success

and at inserting a pendrive kernel recognizes it but
Quote:
Dec 13 10:49:46 [dbus] [system] Activating service name='org.freedesktop.UDisks' (using servicehelper)
Dec 13 10:49:46 [dbus] [system] Activated service 'org.freedesktop.UDisks' failed: Failed to execute program /usr/libexec/dbus-daemon-launch-helper: Success





Here my faint knowledge is exhausted - I do not have a really clear picture about the pam-*kit-dbus system to navigate further. More, for me this combo is a kind of mess with different syntaxes and all. So, till the shiny day it is cleared up I lean on others advise.

Thanx!
_________________
Quis custodiet ipsos, custodes?


Last edited by salmonix on Tue Dec 13, 2011 12:13 pm; edited 4 times in total
Back to top
View user's profile Send private message
salmonix
Guru
Guru


Joined: 16 Jul 2006
Posts: 410

PostPosted: Tue Dec 13, 2011 10:00 am    Post subject: Reply with quote

News.
I followed https://forums.gentoo.org/viewtopic-t-905296.html Hypnos advise and included polkit in USE flag list and also
-policykit.

However, the main problem - delayed logout, no reboot-halt function - has remained.

Quote:
Dec 13 13:09:13 [dbus] [system] Activating service name='org.freedesktop.UPower' (using servicehelper)
Dec 13 13:09:13 [dbus] [system] Activated service 'org.freedesktop.UPower' failed: Failed to execute program /usr/libexec/dbus-daemon-launch-helper: Success

_________________
Quis custodiet ipsos, custodes?
Back to top
View user's profile Send private message
salmonix
Guru
Guru


Joined: 16 Jul 2006
Posts: 410

PostPosted: Tue Dec 13, 2011 12:12 pm    Post subject: Reply with quote

Ok then.
The solution was simply to change the permission of /usr/libexec/dbus-daemon-launch-helper too+x.

All runs fine - pendrive automount, suspend, no delay...
_________________
Quis custodiet ipsos, custodes?
Back to top
View user's profile Send private message
rawdata
n00b
n00b


Joined: 01 Jul 2012
Posts: 1

PostPosted: Sun Jul 01, 2012 8:13 pm    Post subject: Reply with quote

salmonix wrote:
Ok then.
The solution was simply to change the permission of /usr/libexec/dbus-daemon-launch-helper too+x.

All runs fine - pendrive automount, suspend, no delay...


Thank you, salmonix. This fixed my problems too.
Back to top
View user's profile Send private message
SamuliSuominen
Retired Dev
Retired Dev


Joined: 30 Sep 2005
Posts: 2133
Location: Finland

PostPosted: Mon Jul 02, 2012 7:54 am    Post subject: Reply with quote

salmonix wrote:
Ok then.
The solution was simply to change the permission of /usr/libexec/dbus-daemon-launch-helper too+x.

All runs fine - pendrive automount, suspend, no delay...


Never do that, unless you want everyone on your system to be allowed to gain root. As in, that is same as intentionally inserting a vulnerability to your own machine.

The solution is to recompile pkgs like dev-libs/dbus-glib after dev-libs/glib upgrade (as noted by elog in the end of glib emerge)
Propably 'emerge -e sys-apps/dbus dev-libs/dbus-glib' will do the trick if nothing else does
Back to top
View user's profile Send private message
PF4Public
Tux's lil' helper
Tux's lil' helper


Joined: 28 Jan 2019
Posts: 75

PostPosted: Fri Jun 19, 2020 7:20 pm    Post subject: Reply with quote

For anyone coming here from search:
A proper and easier way of fixing this would be to chown this helper to be owned by root:messagebus
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum