Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] [Gnome 3.2] No Japanese input in GTK apps
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
WvR
Apprentice
Apprentice


Joined: 03 Mar 2011
Posts: 189
Location: Tsuruga, Japan

PostPosted: Thu Dec 08, 2011 5:53 am    Post subject: [solved] [Gnome 3.2] No Japanese input in GTK apps Reply with quote

I just took the plunge and updated my computer to Gnome 3.2. It seems that everything went fine. I have a very annoying problem which really baffles me at the moment. I use UIM + Anthy to switch between standard "latin" input and Japanese input. This has always worked fine in the past. I can switch with the "hankaku / zenkaku" button on my keyboard. At any cursor, UIM gives a little icon to indicate which input is selected.

Since the update, I cannot switch to Japanese in certain applications! HELP!

Firefox: works as before, i.e. there is the UIM icon, and I can switch, input Japanese, convert with space-bar, OK!
LibreOffice: works as before
PyBliographer: works as before

BUT.... Gedit, gnome-terminal, and nautilus give no UIM icon, and no Japanese input. Since Firefox etc are OK, it seems that the error is specific to "gnome3" applications.

I have tried to set in ~/.xprofile:

Code:

GTK_IM_MODULE=uim; export GTK_IM_MODULE
QT_IM_MODULE=uim; export QT_IM_MODULE
XMODIFIERS=@im=uim; export XMODIFIERS

LANG="ja_JP.UTF-8"
LANGUAGE="ja_JP.UTF-8"


I have recompiled UIM, but to no avail.

Desktop is Japanese, i.e. all menus etc are correctly displayed in Japanese. Nautilus correctly displays folder names in Japanese (e.g. デスクトップ) This tells me that the fonts etc are OK. But still no Japanese input in gnome3 apps. Google and gentoo forums give no clues as to what might be wrong. Any advice is welcome!


Last edited by WvR on Thu Dec 08, 2011 11:30 pm; edited 1 time in total
Back to top
View user's profile Send private message
WvR
Apprentice
Apprentice


Joined: 03 Mar 2011
Posts: 189
Location: Tsuruga, Japan

PostPosted: Thu Dec 08, 2011 6:07 am    Post subject: Reply with quote

UPDATE

I just emerge'd SciTE, a light-weight text editor. That editor works OK with the Japanese input. But the Gnome 3.2 apps still have no Japanese input.

I am contemplating the wisdom of

Code:

emerge -e gedit


to see if it will help. But 372 packages is a lot to rebuild....
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Thu Dec 08, 2011 11:55 am    Post subject: Reply with quote

Does uim have a gtk3 input module (like i.e. >=ibus-1.3.9-r2 have) ?
Back to top
View user's profile Send private message
WvR
Apprentice
Apprentice


Joined: 03 Mar 2011
Posts: 189
Location: Tsuruga, Japan

PostPosted: Thu Dec 08, 2011 12:36 pm    Post subject: Reply with quote

VoidMage wrote:
Does uim have a gtk3 input module (like i.e. >=ibus-1.3.9-r2 have) ?


Can you explain a bit more? What is a "gtk3 input module", and how can I find out how it works? Googling on "uim input module" gives no relevant answers.
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Thu Dec 08, 2011 2:10 pm    Post subject: Reply with quote

Well, i.e. ibus installs (among other):
Code:
/usr/lib/gtk-2.0/2.10.0/immodules/im-ibus.so
/usr/lib/gtk-3.0/3.0.0/immodules/im-ibus.so

As gtk2 and gtk3 are independent, both are needed, even if only one is used by any given app at a time.
Back to top
View user's profile Send private message
WvR
Apprentice
Apprentice


Joined: 03 Mar 2011
Posts: 189
Location: Tsuruga, Japan

PostPosted: Thu Dec 08, 2011 11:29 pm    Post subject: Reply with quote

The solution turned out the be the following. First, unmask the ~amd64 versions of uim and anthy:

Code:

echo "app-i18n/anthy ~amd64" >> /etc/portage/package.keywords
echo "app-i18n/uim ~amd64" >> /etc/portage/package.keywords


Then set the "gtk3" USE-flag, either in /etc/make.conf, or in /etc/portage/package.use (I have it in the /etc/make.conf). Then:

Code:

emerge -v uim anthy


It may be interesting to add this info to http://gnome.gentoo.org/howtos/gnome-3.2-upgrade.xml
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum