Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[UNSOLVED]how to config tftp ?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Maadiah
n00b
n00b


Joined: 23 May 2011
Posts: 64

PostPosted: Sun Dec 04, 2011 6:12 am    Post subject: [UNSOLVED]how to config tftp ? Reply with quote

Code:
maadiah@localhost ~ $ sudo /etc/init.d/in.tftpd start
 * Caching service dependencies ...                                       [ ok ]
 * Starting tftpd ...                                                     [ !! ]
 * ERROR: in.tftpd failed to start


my /etc/conf.d/in.tftpd file:
Code:
  1 # /etc/init.d/in.tftpd
  2
  3 # Path to server files from
  4 # Depending on your application you may have to change this.
  5 # This is commented out to force you to look at the file!
  6 #INTFTPD_PATH="/var/tftp/"
  7 #INTFTPD_PATH="/tftpboot/"
  8 INTFTPD_PATH="/tftproot/"
  9
 10 # For more options, see in.tftpd(8)
 11 # -R 4096:32767 solves problems with ARC firmware, and obsoletes
 12 # the /proc/sys/net/ipv4/ip_local_port_range hack.
 13 # -s causes $INTFTPD_PATH to be the root of the TFTP tree.
 14 # -l is passed by the init script in addition to these options.
 15 INTFTPD_OPTS="-R 4096:32767 -l -c -s ${INTFTPD_PATH} --ipv4 -a 192.168.0.101:69"


Code:
maadiah@localhost ~ $ sudo /etc/init.d/xinetd restart
 * Caching service dependencies ...                                       [ ok ]
 * Stopping xinetd ...                                                    [ ok ]
 * Bringing up interface eth0
 *   dhcp ...
 *     Running dhcpcd ...
dhcpcd[25111]: dhcpcd already running on pid 2125 (/var/run/dhcpcd.pid)   [ !! ]
 * ERROR: net.eth0 failed to start
 * Starting xinetd ...                                                    [ ok ]

_________________
the world is just the projection of you
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 46339
Location: 56N 3W

PostPosted: Sun Dec 04, 2011 1:47 pm    Post subject: Reply with quote

Maadiah,

Code:
# /etc/init.d/in.tftpd

# Path to server files from
# Depending on your application you may have to change this.
# This is commented out to force you to look at the file!
#INTFTPD_PATH="/var/tftp/"
#INTFTPD_PATH="/tftpboot/"
#INTFTPD_PATH="/tftproot/"
INTFTPD_PATH="/var/mediaplayer/boot/"


# For more options, see in.tftpd(8)
# -R 4096:32767 solves problems with ARC firmware, and obsoletes
# the /proc/sys/net/ipv4/ip_local_port_range hack.
# -s causes $INTFTPD_PATH to be the root of the TFTP tree.
# -l is passed by the init script in addition to these options.
INTFTPD_OPTS="-R 4096:32767 -s ${INTFTPD_PATH}"


works for me. I don't use xinetd. This is just used to boot a diskless media player box from the media server. Both are on my protected network, so xinitd isn't requied.
Is your eth0 supposed to start?
If not, by defualt, Gentoo will consider networking is not up and no servers that depend on the network will start.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Maadiah
n00b
n00b


Joined: 23 May 2011
Posts: 64

PostPosted: Mon Dec 05, 2011 1:08 am    Post subject: Reply with quote

well , when there is a bash script under my /etc/init.d/ : net.eth0

i got this :
Code:
maadiah@localhost ~ $ sudo /etc/init.d/in.tftpd start
Password:
 * Bringing up interface eth0
 *   dhcp ...
 *     Running dhcpcd ...
dhcpcd[2910]: dhcpcd already running on pid 2123 (/var/run/dhcpcd.pid)    [ !! ]
 * ERROR: net.eth0 failed to start
 * ERROR: cannot start in.tftpd as net.eth0 would not start


and i think my eth0 works well:
Code:
maadiah@localhost ~ $ sudo ifconfig
eth0      Link encap:Ethernet  HWaddr 70:5a:b6:03:32:8f 
          inet addr:192.168.1.100  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::725a:b6ff:fe03:328f/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:48 errors:0 dropped:0 overruns:0 frame:0
          TX packets:24 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:7719 (7.5 KiB)  TX bytes:2302 (2.2 KiB)
          Interrupt:16


my Q is why it starts in.tftpd as net.eth0? Can i make it start as another one? [sorry for my pool english, if y dont understand :( ]
_________________
the world is just the projection of you
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 46339
Location: 56N 3W

PostPosted: Mon Dec 05, 2011 7:23 pm    Post subject: Reply with quote

Maadiah,

Please post your /etc/conf.d/net file
Something thinks that eth0 is not started, then it fails when it tries to restart it.

There is a dirty hack.
In the file /etc/rc.conf set
Code:
#rc_depend_strict="YES"
to
Code:
rc_depend_strict="NO"


Thats not a fix. It just tells Gentoo that networking is up, if any interface is up, so services that need the network will start even if only net.lo is up.
Its hiding the problem, not fixing it.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Maadiah
n00b
n00b


Joined: 23 May 2011
Posts: 64

PostPosted: Tue Dec 06, 2011 3:21 am    Post subject: Reply with quote

thank u.
Code:
maadiah@localhost ~ $ cat /etc/conf.d/net
# This blank configuration will automatically use DHCP for any net.*
# scripts in /etc/init.d.  To create a more complete configuration,
# please review /usr/share/doc/openrc/net.example and save your configuration
# in /etc/conf.d/net (this file :]!).



modules=("dhcpcd")



modules=("iwconfig")
key_ESSID1="[1] s:dota1 key [1] enc open"
preferred_aps=("ESSID1")
config_eth0=("dhcp")
dhcpcd_eth0="-t 10"
dhcpcd_eth0="release nodns nontp nopnis"

_________________
the world is just the projection of you
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 46339
Location: 56N 3W

PostPosted: Tue Dec 06, 2011 5:12 pm    Post subject: Reply with quote

Maadiah,

What do you require of your network?

You have two interfaces eth0 and wlan0. Default Gentoo behaviour is to require all interface to be up before networking is considered up.
On a laptop that is sometimes wired, sometimes wireless and sometimes without an external network connection, this behaviour is not what you want. Hence the setting in my last post.

How do you want your network to woek ?

The modules setting is not cumulative. If you want to set it in two goes you need to take care of it yourself. So
Code:
modules=("dhcpcd")
modules=("iwconfig")
doesn't do what you think it does.

You get dhcpcd by defualt anywy, so it need not be included in a modules= statement.

You are using the old baselayout1 syntax in your net file. Its still tolerated but it will break when support is removed.
Look at /usr/share/doc/openrc-0.9.4/net.example.bz2 to the new synatax.
This is not the cause of your tftp problem.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum