Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
BCM4318 e ssb_sprom
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
VeLuca93
n00b
n00b


Joined: 09 Jun 2010
Posts: 17

PostPosted: Tue Nov 29, 2011 11:34 pm    Post subject: BCM4318 e ssb_sprom Reply with quote

Ciao a tutti, ho un problema piuttosto incomprensibile con una scheda wireless che non vuole saperne di funzionare (non appare nemmeno tra le interfacce)

dmesg riporta questo:

[ 1.362979] b43-pci-bridge 0000:02:00.0: PCI INT A -> GSI 21 (level, low) -> IRQ 21
[ 1.380720] ssb: Failed to switch to core 0
[ 1.380779] ssb: Failed to register PCI version of SSB with error -19
[ 1.380838] b43-pci-bridge 0000:02:00.0: PCI INT A disabled


quando provo rmmod ssb; modprobe b43 ottengo

[ 8720.399500] b43-pci-bridge 0000:02:00.0: PCI INT A -> GSI 21 (level, low) -> IRQ 21
[ 8720.416150] ssb: PCI-ID not in fallback list
[ 8720.416172] ssb: CHIPID not in nrcores fallback list
[ 8720.416183] ssb: Core 0 found: UNKNOWN (cc 0x8FF, rev 0x7F, vendor 0xFFFF)
[ 8720.436317] ssb: WARNING: Using fallback SPROM failed (err -2)
[ 8720.436325] ssb: WARNING: Invalid SPROM CRC (corrupt SPROM)
[ 8720.436332] ssb: Unsupported SPROM revision 255 detected. Will extract v1
[ 8720.456137] ssb: Sonics Silicon Backplane found on PCI device 0000:02:00.0


Ho già provato a sovrascrivere l'SPROM con una trovata in rete che dovrebbe corrispondere a quella scheda, ma tutto ciò che ottengo è un "Invalid argument"

Avete qualche idea?
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Wed Nov 30, 2011 10:19 am    Post subject: Re: BCM4318 e ssb_sprom Reply with quote

VeLuca93 wrote:
Ho già provato a sovrascrivere l'SPROM con una trovata in rete che dovrebbe 8O :?: corrispondere a quella scheda, ma tutto ciò che ottengo è un "Invalid argument"
:? :twisted:
Smontala e verifica su un altro OS se funziona ancora. Pregare mi pare inutile ma, qualora fossi ancora ancorato a queste antiche superstizioni fallo.
Riportare
Code:
[quote="lspci -kvvnns xx:xx.x"]incollare l'output qui[/quote]
non è una idea malvagia (come correggere il tuo post), quando si riporta qualcosa in generale è bene farlo (la scelta tra il tag code e quote è un'altra questione ma mi sono stancato di ripetere) con dovizia di particolari, senza eccedere (si tagliano le parti inutili ed usando i tag. :wink:
Altri tip per capire che bestia è li ho già riportati di recente e non li ripeto.
A naso mi pare che stai tentando di usare un dispositivo "blacklisted".
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
VeLuca93
n00b
n00b


Joined: 09 Jun 2010
Posts: 17

PostPosted: Wed Nov 30, 2011 11:58 am    Post subject: Re: BCM4318 e ssb_sprom Reply with quote

djinnZ wrote:
VeLuca93 wrote:
Ho già provato a sovrascrivere l'SPROM con una trovata in rete che dovrebbe 8O :?: corrispondere a quella scheda, ma tutto ciò che ottengo è un "Invalid argument"
:? :twisted:
Smontala e verifica su un altro OS se funziona ancora. Pregare mi pare inutile ma, qualora fossi ancora ancorato a queste antiche superstizioni fallo.
[…]
A naso mi pare che stai tentando di usare un dispositivo "blacklisted".

effettivamente ieri sera avevo dimenticato di dire che 24 ore fa la scheda funzionava perfettamente sullo stesso sistema e ha iniziato a non funzionare dopo un kernel panic, inoltre a seguito di questo l'SPROM risultava essere FF...FF (255 F), solo a seguito di ciò ho tentato di flasharla senza successo
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Wed Nov 30, 2011 2:55 pm    Post subject: Re: BCM4318 e ssb_sprom Reply with quote

VeLuca93 wrote:
24 ore fa la scheda funzionava perfettamente
8O ... ma ...:twisted:
Per quel poco che mi è dato di sapere puoi solo procedere alle esequie ( 'ndàmonneézz' ) prova a chiedere sul forum internazionale se conoscono soluzioni o (ho perso il link e non mi va di cercare sul forum) c'era una volta un forum (nella squallida ed odiosa lingua degli sporchi ed incivili abitanti della perfida albione, pourtroppo) per le riparazioni "faidate".
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum