Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Serbian Cyrillic in LibreOffice [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
while true
Guru
Guru


Joined: 07 Apr 2010
Posts: 509
Location: Ljubljana, Slovenia

PostPosted: Wed Nov 23, 2011 6:33 pm    Post subject: Serbian Cyrillic in LibreOffice [SOLVED] Reply with quote

Hello, newbie here
(I could not decide where to post my question, if I am in wrong section, ... well, sorry admins)

I have just emerged libreoffice, and also emerged like 30 fonts, among them some cyrillic.
I tried all fonts in Libreoffice, but none did write in cyrillic...

I haven't used cyrillic in OO, but now I want to be able to type in cyrillic
Serbian cyrillic precisely.

I want to be able to write cyrillic in Libre office, how to?

I searched uncle google, but I guess I can nto search right, closest was this:
http://user.services.openoffice.org/en/forum/viewtopic.php?f=5&t=29739
but, I do not have desktop, I have ratpoison VM, and I try to do as much as I can in console.

Now, I know I can set keyboard in .ratpoisonrc file
(I did English and Slovenian, not yet cyrillic,
I do not know what would be the right syntax for cyrillic
[I know russian, but that is not same cyrillic as Srebian], now I have:
Code:
# american keyboard layot
#exec setxkbmap us
# slovenian keyboard layot
exec setxkbmap si

) but that requires to restart ratpoison, which than puts all frames on first workplace...

Thank you
_________________
Kind regards, Goran Mitic

alive
while true
kick ass


Last edited by while true on Sat Nov 26, 2011 10:08 pm; edited 2 times in total
Back to top
View user's profile Send private message
tclover
Guru
Guru


Joined: 10 Apr 2011
Posts: 516

PostPosted: Wed Nov 23, 2011 7:45 pm    Post subject: Reply with quote

I guess you have to set up locale and keymap in cyrillic to begin with and then, you could type in cyrillic. You could follow gentoo-wiki.com https://wiki.archlinux.org if need be. You should take care of font, especially for terminal which could be a nightmare if you don't have a cyrillic compatible font (try media-fonts/terminus-font). Console related font/keymap/dumpkeys settings can be found in `/etc/conf.d/keymaps'. To generate the right locales, set what fit you in `/etc/locale.gen' with your cyrillic locale, and then generate the right locales with `locale' command.
_________________
home/:mkinitramfs-ll/:supervision/:e-gtk-theme/:overlay/
Back to top
View user's profile Send private message
while true
Guru
Guru


Joined: 07 Apr 2010
Posts: 509
Location: Ljubljana, Slovenia

PostPosted: Wed Nov 23, 2011 11:52 pm    Post subject: Reply with quote

oi tclover,

ok, I looked (I must admit, I do not understand arch link) but I have english set in /etc/conf.d/keymaps
Code:
keymap="us"

and I would like it to stay that way, but will give it a try to set it to Serbian, but maybe I'll try first for locale /etc/locale.gen I looked, I have nothing set, but looked at suggested list and I can try following:
Code:
sr_ME UTF-8
sr_RS UTF-8
sr_RS@latin UTF-8


I do not understand yours:"...and then generate the right locales with `locale' command."

I guess this is like eselect thingy, but can you guide me how to do that?

Thank you
_________________
Kind regards, Goran Mitic

alive
while true
kick ass
Back to top
View user's profile Send private message
tclover
Guru
Guru


Joined: 10 Apr 2011
Posts: 516

PostPosted: Thu Nov 24, 2011 12:05 pm    Post subject: Reply with quote

That's just means... run `locale-gen` to generate the locales. You may need to read gentoo UTF8 guide at www.gentoo.org as well, there are valuable info in that guide. You should know that as it's written in `/etc/locale.gen' comments.

EDIT: Anyway, I'm not sure if you can type cyrillic character with a US keymap... so you mean you have a US keyboard and want to type in cyrillic or you have a Serbian keyboard and want to be able to type in cyrillic? That's a bit different because some keyboard do not have characters related to a locale keyboard. Typically you can type ISO-8859-1 characters with a US keyboard. Now, with a keymap and/or dumpkeys_charset change in `/etc/conf.d/keymaps', you can do a few things. However, you have to have a font to be able to display those characters. Typically, you'll have to choose a unicode font and dumpkeys_charset for that.
Maybe you should begin reading gentoo UT8 guide and follos the comments in `/etc/conf.d/keymaps'.
_________________
home/:mkinitramfs-ll/:supervision/:e-gtk-theme/:overlay/
Back to top
View user's profile Send private message
while true
Guru
Guru


Joined: 07 Apr 2010
Posts: 509
Location: Ljubljana, Slovenia

PostPosted: Thu Nov 24, 2011 12:39 pm    Post subject: Reply with quote

oi tclover,

ok, so I found
http://www.gentoo.org/doc/en/utf-8.xml
and I knew from before
http://www.gentoo.org/doc/en/guide-localization.xml

so I guess I will have to read a bit more and try to understand this font thingy...

I have a lapotop, that has slovenian keyboard layout,
and comming from the same great mother, JUGOSLAVIA,
manufactures put all of ours wierd letters on keyboard, like: š đ ž ć č,
although Slovene has no đ ć in its alphabeth, but Croatian, Bosnian, Serbian does.

Also, I do have set english for command line (after boot, it is qwerty layout, with no above mentioned letters),
but as I start WM ratpoison, it issues a command "exec setxkbmap si" that makes slovene qwertz keyboard layout.

Further more, as I plug in external keyboard (compact-small english layout - I love it)
it has qwerty layout, while my laptop integrated keyboard keeps slovenian qwertz layout.

Also, I believe I do have installed cyrillic fonts, I used porthole to find cyrillic fonts, and I installed most of them (I did not installed mongolian for instance)

anyway, I guess I have to read and understand a bit more about those fonts, as I said.

Thanks for pointing me into that direction.

Kind regards


EDIT:
Workaround, and really bloby one.
I installed back gnome, and there I can use gui to change keyboard layout.

Small price to pay to be able to write in mother language...
shamefully enough, I do not write in cyrillic much, but hey...
_________________
Kind regards, Goran Mitic

alive
while true
kick ass
Back to top
View user's profile Send private message
tclover
Guru
Guru


Joined: 10 Apr 2011
Posts: 516

PostPosted: Fri Nov 25, 2011 4:04 pm    Post subject: Reply with quote

while true wrote:
EDIT:
Workaround, and really bloby one.
I installed back gnome, and there I can use gui to change keyboard layout.

Small price to pay to be able to write in mother language...
shamefully enough, I do not write in cyrillic much, but hey...

Hey, you don't need any gui to change keyboard layouts! You could use `x11-apps/setxkbmap' for example for that with your light setup. I did not quite follow that you wanted to be able to change easily keyboard layout because I thought you were busy to set up Cyrillic/Serbian locales and possibly fonts with UTF-8 to be able to display/write such characters. As I did not ever tried that, I've just pointed out the direction.

Now, for keyboard layout you have far better options than installing gnome for that. The above applications will let you change layout running `setxkbmpa us` for example in a terminal for a US layout. If you want a gui application for that, just look for one! You'll be better off gnome to just be able to change keyboard layouts!
_________________
home/:mkinitramfs-ll/:supervision/:e-gtk-theme/:overlay/
Back to top
View user's profile Send private message
M
Guru
Guru


Joined: 12 Dec 2006
Posts: 432

PostPosted: Fri Nov 25, 2011 5:33 pm    Post subject: Reply with quote

Hi while true, you have a post about that on gentoo serbia forums http://gentoo-srbija.org/forumi/desktop-okruzenja/xorg-konfiguraci-srpskih-rasporeda-tastera . Post describes how one can configure xorg to switch between layouts.
Back to top
View user's profile Send private message
while true
Guru
Guru


Joined: 07 Apr 2010
Posts: 509
Location: Ljubljana, Slovenia

PostPosted: Sat Nov 26, 2011 10:08 pm    Post subject: Reply with quote

M, there is gentoo site in Serbia...?!?!
I must be living in a cave... what is that big yellow circle above on blue background?

I tried that suggestion, but no go...
I also joined gentoo Serbia site, and posted a reply, hopefully I will get a response.

For now, I unmerged gnome,
tclover thanks, now I use setxkbmap rs,
but I have to be careful,
since after changing to cyrillic,
xterm is useless, so I issue commands:
Code:
setxkbmap us
setxkbmap rs

so I can use "up" key to get' setxkbmap us' and execute it.

Thanks again, will change [WORKAROUND] to [SOLVED]
_________________
Kind regards, Goran Mitic

alive
while true
kick ass
Back to top
View user's profile Send private message
tclover
Guru
Guru


Joined: 10 Apr 2011
Posts: 516

PostPosted: Sun Nov 27, 2011 2:55 am    Post subject: Reply with quote

while true wrote:
For now, I unmerged gnome,
tclover thanks, now I use setxkbmap rs,
but I have to be careful,
since after changing to cyrillic,
xterm is useless, so I issue commands:
Code:
setxkbmap us
setxkbmap rs

so I can use "up" key to get' setxkbmap us' and execute it.

Thanks again, will change [WORKAROUND] to [SOLVED]

That old X server options is no good anymore, there're many threads with weird keyboard behaviour with that thing. I had to remove option similar to that as well...
You could use uXTerm, the unicode wrapper for unicode support else try rxvt-unicode. I'm running a full UTF-8 compatible settings with XTerm and URXvt without any issue with a somewhat ios-8859-16 keymaps... So you could get everything worjing with XTerm. And I don't use uXTerm to get UTF-8 support.
_________________
home/:mkinitramfs-ll/:supervision/:e-gtk-theme/:overlay/
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum