Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Ati fglrx question
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
ffpp
n00b
n00b


Joined: 20 Jun 2005
Posts: 59
Location: Tatabánya, Hungary

PostPosted: Mon Nov 21, 2011 7:17 pm    Post subject: Ati fglrx question Reply with quote

Heya,

I am trying to get my box working with the propretiary driver. (HD4850)

I have made a clean install (amd64), and emerged ati-drivers. When I try to start X I got some wierd messages about missing dri. I have read all the tutorials and faqs about fglrx but it seems I missed something really important. What is it? :(

All ideas are welcome....
_________________
jAzz
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 46313
Location: 56N 3W

PostPosted: Mon Nov 21, 2011 8:13 pm    Post subject: Reply with quote

ffpp,

The binary blob driver does all its own thing, the kernel and Xorg proveded DRI is not used.
Its untidy, but nor important.

You can tell xorg to not attempt to laod the DRI modules if it really annoys you.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
ffpp
n00b
n00b


Joined: 20 Jun 2005
Posts: 59
Location: Tatabánya, Hungary

PostPosted: Tue Nov 22, 2011 12:08 pm    Post subject: Reply with quote

Hey,

it is not about annoying me, xorg just won't start. :) That is my problem.

btw how can I tell xorg not to use DRI modules?
_________________
jAzz
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 46313
Location: 56N 3W

PostPosted: Tue Nov 22, 2011 6:31 pm    Post subject: Reply with quote

ffpp,

Please post your /var/log/Xorg.0.log file so we can see why Xorg won't start.
wgetpaste is your friend.

Code:
emerge wgetpaste
wgetpaste /var/log/Xorg.0.log
and tell us the URL you get.

You may as well post your xorg.conf file too, since you must use one to invoke the binary blob driver.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum