Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Auto-load nvidia-settings? [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6347
Location: /usr/lib64/lv2

PostPosted: Tue Nov 15, 2011 1:47 am    Post subject: Auto-load nvidia-settings? [SOLVED] Reply with quote

How can I get my settings from nvidia-settings to take effect when I log into Xfce? My settings are retained somewhere because when I open nvidia-settings, it's the way I last set it, but those settings don't take effect until I run nvidia-settings (in other words, my screen brightens up the way I set nvidia-settings to do so but only when running nvidia-settings for the first time per session).
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.


Last edited by audiodef on Tue Nov 15, 2011 7:02 pm; edited 1 time in total
Back to top
View user's profile Send private message
PaulBredbury
Watchman
Watchman


Joined: 14 Jul 2005
Posts: 7310

PostPosted: Tue Nov 15, 2011 3:19 am    Post subject: Reply with quote

Create a startup script using XFCE's control panel, and add:
Code:
/usr/bin/nvidia-settings --load-config-only


For the brightness, I use in an initscript (i.e. run as root):
Code:
echo 5 > /sys/class/backlight/acpi_video0/brightness
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6347
Location: /usr/lib64/lv2

PostPosted: Tue Nov 15, 2011 7:02 pm    Post subject: Reply with quote

Perfect, thanks. :)
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.
Back to top
View user's profile Send private message
PaulBredbury
Watchman
Watchman


Joined: 14 Jul 2005
Posts: 7310

PostPosted: Sat Jun 09, 2012 12:27 am    Post subject: Reply with quote

My upgrade from kernel 3.3.x to 3.4.1 has somehow removed /sys/class/backlight/acpi_video0/ , so a quick alternative is to run as a normal user, within X:

Code:
nvidia-settings -a RedBrightness=-0.4 -a GreenBrightness=-0.4 -a BlueBrightness=-0.4 > /dev/null


Edit: For /sys/class/backlight/acpi_video0/, I need acpi_backlight=legacy
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum