Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO]TL-WN722N usb wifi (TP-LINK) non vede rete di casa
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Kernel78
Moderator
Moderator


Joined: 24 Jun 2005
Posts: 3652

PostPosted: Mon Nov 14, 2011 12:54 pm    Post subject: Reply with quote

[Modalità moderatore=ON]
Porca di quella zerba ragazzi ...
è ovvio che siete come l'olio e l'acqua, semplicemente non legate.

Io non sono Salomone e non pretendo di essere infallibile ma sono un moderatore
e il mio compito è quello di moderare anche se mi mortifica dover intervenire:

@djinnZ capisco che possa infastidirti il comportamento di un altro utente ma questo non giustifica il tono delle tue risposte ...
[Modalità moderatore=off]

Per favore non fatemi più intervenire, non ho problemi a spostare nel cestino thread spam ma a tirare le orecchie ad utenti che conosco da tempo mi crea problemi ...
_________________
Le tre grandi virtù di un programmatore: pigrizia, impazienza e arroganza. (Larry Wall).
Prima di postare un file togli i commenti con
Code:
grep -vE '(^[[:space:]]*($|(#|!|;|//)))'
Back to top
View user's profile Send private message
tornadomig
Tux's lil' helper
Tux's lil' helper


Joined: 22 Oct 2011
Posts: 116
Location: Torino

PostPosted: Sat Nov 19, 2011 8:57 pm    Post subject: Reply with quote

Code:
grep -i firmware /usr/src/linux/.config

CONFIG_PREVENT_FIRMWARE_BUILD=y
CONFIG_FIRMWARE_IN_KERNEL=y
CONFIG_EXTRA_FIRMWARE=""
CONFIG_HOSTAP_FIRMWARE=y
CONFIG_HOSTAP_FIRMWARE_NVRAM=y
CONFIG_RT2X00_LIB_FIRMWARE=y
CONFIG_FIRMWARE_EDID=y
# Firmware Drivers
CONFIG_FIRMWARE_MEMMAP=y
# CONFIG_GOOGLE_FIRMWARE is not set


allora, vediamo di ricapitolare...questa cosa non mi e' chiara e il dispositivo usb TL-WN722N non vuol funzionare proprio con la mia sola rete casalinga.

adesso ho aggiornato il kernel e ho il 3.1.1. l'ho ottenuto con genkernel. ho messo i moduli per questo adattatore, funziona tutto e ringrazio djiinz e fbcyborg per il loro supporto e la loro pazienza.

in /lib64/firmware vi e' il firmware htc_9271.fw ed e' quello aggiornato.

uso wicd che vede ora tutti i circostanti networks e la mia eth0 wired interface ma manca sempre la mia homenetwork. con iwconfig -a ottengo wlan0 e non ho altri dispositivi in uso per il wifi su questo pc. con tail -0f /var/log/messages il dispositivo viene riconosciuto e non ci sono segni di errori.

potete aiutarmi? grazie!


Last edited by tornadomig on Sun Nov 20, 2011 8:38 pm; edited 1 time in total
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Sun Nov 20, 2011 1:33 pm    Post subject: Reply with quote

tornadomig wrote:
CONFIG_EXTRA_FIRMWARE=""
Se vuoi che sia incluso nel kernel devi sempre valorizzarlo. Quindi genkernel --menuconfig ed aggiungi il path completo del file firmware che ti interessa (o se ti è più comodo puoi anche editare direttamente il file di configurazione).
Se usi l'immagine devi aggiungerlo nella conf di genkernel. Per far le cose per bene. Rimetti a posto.

Ti tipeto che per riportare è meglio
Code:
[code="comando dato"]quello che riporta[/code]
riedita il tuo messaggio.

Finite le amenità: se vedi le altre wifi vuol dire che il driver funziona quindi il problema è nella tua rete.
Sei sicuro che sia regolata su parametri compatibili (frequenze e modalità) con le impostazioni della tua scheda? Non è che stai tentando di connetterti in modalità 802.11b su un nrouter che opera solo in 802.11g o viceversa?
Le impostazioni nazionali dell'ap e della scheda determinano quali frequenze sono accettabili e quali no, se hai sull'ap o sulla schda US alcune frequenze sono ignorate perchè quello che è lecito in europa non lo è negli stati uniti e viceversa.
Sei sicuro che l'AP non è configurato ad SSID nascosto? Capisco che è utile, alle volte, per evitare che tutti i bimbiminkia windozziani dei dintorni si accalchino a cercare di entrare sulla tua rete piuttosto che sulla loro ingolfando i log di hostapd (l'unico motivo serio, benchè discutibile, per ricorrere a questo ridicolo espediente) ma non è un buon motivo per mantenerlo. Alcuni router vengono preconfigurati così dai codittetti "tecnici" delle compagnie telefoniche.
Entra nella configurazione del router e verifica.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Sun Nov 20, 2011 1:38 pm    Post subject: Reply with quote

Ha risolto, grazie all'aiuto mio e di Apetrini su gentoo-it.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered


Last edited by fbcyborg on Sun Nov 20, 2011 2:29 pm; edited 3 times in total
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Sun Nov 20, 2011 2:14 pm    Post subject: Reply with quote

@tornadomig: C'è un motivo per cui simili firmware vanno inclusi nel kernel e nell'immagine.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
tornadomig
Tux's lil' helper
Tux's lil' helper


Joined: 22 Oct 2011
Posts: 116
Location: Torino

PostPosted: Sun Nov 20, 2011 8:30 pm    Post subject: Reply with quote

ebbene si' ragassuoli, ce l'abbiamo fatta.

prima di tutto sempre un plauso a tutto lo staff del forum gentoo italiano per la grande capacita' tecnica a mettere al servizio di tutti gli appassionati di gentoo linux la loro esperienza con totale disponibilita'. un sentitissimo ringraziamento a fbcyborg per l'impegno e il tempo profuso verso il sottoscritto in gentoo-it (per chi non lo sapeva ancora come me, e' la chat su freenode di gentoo). chiave di volta per risolvere definitivamente questo problema e' stato l'intervento di Apetrini, grande cultore e conoscitore della materia. non nascondo l'emozione di gioia provata al momento della connessione del mio dispositivo wifi usb alla rete.

tengo a precisare che e' stato un percorso davvero interessante all'interno di come vengono settate le configurazioni kernel e rete wi-fi. ce ne sarebbe da imparare e qui ho trovato argomenti validi per applicarmici.
prima non e' che ne sapessi granche', basta vedere se funziona l'hardware, metti un driver e via cosi' se sei fortunato alla fine funziona. ma i forum giocano un ruolo fondamentale in tutto cio' per capire e risolvere i problemi degli utenti, specialmente niubbi come me :)

imparato un po' piano piano la configurazione del kernel che non avevo mai compiuto (grazie a fbcyborg) e genkernel (grazie a djiinz) ci si e' addentrati dentro al problema fino a scoprire con un colpo da maestro del risolutivo Apetrini che era un errato settaggio del mio router, uno zyxel P-660HW-T1 v2. in pratica con lui si e' modificato il channel. si e' visto, anzi Apetrini ha visto in chat e interagendo io, fbcyborg e lui con wgetpaste (fantastico tool, installatelo tutti che e' utilissimo) che oltre a un determinato channel il mio router non avrebbe funzionato in gentoo. con altre distro (slackware 13.37, slackex, ubuntu, backbox, backtrack5) non ho mai modificato niente del mio router e riuscivo a farlo andare googlando qua e la' fino a scovare una qualche soluzione. pero' con gentoo alla fine ci siamo riusciti. grande lavoro d'equipe e ancora grazie. ma non e' finita qui :D
Back to top
View user's profile Send private message
tornadomig
Tux's lil' helper
Tux's lil' helper


Joined: 22 Oct 2011
Posts: 116
Location: Torino

PostPosted: Sun Nov 20, 2011 8:41 pm    Post subject: Reply with quote

@djiinz: questa era un altra cosa da chiederti infatti. ci scrivo "htc_9271" o "htc_9271.fw" dopo firmware= ?

Code:
CONFIG_EXTRA_FIRMWARE=""


grazie!!!
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Mon Nov 21, 2011 1:38 pm    Post subject: Reply with quote

    dipende
  • o
    • metti "/lib/firmware/htc_9271.fw"
    • e lasci così
  • oppure
    • metti "htc_9271.fw"
    • compare nel menu (solo dopo che hai messo qualcosa in External firmware blobs to build ) Firmware blobs root directory
    • ci metti "/lib/firmware"
quale sia il tuo percorso esatto non lo so. La seconda soluzione in effetti è più utilizzata quando ci sono diversi file da includere.
In questo modo il kernel sarà capace di caricare correttamente il modulo anche all'avvio, prima che sia montata la partizione principale, e se cancelli il file (o ne prendi uno nuovo, incompatibile, per far contento un kernel più recente) non smetterà di funzionare.
Cerchiamo di non innalzare il bestemmiometro, anche se gentoo è nata per questo.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum