Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[portage] suite à mise à jour revdep [Résolu]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Bruneau
n00b
n00b


Joined: 27 Jul 2011
Posts: 6

PostPosted: Sat Nov 05, 2011 11:59 am    Post subject: [portage] suite à mise à jour revdep [Résolu] Reply with quote

Bonjour,

suite à un emerge j'ai reçu une news :
Quote:
After upgrading from libpng14 to libpng15 it's important that you rebuild
cairo and gdk-pixbuf as soon as possible if they are installed ...


Je m'exécute par :
Quote:
revdep-rebuild --library libpng14.so.14 -- --keep-going


ce qui produit :
Code:
Calculating dependencies -

!!! Problem resolving dependencies for media-video/mplayer:0
... done!

!!! The ebuild selected to satisfy "media-video/mplayer:0" has unmet requirements.
- media-video/mplayer-1.0_rc4_p20110322-r1::gentoo USE="X alsa ass bindist cdio dirac dts dv dvd enca encode faac faad gif iconv ipv6 jpeg live mad mmx mng mp3 (multilib) network opengl osdmenu png quicktime rar real rtc schroedinger sdl shm speex sse sse2 ssse3 theora toolame tremor truetype twolame unicode vorbis x264 xscreensaver xv xvid -3dnow -3dnowext -a52 -aalib (-altivec) -amr (-aqua) -bidi -bl -bluray -bs2b -cddb -cdparanoia -cpudetection -custom-cpuopts -debug -dga -directfb -doc -dvb -dvdnav (-dxr3) -esd -fbcon -ftp -ggi -gsm -jack -joystick -jpeg2k -ladspa -libcaca -libmpeg2 -lirc -lzo -md5sum -mmxext -mpg123 -nas -nut -openal -oss -pnm -pulseaudio -pvr -radio -rtmp -samba -tga -v4l -vdpau (-vidix) -vpx (-win32codecs) -xanim -xinerama -xvmc -zoran" VIDEO_CARDS="mga vesa -s3virge -tdfx"

  The following REQUIRED_USE flag constraints are unsatisfied:
    bindist? ( !faac )

  The above constraints are a subset of the following complete expression:
    bindist? ( !amr !faac !win32codecs )

 * Build finished correctly. Removing temporary files...
 * You can re-run revdep-rebuild to verify that all libraries and binaries
 * are fixed. Possible reasons for remaining inconsistencies include:
 *   orphaned files
 *   deep dependencies
 *   packages installed outside of portage's control
 *   specially-evaluated libraries


Cela c'est fini correctement mais dois-je comprendre que j'ai un problème avec mplayer qui viendrait de mon use ?
M'échappe " The following REQUIRED_USE flag constraints are unsatisfied:
bindist? ( !faac )" car cette variable figure bien dans mon use.conf :

Quote:
USE="mmx sse sse2 ssse3 sse4_1 sse4_2 ssl \
-a52 -amr -debug -dvdnav -hal -kde mp3 mp4 mpeg2 mpeg4pt2 real xvid \
X aac accessibility acl acpi alsa amd64 asf atm asyncns audio avahi berkdb bindist branding bzip2 \
cairo caps cdda cdr cli community consolekit cracklib crypt css cups cxx \ ..."


Qu'est-ce qui coince ?

Merci pour vos éclairages.


Last edited by Bruneau on Sat Nov 05, 2011 5:35 pm; edited 1 time in total
Back to top
View user's profile Send private message
bas25
n00b
n00b


Joined: 04 Nov 2011
Posts: 26

PostPosted: Sat Nov 05, 2011 1:22 pm    Post subject: Reply with quote

Ca a dû se terminer sans rien réinstaller sans doute !
Le message signifie que l'on ne peut avoir à la fois bindist et faac d'activé en même temps.
Back to top
View user's profile Send private message
guilc
Bodhisattva
Bodhisattva


Joined: 15 Nov 2003
Posts: 3326
Location: Paris - France

PostPosted: Sat Nov 05, 2011 2:15 pm    Post subject: Reply with quote

Comme dit par bas25, bindist est incompatible avec faac, amr et win32codecs. Comme je doute que tu redistribues ton binaire compilé, retire donc bindist de tes USE flags, et portage ne rallera plus.

Accessoirement, cela n'a rien a voir avec le revdep-rebuild, si tu en doutes, mais simplement avec le fait que tu recompiles mplayer. Lors de ta précédente compilation, cette restriction ne devait pas exister ! (la restriction n'entre en action que si mplayer entre dans l'arbre des dépendances, sinon, portage va passer à côté tout simplement).
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
Bruneau
n00b
n00b


Joined: 27 Jul 2011
Posts: 6

PostPosted: Sat Nov 05, 2011 5:33 pm    Post subject: Reply with quote

Merci à vous deux. Décidément le ticket d'entrée dans Gentoo est très élevé ... à chaque mise à jour je suis bon pour une petite intervention dans le moteur. Difficile de rester utilisateur :cry:
Back to top
View user's profile Send private message
guilc
Bodhisattva
Bodhisattva


Joined: 15 Nov 2003
Posts: 3326
Location: Paris - France

PostPosted: Sat Nov 05, 2011 5:46 pm    Post subject: Reply with quote

Mais non ;)
Avant tout, bien lire attentivement tous les messages d'erreur. Ils contiennent quasiment toujours la clé de la résolution du problème. Et dans le doute, sauf besoin spécifique, ne pas hésiter à laisser les USE flags par défaut !

PS : attention de ne pas confondre le bouton "Répondre" Avec le bouton "Report". là, tu as alerté tous les modérateurs ;) (Le bouton 'report', c'est pour signaler les spams et abus)
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum