Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO]wlan0 scomparsa
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
mattylux
Apprentice
Apprentice


Joined: 19 Jul 2008
Posts: 240
Location: bologna

PostPosted: Sun Oct 30, 2011 12:47 pm    Post subject: [RISOLTO]wlan0 scomparsa Reply with quote

salve
ho un problema con la mia scheda di rete

Code:
06:00.0 Network controller [0280]: Broadcom Corporation BCM4311 802.11b/g WLAN [14e4:4311] (rev 01)


praticamente reinstallando gentoo, nella compilazione del kernel iniziale funzionava tutto la presenza di wlan0 [/b ]c'era.
poi ho fatto delle altre modifiche al kernel e devo aver disabilitato quacosa involontariamente, sono uscito dalla configurazione senza salvare le impostazioni del kernel da quel momento la sche da wifi e scomparsa


Code:
ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:16:d4:f0:48:60 
          inet addr:192.168.0.104  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::216:d4ff:fef0:4860/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:36651 errors:0 dropped:0 overruns:0 frame:0
          TX packets:33132 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:36878498 (35.1 MiB)  TX bytes:5500827 (5.2 MiB)
          Interrupt:16 Base address:0xa000

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:236 errors:0 dropped:0 overruns:0 frame:0
          TX packets:236 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:17032 (16.6 KiB)  TX bytes:17032 (16.6 KiB)

sit0      Link encap:IPv6-in-IPv4 
          NOARP  MTU:1480  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)


e questo[b] /etc/init.d/net.wlan0 start


Code:

mattylux linux # /etc/init.d/net.wlan0 start
 * Bringing up interface wlan0
 *   ERROR: interface wlan0 does not exist
 *   Ensure that you have loaded the correct kernel module for your hardware
 * ERROR: net.wlan0 failed to start


qualche conscilglio??
_________________
persempre gentoo
il mio progetto in fase di lavoro
Http://stradedicarta.netsons.org


Last edited by mattylux on Tue Nov 01, 2011 10:16 pm; edited 1 time in total
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Sun Oct 30, 2011 1:29 pm    Post subject: Reply with quote

Rivedere la configurazione del kernel. Sezione driver. Ricompilare e risistemare.
Ricompilato il kernel è buona cosa ricompilare i moduli.
Se sei poco pratico usa genkernel --menuconfig e non fare l'eroe; gli eroi sono sono imbecilli (per lo più morti), fumo negli occhi o mistificatori, quasi sempre tutte e tre le cose.

Controllare con un bel dmesg
esempio:
ath5k 0000:02:07.0: PCI INT A -> GSI 22 (level, low) -> IRQ 22
ath5k 0000:02:07.0: registered as 'phy0'
cosa viene caricato e con
lspci -vvs 02:07.0:
02:07.0 Ethernet controller: Atheros Communications Inc. Atheros AR5001X+ Wireless Network Adapter (rev 01)
        Subsystem: Atheros Communications Inc. TRENDnet TEW-443PI Wireless PCI Adapter
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 168 (2500ns min, 7000ns max), Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 22
        Region 0: Memory at fe7f0000 (32-bit, non-prefetchable) [size=64K]
        Capabilities: [44] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=375mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=2 PME-
        Kernel driver in use: ath5k
se la scheda è correttamente rilevata (possibile che un banale urto l'abbia spostata, fidati, mi ha fatto impazzire per una settimana ed è bastato usare un cacciavite a stella).

In alternativa
/etc/conf.d/udev:
persistent_net_disable="no"
Code:
rm /etc/udev/rules.d/70-persistent-net.rules
potrebbero essere soluzioni.

Da provare nell'ordine che ho indicato. I cocci sono tuoi ovviamente.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
mattylux
Apprentice
Apprentice


Joined: 19 Jul 2008
Posts: 240
Location: bologna

PostPosted: Sun Oct 30, 2011 1:54 pm    Post subject: Reply with quote

ecco qui questo e il mio lspci -vvs 06:00.0

Code:

06:00.0 Network controller: Broadcom Corporation BCM4311 802.11b/g WLAN (rev 01)
        Subsystem: Hewlett-Packard Company BCM4311 802.11b/g Wireless LAN Controller                                                                                               
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-                                                                       
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-                                                                       
        Latency: 0, Cache Line Size: 64 bytes                                                                                                                                       
        Interrupt: pin A routed to IRQ 3                                                                                                                                           
        Region 0: Memory at 80000000 (32-bit, non-prefetchable) [size=16K]                                                                                                         
        Capabilities: [40] Power Management version 2                                                                                                                               
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=375mA PME(D0-,D1-,D2-,D3hot-,D3cold-)                                                                                       
                Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=2 PME-                                                                                                             
        Capabilities: [58] MSI: Enable- Count=1/1 Maskable- 64bit-                                                                                                                 
                Address: 00000000  Data: 0000                                                                                                                                       
        Capabilities: [d0] Express (v1) Legacy Endpoint, MSI 00                                                                                                                     
                DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <4us, L1 unlimited                                                                                           
                        ExtTag+ AttnBtn- AttnInd- PwrInd- RBE- FLReset-                                                                                                             
                DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-                                                                                                 
                        RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop-
                        MaxPayload 128 bytes, MaxReadReq 128 bytes
                DevSta: CorrErr- UncorrErr- FatalErr- UnsuppReq- AuxPwr- TransPend-
                LnkCap: Port #0, Speed 2.5GT/s, Width x1, ASPM L0s, Latency L0 <4us, L1 <64us
                        ClockPM- Surprise- LLActRep- BwNot-
                LnkCtl: ASPM Disabled; RCB 64 bytes Disabled- Retrain- CommClk+
                        ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
                LnkSta: Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-


e questo dmesg


Code:
dmesg | tail
[10713.402899] usb 3-2: usb_probe_device
[10713.402904] usb 3-2: configuration #1 chosen from 1 choice
[10713.405787] usb 3-2: adding 3-2:1.0 (config #1, interface 0)
[10713.405862] usbhid 3-2:1.0: usb_probe_interface
[10713.405867] usbhid 3-2:1.0: usb_probe_interface - got id
[10713.419108] input: Microsoft  Microsoft Basic Optical Mouse v2.0  as /devices/pci0000:00/0000:00:1d.1/usb3/3-2/3-2:1.0/input/input11
[10713.419236] generic-usb 0003:045E:00CB.000A: input,hidraw0: USB HID v1.11 Mouse [Microsoft  Microsoft Basic Optical Mouse v2.0 ] on usb-0000:00:1d.1-2/input0
[10713.419258] drivers/usb/core/inode.c: creating file '012'
[10713.419293] hub 3-0:1.0: state 7 ports 2 chg 0000 evt 0004
[10713.436040] uhci_hcd 0000:00:1d.1: reserve dev 12 ep81-INT, period 8, phase 4, 93 us

_________________
persempre gentoo
il mio progetto in fase di lavoro
Http://stradedicarta.netsons.org
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Sun Oct 30, 2011 2:18 pm    Post subject: Reply with quote

mi pare che ti manchi il
esempio:
Kernel driver in use: ath5k
che ho io e comunque al massimo dovresti vedere cosa riporta
Code:
dmesg | grep 06:00.0
il tail non è utile.
Mi pare sempre che ti sei scordato il driver ma nel dubbio ti ho indicato tutte le prime possibilità di rogna e relativi rimedi.

Rivedere la configurazione del kernel, ricompilarlo (casomai potresti metterla builtin la scheda) e controllare i moduli, che siano tutti al loro posto.

[OT]gli output e le configurazioni, per chiarezza, è meglio riportarli con
comando:
output
Code:
[code="comando"]output[/code]
od in alternativa
/path/file wrote:
contenuto
Code:
[quote="/path/file"]contenuto[/quote]
se vuoi fare uso di colori, dimensione carattere etc. :wink: [/OT]
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
xdarma
l33t
l33t


Joined: 08 Dec 2003
Posts: 682
Location: tra veneto e friuli (italy)

PostPosted: Sun Oct 30, 2011 7:36 pm    Post subject: Re: wlan0 scomparsa Reply with quote

Code:
06:00.0 Network controller [0280]: Broadcom Corporation BCM4311 802.11b/g WLAN [14e4:4311] (rev 01)

Mi è capitato qulacosa di simile ;-)
mattylux wrote:
qualche conscilglio??

Il wiki ufficioso di gentoo: Broadcom 43xx
_________________
proud user of faKeDE-4.7.3
Back to top
View user's profile Send private message
mattylux
Apprentice
Apprentice


Joined: 19 Jul 2008
Posts: 240
Location: bologna

PostPosted: Tue Nov 01, 2011 10:18 pm    Post subject: Reply with quote

risolto ho ricompilato da capo il kernel eliminando quello vecchio e tutto e funzionanto alla perfezione...
avevo disabilitato io per sbalgio qualche modulo.. :)
_________________
persempre gentoo
il mio progetto in fase di lavoro
Http://stradedicarta.netsons.org
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Wed Nov 02, 2011 12:54 pm    Post subject: Reply with quote

mattylux wrote:
e tutto e funzionanto alla perfezione...
8O capisco che un errore di battitura possa scappare ma... povera lingua italiana... oggi siamo proprio in tema... una prece
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum