Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201110-22 ] PostgreSQL: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1650

PostPosted: Tue Oct 25, 2011 8:26 am    Post subject: [ GLSA 201110-22 ] PostgreSQL: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: PostgreSQL: Multiple vulnerabilities (GLSA 201110-22)
Severity: normal
Exploitable: remote
Date: October 25, 2011
Updated: March 05, 2012
Bug(s): #261223, #284274, #297383, #308063, #313335, #320967, #339935, #353387, #384539
ID: 201110-22

Synopsis

Multiple vulnerabilities in the PostgreSQL server and client allow
remote attacker to conduct several attacks, including the execution of
arbitrary code and Denial of Service.


Background

PostgreSQL is an open source object-relational database management
system.


Affected Packages

Package: dev-db/postgresql
Vulnerable: <= 9
Architectures: All supported architectures

Package: dev-db/postgresql-server
Vulnerable: < 9.0.5
Unaffected: >= 9.0.5
Unaffected: >= 8.4.9 < 8.4.10
Unaffected: >= 8.3.16 < 8.3.17
Unaffected: >= 8.2.22 < 8.2.23
Unaffected: >= 8.4.10 < 8.4.11
Unaffected: >= 8.3.17 < 8.3.18
Unaffected: >= 8.2.23 < 8.2.24
Unaffected: >= 8.4.11
Unaffected: >= 8.3.18
Architectures: All supported architectures

Package: dev-db/postgresql-base
Vulnerable: < 9.0.5
Unaffected: >= 9.0.5
Unaffected: >= 8.4.9 < 8.4.10
Unaffected: >= 8.3.16 < 8.3.17
Unaffected: >= 8.2.22 < 8.2.23
Unaffected: >= 8.4.10 < 8.4.11
Unaffected: >= 8.3.17 < 8.3.18
Unaffected: >= 8.2.23 < 8.2.24
Unaffected: >= 8.4.11
Unaffected: >= 8.3.18
Architectures: All supported architectures


Description

Multiple vulnerabilities have been discovered in PostgreSQL. Please
review the CVE identifiers referenced below for details.


Impact

A remote authenticated attacker could send a specially crafted SQL query
to a PostgreSQL server with the "intarray" module enabled, possibly
resulting in the execution of arbitrary code with the privileges of the
PostgreSQL server process, or a Denial of Service condition. Furthermore,
a remote authenticated attacker could execute arbitrary Perl code, cause
a Denial of Service condition via different vectors, bypass LDAP
authentication, bypass X.509 certificate validation, gain database
privileges, exploit weak blowfish encryption and possibly cause other
unspecified impact.


Workaround

There is no known workaround at this time.

Resolution

All PostgreSQL 8.2 users should upgrade to the latest 8.2 base version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose
      ">=dev-db/postgresql-base-8.2.22:8.2"
   
All PostgreSQL 8.3 users should upgrade to the latest 8.3 base version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose
      ">=dev-db/postgresql-base-8.3.16:8.3"
   
All PostgreSQL 8.4 users should upgrade to the latest 8.4 base version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose
      ">=dev-db/postgresql-base-8.4.9:8.4"
   
All PostgreSQL 9.0 users should upgrade to the latest 9.0 base version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose
      ">=dev-db/postgresql-base-9.0.5:9.0"
   
All PostgreSQL 8.2 server users should upgrade to the latest 8.2 server
version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose
      ">=dev-db/postgresql-server-8.2.22:8.2"
   
All PostgreSQL 8.3 server users should upgrade to the latest 8.3 server
version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose
      ">=dev-db/postgresql-server-8.3.16:8.3"
   
All PostgreSQL 8.4 server users should upgrade to the latest 8.4 server
version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose
      ">=dev-db/postgresql-server-8.4.9:8.4"
   
All PostgreSQL 9.0 server users should upgrade to the latest 9.0 server
version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose
      ">=dev-db/postgresql-server-9.0.5:9.0"
   
The old unsplit PostgreSQL packages have been removed from portage.
Users still using them are urged to migrate to the new PostgreSQL
packages as stated above and to remove the old package:
Code:
# emerge --unmerge "dev-db/postgresql"
   


References

CVE-2009-0922
CVE-2009-3229
CVE-2009-3230
CVE-2009-3231
CVE-2009-4034
CVE-2009-4136
CVE-2010-0442
CVE-2010-0733
CVE-2010-1169
CVE-2010-1170
CVE-2010-1447
CVE-2010-1975
CVE-2010-3433
CVE-2010-4015
CVE-2011-2483


Last edited by GLSA on Thu Nov 01, 2012 4:29 am; edited 4 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum