Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[crypt/pam_mount] mount montre 2 entrées
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Thu Oct 20, 2011 10:52 am    Post subject: [crypt/pam_mount] mount montre 2 entrées Reply with quote

Salut,

Ça faisait longtemps que j'avais pas eu un soucis de config mais là je sèche. J'ai rien trouvé concernant mon problème.
Voilà ma partition /home/user est chiffrée, via cryptsetup au format luks, rien d'extravaguant là dedans.

Le soucis c'est avec pam_mount, au login tout se passe bien mais mount me montre ça:
Code:

/dev/mapper/_dev_sda9 on /home/user type xfs (rw)
/dev/sda9 on /home/user type crypt (rw)


Seuleument voilà, la seconde entrée est totalement inutile. Et je vois pas à quoi ça sert. Si à la main je fait:
Code:

cryptsetup luksOpen /dev/sda9 _dev_sda9
mount /dev/mapper/_dev_sda9 /home/user

J'ai pas ce soucis.

Pourquoi pam_mount persiste à monter /dev/sda9 sur /home/user ?

Voilà le pam_mount.conf.xml:
Code:

<?xml version="1.0" encoding="utf-8" ?>
<!DOCTYPE pam_mount SYSTEM "pam_mount.conf.xml.dtd">
<!--
   See pam_mount.conf(5) for a description.
-->

<pam_mount>

      <!-- debug should come before everything else,
      since this file is still processed in a single pass
      from top-to-bottom -->

<debug enable="0" />

      <!-- Volume definitions -->
<volume user="user"
   fstype="crypt"
   path="/dev/sda9"
   mountpoint="/home/user"/>

      <!-- pam_mount parameters: General tunables -->

<!--
<luserconf name=".pam_mount.conf.xml" />
-->

<!-- Note that commenting out mntoptions will give you the defaults.
     You will need to explicitly initialize it with the empty string
     to reset the defaults to nothing. -->
<mntoptions allow="nosuid,nodev,loop,encryption,fsck,nonempty,allow_root,allow_other" />
<!--
<mntoptions deny="suid,dev" />
<mntoptions allow="*" />
<mntoptions deny="*" />
-->
<mntoptions require="nosuid,nodev" />
<path>/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin</path>

<logout wait="0" hup="0" term="0" kill="0" />

      <!-- pam_mount parameters: Volume-related -->

<!-- <mkmountpoint enable="1" remove="true" /> -->

</pam_mount>


une idée? :|
Back to top
View user's profile Send private message
fb99
l33t
l33t


Joined: 09 Apr 2003
Posts: 998
Location: Le Locle (Suisse,Neuchâtel)

PostPosted: Thu Oct 20, 2011 9:58 pm    Post subject: Reply with quote

dans la rubrique on ne sait jamais. Peut-être que qql d'autre monte ou essaye de monter /dev/sda9 dans /home/user. Une veille config pas effacé ou autre (ex fstab). -> Ou alors est-ce qu'il essayerait pas le monter seul. Au quel cas il faudrait rajouter une ligne avec l'option noauto.

Ou alors tu as bien identifié que c'est pam_mount qui de fait cela.

En espérant aider. :wink:
_________________
L'ami aime en tout temps, et dans le malheur il se montre un frère ( Prov. 17,17 )
L'insensé même, quand il se tait, passe pour sage ( Prov. 17;28a )
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Fri Oct 21, 2011 7:35 am    Post subject: Reply with quote

Oui j'ai verifié et revérifié: le seul qui me fait ça c'est pam_mount.
J'ai aucune ligne concernant cette partition dans mon fstad ni ailleurs genre dmtab etc...

Quand j'aurais le temps j'irais voir son code.
Back to top
View user's profile Send private message
fb99
l33t
l33t


Joined: 09 Apr 2003
Posts: 998
Location: Le Locle (Suisse,Neuchâtel)

PostPosted: Fri Oct 21, 2011 12:08 pm    Post subject: Reply with quote

j'y connais rien au code, jamais employé testé donc voilà. Mais j'ai vu qu'il y avait une option debug à pam_mount donc l'activer devrait t'aider.
_________________
L'ami aime en tout temps, et dans le malheur il se montre un frère ( Prov. 17,17 )
L'insensé même, quand il se tait, passe pour sage ( Prov. 17;28a )
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum