Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDE: How to make Alt+Tab skip a window
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
chaoscommander
n00b
n00b


Joined: 15 Oct 2012
Posts: 55

PostPosted: Mon Mar 16, 2015 10:09 am    Post subject: KDE: How to make Alt+Tab skip a window Reply with quote

I have on my desktop a timer widget (wmtimer) I set to always be on top of other windows. Can I somehow mark it so it won't be navigated to by Alt+Tab? Since I regularly click it it's always near the top of the window switcher stack and I constantly switch to it in error (because it's tiny and looks like I'm already at the window I actually want to activate).
Back to top
View user's profile Send private message
Apheus
Apprentice
Apprentice


Joined: 12 Jul 2008
Posts: 295

PostPosted: Mon Mar 16, 2015 10:43 am    Post subject: Reply with quote

Open the window's window menu (Klick on the upper-left icon, or Alt+F3 if the window does not have a title bar), "More Actions", "Special Window Settings", Tab "Arrangement and Access", Checkbox "Skip Switcher". You can later find the rule you created by this in Systemsettings - "Workspace Appearence and Behavior" - "Window Behavior" - "Window Rules"
Back to top
View user's profile Send private message
chaoscommander
n00b
n00b


Joined: 15 Oct 2012
Posts: 55

PostPosted: Mon Mar 16, 2015 4:37 pm    Post subject: Reply with quote

Wow, that's well hidden.
Aaand it's gone. Thank you!
Back to top
View user's profile Send private message
chaoscommander
n00b
n00b


Joined: 15 Oct 2012
Posts: 55

PostPosted: Mon Mar 16, 2015 5:43 pm    Post subject: Reply with quote

.. but after a while without me touching anything it reappears in the window switcher - I don't understand how, but when I look at the options after it reappears, they also aren't selected anymore.
Back to top
View user's profile Send private message
Apheus
Apprentice
Apprentice


Joined: 12 Jul 2008
Posts: 295

PostPosted: Mon Mar 16, 2015 6:58 pm    Post subject: Reply with quote

Hm, that must be a bug, or KDE has problems to identify the window correctly. Do you still see the rule in systemsettings? What does it say on the "Window identification" tab (or whatever it is named in english, it is the first tab of four)?
Back to top
View user's profile Send private message
chaoscommander
n00b
n00b


Joined: 15 Oct 2012
Posts: 55

PostPosted: Mon Mar 16, 2015 7:49 pm    Post subject: Reply with quote

Apheus wrote:
Hm, that must be a bug, or KDE has problems to identify the window correctly. Do you still see the rule in systemsettings? What does it say on the "Window identification" tab (or whatever it is named in english, it is the first tab of four)?


Yes. Since I had tried re-setting the rule after it stopped working, it was present several times now. I deleted the extraneous ones and modified one to apply not to the window, but to the program /usr/bin/wmtimer, to be applicable for all types of windows, I checked "Not in window switcher", selected "Enforce" and "yes". Now it has once again stopped being focused on Alt+Tab, let's see if it stays that way.

A side note: whenever I apply window rules, no matter if from the window context menu or from system settings, KWin crashes and restarts. Could be more or less intentional, though.
Back to top
View user's profile Send private message
Apheus
Apprentice
Apprentice


Joined: 12 Jul 2008
Posts: 295

PostPosted: Mon Mar 16, 2015 8:01 pm    Post subject: Reply with quote

No, I have a bunch of window rules and modify them sometimes, definitely no crash here. Not even a reload of kwin (which would look like "window borders vanish and reappear after a second")
Back to top
View user's profile Send private message
chaoscommander
n00b
n00b


Joined: 15 Oct 2012
Posts: 55

PostPosted: Wed Mar 18, 2015 8:56 pm    Post subject: Reply with quote

just for the record: this time it appears to be persistent.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum