Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ath9k_htc driver calling incorrect firmware [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
NathanZachary
Moderator
Moderator


Joined: 30 Jan 2007
Posts: 2499
Location: /home/zach

PostPosted: Wed Oct 19, 2011 12:51 pm    Post subject: ath9k_htc driver calling incorrect firmware [solved] Reply with quote

Hello all,

I've been having a problem with my Alfa AWUS036NHA wireless adapter for a long time now, and I finally found something that might be causing the issues. Per this page:

http://linuxwireless.org/en/users/Drivers/ath9k_htc#Firmware

the driver should be calling the new firmware map of htc_9271.fw instead of the former ar9271.fw. I have both drivers in /lib/firmware:

Code:

tuxtoddler firmware # ls -lh | grep 9271
-rw-r--r-- 1 root root  51K Oct 14 05:29 ar9271.fw
-rw-r--r-- 1 root root  51K Oct 19 06:57 htc_9271.fw


but the driver is still loading the former firmware when plugged in:

Code:

[ 4628.056924] ath9k_htc 1-6:1.0: usb_probe_interface
[ 4628.056935] ath9k_htc 1-6:1.0: usb_probe_interface - got id
[ 4628.343687] usb 1-6: ath9k_htc: Transferred FW: ar9271.fw, size: 51312
[ 4628.609651] ath9k_htc 1-6:1.0: ath9k_htc: HTC initialized with 33 credits
[ 4629.046651] ath: EEPROM regdomain: 0x0
[ 4629.046658] ath: EEPROM indicates default country code should be used
[ 4629.046662] ath: doing EEPROM country->regdmn map search
[ 4629.046668] ath: country maps to regdmn code: 0x3a
[ 4629.046673] ath: Country alpha2 being used: US
[ 4629.046677] ath: Regpair used: 0x3a
[ 4629.048529] ieee80211 phy5: Atheros AR9271 Rev:1
[ 4629.049854] Registered led device: ath9k-phy5::radio
[ 4629.049919] Registered led device: ath9k-phy5::assoc
[ 4629.049994] Registered led device: ath9k-phy5::tx
[ 4629.050097] Registered led device: ath9k-phy5::rx
[ 4629.050107] usb 1-6: ath9k_htc: USB layer initialized
[ 4629.050170] usbcore: registered new interface driver ath9k_htc


I'm not certain that it will make any difference to use the htc_9271.fw instead of the ar9271.fw, but this adapter has been nothing but trouble. A huge number of wireless networks appear as available, but I cannot connect to any of them. Any advice would be greatly appreciated!


Cheers,
Nathan Zachary
_________________
“Truth, like infinity, is to be forever approached but never reached.” --Jean Ayres (1972)
---avatar cropped from =AimanStudio---


Last edited by NathanZachary on Wed Oct 19, 2011 4:54 pm; edited 1 time in total
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2665
Location: Slovenia

PostPosted: Wed Oct 19, 2011 3:39 pm    Post subject: Reply with quote

It depends on the kernel version which firmware will be called. If you're using 3.0 htc_9271.fw is the one, earlier kernels use ar9271.fw. I have a wireless adapter with ath9k_htc, works nicely with kernel 3.0.
Back to top
View user's profile Send private message
NathanZachary
Moderator
Moderator


Joined: 30 Jan 2007
Posts: 2499
Location: /home/zach

PostPosted: Wed Oct 19, 2011 4:54 pm    Post subject: Reply with quote

I found the problem, and it was my own mistake. Now I just have to play with the adapter in order to figure out why it isn't performing like I think it should. I should see many more APs than I do.

Cheers,
Nathan Zachary
_________________
“Truth, like infinity, is to be forever approached but never reached.” --Jean Ayres (1972)
---avatar cropped from =AimanStudio---
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum