Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
app-office/libreoffice-bin-3.4.3.2-r1 too many packages
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
yellowhat
Guru
Guru


Joined: 10 Sep 2008
Posts: 512

PostPosted: Mon Oct 17, 2011 4:20 pm    Post subject: app-office/libreoffice-bin-3.4.3.2-r1 too many packages Reply with quote

Hi all.
I have just updated my portage tree and I get this new update of libreoffice-bin: app-office/libreoffice-bin-3.4.3.2-r1, but it wants to emerge all this stuff:
Code:
Calculating dependencies... done!
[ebuild  N     ] sci-libs/ufconfig-3.6.1  USE="-static-libs" 8 kB
[ebuild  N     ] app-dicts/myspell-en-20081002  6,881 kB
[ebuild  N     ] dev-db/unixODBC-2.3.0-r1  USE="minimal -odbcmanual -static-libs" 1,763 kB
[ebuild  N     ] net-nds/openldap-2.4.25-r1  USE="berkdb crypt ipv6 perl ssl tcpd -cxx -debug -experimental -gnutls -icu -iodbc -kerberos -minimal -odbc -overlays -samba -sasl (-selinux) -slp -smbkrb5passwd -syslog" 5,128 kB
[ebuild  N     ] app-crypt/mhash-0.9.9.9  USE="-static-libs" 910 kB
[ebuild  N     ] sci-libs/colamd-2.7.3  USE="-static-libs" 54 kB
[ebuild  N     ] sys-process/time-1.7-r1  101 kB
[ebuild  N     ] sci-mathematics/lpsolve-5.5.2.0  USE="-static-libs" 720 kB
[ebuild  N     ] dev-java/javatoolkit-0.3.0-r6  17 kB
[ebuild  N     ] app-text/hunspell-1.3.2-r3  USE="ncurses nls readline -static-libs" LINGUAS="it -af -bg -ca -cs -cy -da -de -el -en -eo -es -et -fo -fr -ga -gl -he -hr -hu -ia -id -ku -lt -lv -mk -ms -nb -nl -nn -pl -pt -ro -ru -sk -sl -sv -sw -tn -uk -zu" 954 kB
[ebuild  N     ] app-admin/eselect-boost-0.3  0 kB
[ebuild  N     ] dev-util/boost-build-1.46.1  USE="python -examples" 41,017 kB
[ebuild  N     ] app-text/mythes-1.2.1  USE="-static-libs" 4,780 kB
[ebuild  N     ] dev-libs/hyphen-2.8.3  USE="-static-libs" 600 kB
[ebuild  N     ] dev-libs/boost-1.46.1-r1  USE="eselect python -debug -doc -icu -mpi -static-libs -test -tools" 0 kB
[ebuild  N     ] app-text/libwpd-0.9.3  USE="tools -doc -test" 608 kB
[ebuild  N     ] media-libs/raptor-2.0.4  USE="curl unicode xml -debug -json -static-libs" 1,622 kB
[ebuild  N     ] net-libs/neon-0.29.6  USE="nls ssl zlib -doc -expat -gnutls -kerberos -libproxy -pkcs11 -static-libs" LINGUAS="-cs -de -fr -ja -nn -pl -ru -tr -zh_CN" 862 kB
[ebuild  N     ] app-text/libwps-0.2.3  USE="-debug -doc -static-libs" 260 kB
[ebuild  N     ] app-text/libwpg-0.2.1  USE="-doc -static-libs" 328 kB
[ebuild  N     ] dev-libs/rasqal-0.9.27  USE="crypt mhash pcre -doc -gmp -static-libs -test -xml" 1,445 kB
[ebuild  N     ] dev-libs/redland-1.0.14  USE="berkdb ssl xml -iodbc -mysql -odbc -postgres -sqlite -static-libs" 1,545 kB
[ebuild  N     ] virtual/fortran-0  USE="openmp" 0 kB
[ebuild  N     ] sci-libs/hdf5-1.8.7  USE="cxx fortran zlib -debug -examples -mpi -szip -threads" 5,577 kB
[ebuild  N     ] sci-libs/fftw-3.3-r1  USE="fortran openmp sse sse2 (-altivec) -doc -mpi -static-libs -threads" 3,873 kB
[ebuild  N     ] media-gfx/graphite2-1.0.3  USE="perl -test" 4,251 kB
[ebuild  N     ] media-libs/vigra-1.7.1-r1  USE="fftw hdf5 jpeg png python tiff -doc -test" 27,814 kB
[ebuild  N     ] dev-java/ant-core-1.8.1  USE="-doc -source" 5,740 kB
[ebuild  N     ] dev-java/antlr-2.7.7-r3  USE="cxx java python -debug -doc -examples -mono -script -source -static-libs" 1,774 kB
[ebuild  N     ] dev-java/xml-commons-external-1.3.04  USE="-doc -source" 645 kB
[ebuild  N     ] dev-java/junit-3.8.2-r1  USE="-doc -source" 451 kB
[ebuild  N     ] dev-java/relaxng-datatype-1.0-r1  USE="-doc -source" 73 kB
[ebuild  N     ] dev-java/saxpath-1.0-r2  USE="-doc -source -test" 2,116 kB
[ebuild  N     ] dev-java/xml-commons-resolver-1.2  USE="-doc -source" 257 kB
[ebuild  N     ] dev-java/lucene-analyzers-2.3.2  USE="-source" 4,495 kB
[ebuild  N     ] dev-java/ant-nodeps-1.8.1  0 kB
[ebuild  N     ] dev-java/xpp3-1.1.4c-r1  USE="-doc -source -test" 938 kB
[ebuild  N     ] dev-java/log4j-1.2.16  USE="-doc -javamail -jms -jmx -source" 2,727 kB
[ebuild  N     ] dev-java/tomcat-servlet-api-4.1.36  USE="-doc -source" 3,629 kB
[ebuild  N     ] dev-java/bcel-5.2-r2  USE="-doc -findbugs -source" 256 kB
[ebuild  N     ] dev-java/javacup-0.11a_beta20060608  USE="-doc -source" 280 kB
[ebuild  N     ] dev-java/iso-relax-20050331-r2  USE="-source" 681 kB
[ebuild  N     ] dev-java/xjavac-20110814  3 kB
[ebuild  N     ] dev-java/gnu-regexp-1.1.4-r2  USE="-doc -source" 161 kB
[ebuild  N     ] dev-java/java-getopt-1.0.13  USE="-doc -source" 45 kB
[ebuild  N     ] dev-java/libreadline-java-0.8.0-r3  USE="-doc -source" 76 kB
[ebuild  N     ] dev-java/servletapi-2.4-r5  USE="-doc -source" 4,684 kB
[ebuild  N     ] dev-java/xalan-serializer-2.7.1  USE="-doc -source" 6,138 kB
[ebuild  N     ] dev-java/bsh-2.0_beta4-r3  USE="readline -bsf -doc -source" 1,628 kB
[ebuild  N     ] dev-java/javacc-4.2  USE="-doc -examples -source -test" 824 kB
[ebuild  N     ] java-virtuals/servlet-api-2.3  0 kB
[ebuild  N     ] dev-java/xerces-2.9.1  USE="-doc -examples -source" 1,672 kB
[ebuild  N     ] dev-java/lucene-2.9.4  USE="-doc -source -test" 12,202 kB
[ebuild  N     ] dev-db/hsqldb-1.8.1.2-r1  USE="-doc -source -test" 3,435 kB
[ebuild  N     ] dev-java/xsdlib-20050627-r2  USE="-doc -source" 786 kB
[ebuild  N     ] dev-java/xalan-2.7.1  USE="-doc -source" 0 kB
[ebuild  N     ] dev-java/xpp2-2.1.10-r1  USE="-doc -source" 2,257 kB
[ebuild  N     ] dev-java/msv-20050627-r3  USE="-doc -source" 3,703 kB
[ebuild  N     ] dev-java/xmldb-20011111-r1  USE="-doc -source" 36 kB
[ebuild  N     ] dev-java/ant-owanttask-1.1-r12  10 kB
[ebuild  N     ] dev-java/jaxme-0.5.2  USE="-doc -source" 5,351 kB
[ebuild  N     ] dev-java/asm-2.0-r1  USE="-doc -source" 253 kB
[ebuild  N     ] dev-java/jsr173-1.0-r1  USE="-doc -source" 625 kB
[ebuild  N     ] dev-java/jarjar-0.9  USE="-doc -source -test" 184 kB
[ebuild  N     ] dev-java/xom-1.2.6  USE="-doc -examples -source" 11,100 kB
[ebuild  N     ] dev-java/dom4j-1.6.1-r3  USE="-doc -source -test" 9,463 kB
[ebuild  N     ] dev-java/jdom-1.0-r4  USE="-doc -examples -source" 3,489 kB
[ebuild  N     ] dev-java/jaxen-1.1.1  USE="-doc -examples -source -test" 265 kB
[ebuild  N     ] dev-java/jdom-jaxen-1.0-r1  0 kB
[ebuild  N     ] dev-java/saxon-8.4b-r3  USE="-doc -examples -source" 7,097 kB
[ebuild     U *] app-office/libreoffice-bin-3.4.3.2-r1 [3.4.3-r2] USE="gnome java (-aqua) -kde% (-kdeenablefinal)" 109,761 kB

Is it normal?
Back to top
View user's profile Send private message
mikegpitt
Advocate
Advocate


Joined: 22 May 2004
Posts: 3224

PostPosted: Mon Oct 17, 2011 4:24 pm    Post subject: Reply with quote

In a word, yes. You can look at all the dependencies by browsing the ebuild here: /usr/portage/app-office/libreoffice/libreoffice-3.4.3.2-r1.ebuild

I take it that since packages are all marked as new merges, that you are performing the installation of libreoffice following a fresh install?
Back to top
View user's profile Send private message
yellowhat
Guru
Guru


Joined: 10 Sep 2008
Posts: 512

PostPosted: Mon Oct 17, 2011 5:05 pm    Post subject: Reply with quote

No, I installed gentoo one month ago.
I have all packages that I need: gnome-light, chrome, ...
That's why I asked about so many new packages requesting by libreoffice-bin
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 10459
Location: Somewhere over Atlanta, Georgia

PostPosted: Mon Oct 17, 2011 5:07 pm    Post subject: Reply with quote

It's a fresh install of libreoffice, though, right? Libreoffice is a monster. What you're seeing is normal.

- John
_________________
I can confirm that I have received between 0 and 499 National Security Letters.
Back to top
View user's profile Send private message
yellowhat
Guru
Guru


Joined: 10 Sep 2008
Posts: 512

PostPosted: Mon Oct 17, 2011 5:22 pm    Post subject: Reply with quote

No it isn't a fresh install of libreoffice-bin; now I am using app-office/libreoffice-bin-3.4.3-r2, this problem comes when I try to upgrade.
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 10459
Location: Somewhere over Atlanta, Georgia

PostPosted: Mon Oct 17, 2011 5:37 pm    Post subject: Reply with quote

Well, it's still almost certainly normal. libreoffice is moving really fast.

- John
_________________
I can confirm that I have received between 0 and 499 National Security Letters.
Back to top
View user's profile Send private message
yellowhat
Guru
Guru


Joined: 10 Sep 2008
Posts: 512

PostPosted: Mon Oct 17, 2011 5:38 pm    Post subject: Reply with quote

Ok thanks I will emerge all that stuff
Back to top
View user's profile Send private message
tassilo80
Guru
Guru


Joined: 26 Mar 2003
Posts: 346
Location: Koblenz, Germany

PostPosted: Tue Oct 18, 2011 5:19 pm    Post subject: Reply with quote

John R. Graham wrote:
Well, it's still almost certainly normal. libreoffice is moving really fast.

No, it's not really normal. All previous versions of libreoffice-bin shipped with a huge set of precompiled libraries. Now the maintainers seems to have decided to drop installation of those, so that the package requires much more than it used to. See this bug report.

Not sure if that's a good decision. I don't really want to install 10 new packages only for libreoffice-bin which I only use twice a year...

Bye,
Tassilo
Back to top
View user's profile Send private message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3809
Location: Hamburg

PostPosted: Tue Oct 18, 2011 8:41 pm    Post subject: Reply with quote

tassilo80 wrote:
John R. Graham wrote:
Well, it's still almost certainly normal. libreoffice is moving really fast.

No, it's not really normal.
...
Not sure if that's a good decision.
+1
Where is the advantage to use the offine-bin package over the source code package now ?
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 10459
Location: Somewhere over Atlanta, Georgia

PostPosted: Tue Oct 18, 2011 8:47 pm    Post subject: Reply with quote

I can't really agree. The compile time of libreoffice completely dwarfs the compile time of these dependencies. I see the justification as reducing bloat.

- John
_________________
I can confirm that I have received between 0 and 499 National Security Letters.
Back to top
View user's profile Send private message
Hwoarang
Retired Dev
Retired Dev


Joined: 24 Feb 2007
Posts: 701
Location: Leeds, UK

PostPosted: Wed Oct 19, 2011 7:42 am    Post subject: Reply with quote

The libreoffice-bin uses the desktop profile use flags. This is why you get so many dependencies. If you want to reduce them you have to build it yourself
Back to top
View user's profile Send private message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3809
Location: Hamburg

PostPosted: Wed Oct 19, 2011 9:18 am    Post subject: Reply with quote

John R. Graham wrote:
I can't really agree. The compile time of libreoffice completely dwarfs the compile time of these dependencies.
oh - thx
Back to top
View user's profile Send private message
mikegpitt
Advocate
Advocate


Joined: 22 May 2004
Posts: 3224

PostPosted: Wed Oct 19, 2011 1:29 pm    Post subject: Reply with quote

Usually decisions like this are due to upstream changes, so it is quite possible that upstream is requiring that the binary is depending on all these packages.
Back to top
View user's profile Send private message
khumba
n00b
n00b


Joined: 16 Jun 2011
Posts: 43

PostPosted: Thu Oct 20, 2011 7:29 am    Post subject: Reply with quote

On the other hand, most of those look like they're being pulled in because of USE=java. Any idea how many features LibreOffice loses without Java support?
Back to top
View user's profile Send private message
scarabeus
Developer
Developer


Joined: 25 Oct 2008
Posts: 95
Location: Europe/Prague

PostPosted: Fri Oct 21, 2011 7:12 pm    Post subject: Reply with quote

It really is not too many :)

With no useflags set it is few 1MB large packages which are just unbundled dependencies.
If you set java/gnome/kde then it is completely different story of course...
Back to top
View user's profile Send private message
khumba
n00b
n00b


Joined: 16 Jun 2011
Posts: 43

PostPosted: Sat Oct 22, 2011 5:43 pm    Post subject: Reply with quote

Wow, deps do go way down... Thanks, I'm setting a preemptive '>=app-office/libreoffice-bin-3.4.3.2-r1 -java' in package.use for when this hits stable.
Back to top
View user's profile Send private message
morpheus2051
Tux's lil' helper
Tux's lil' helper


Joined: 07 May 2006
Posts: 95

PostPosted: Wed Oct 26, 2011 6:18 pm    Post subject: Reply with quote

What bugs me that it is pulling in media-libs/gstreamer no matter what. Well I masked this update for the time beeing.
Back to top
View user's profile Send private message
jchau
n00b
n00b


Joined: 15 Mar 2007
Posts: 74

PostPosted: Thu Oct 27, 2011 5:06 am    Post subject: Reply with quote

Shucks. I like having the Presenter Console extension available (and I seem to need to enable the java use flag for extensions). So I guess I'll have to install these 43 new packages.

The explanation that libreoffice-bin used to ship these as precompiled libraries doesn't really make sense to me though. My previous (current) version of libreoffice was emerged from source (so it seems improbable that it was previously bundled as precompiled libraries) instead of libreoffice-bin and these 43 dependencies are new for me too.

It seems like most of these new dependencies arise from the new dependency on dev-java/saxon, which appears optional [enabled with --with-saxon-jar=$(java-pkg_getjar saxon saxon8.jar)] from the ebuild. I wonder if this option is worth adding so many dependencies and whether it'll be appropriate to make saxon optional with another use-flag.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum