Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDE4 and policy kit (?)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
pygoscelis
Guru
Guru


Joined: 07 Jun 2003
Posts: 394

PostPosted: Fri Oct 14, 2011 6:27 pm    Post subject: KDE4 and policy kit (?) Reply with quote

I'm having trouble with remembering authorization for system actions. That is, it is never remembered.

For instance, when I go and change clock settings, the date&time module asks me to enter the root password. A check box named "remember authorization" is ticked. However nothing is remembered. If in a minute I go and change the settings again, the module asks me to enter the root password again.

I have tried to add some local policies via kcontrol/actions policy, but they are forgotten as soon as I exit kcontrol, and don't seem to have any effect even when they exist.

I'm really lost here. Any hints?
_________________
!זה הכי, אחי Gentoo
Back to top
View user's profile Send private message
Martux
Veteran
Veteran


Joined: 04 Feb 2005
Posts: 1917

PostPosted: Sat Oct 15, 2011 11:00 am    Post subject: Reply with quote

This is a bug, which unfortunately seems to never get resolved... :(
https://bugs.gentoo.org/show_bug.cgi?id=358657
_________________
"Coincidence is God's way of remaining anonymous."
Albert Einstein
"The road to success is always under construction"
Back to top
View user's profile Send private message
pygoscelis
Guru
Guru


Joined: 07 Jun 2003
Posts: 394

PostPosted: Sat Oct 15, 2011 3:21 pm    Post subject: Reply with quote

Martux wrote:
This is a bug, which unfortunately seems to never get resolved... :(
https://bugs.gentoo.org/show_bug.cgi?id=358657

Thanks. Is there a way to add relevant policies manually? I have tried to read the polkit documentation and it looks like I need to files in /etc/polkit/localauthority. I added one named /etc/polkit-1/localauthority/50-local.d/org.kde.kcontrol.kcmclock.save:
Code:

[kcmclock]
Identity=unix-user:myusername
Action=org.kde.kcontrol.kcmclock.save
ResultAny=yes
ResultInactive=yes
ResultActive=yes

But this doesn't seem to help. Am I missing something, or this is another manifestation of the same bug?
_________________
!זה הכי, אחי Gentoo
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum