Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[WORKAROUND]DRI/OpenGL rendering issue?[i915/intel]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
tclover
Guru
Guru


Joined: 10 Apr 2011
Posts: 516

PostPosted: Thu Oct 13, 2011 6:15 pm    Post subject: [WORKAROUND]DRI/OpenGL rendering issue?[i915/intel] Reply with quote

I've just upgraded xorg-server yesterday from 1.9.5 to 1.10.4 because I've just bumped into an DRI/OpenGL issue(?). Until yesterday and using the same x11-drivers set and X server, I could run a poor e17+ecomorph using the poor capabilities of i915/radeon flawlessly. I'm saying poor because the displayed colors are just a little too awful, well, to be fair, it could be the poor (TN) panel that displays those awful colors.

Anyway, at least a little eye candy was possible until then. Actually I use a single stage4 for a desktop and a laptop to avoid compiling the same stuff twice. So after major updates, like libpng-1.5.x went through with a little pain, and after starting to remove gnome-2.32, I've just decide to make a new stage4 so it could serve to make a very quick restore to the laptop because I was satisfied with what I've got; and because as {{,s}bin,lib{32,64},opt,var/{{,local/}portage,{,cache/e}db,lib/layman}} are squashed, making a stage4 is just a matter of a very few minutes!

But now only the radeon is capable of displaying an e17+ecomorph, however, the discret card run too hot to use it all the time. So I've just decided to bump to a xf86-video-intel with sna USE flag which require a >=xorg-server-1.10. I was stuck with xorg-server-1.9.5 because I kept an old nvidia-drivers-275.09.07 dependency when it hit portage a while back, now those drivers are compatible with version 1.10 of X server. So I upgraded X server to version 1.10.4 and rebuild the whole stack of xf86-{input,video}-* with sna USE flag to no avail. Only the radeon driver is capable of running e17+ecomorph. I considered a possible fglrx route but as the discret chips runs very hot, I'm not sure if it's an option.

There's seems nothing particular in Xorg.0.log but a few (WW) warings:
Quote:
[ 1264.687] (WW) intel(0): cannot enable DRI2 whilst the GPU is wedged
[ 1264.687] (II) intel(0): SNA initialized with Broadwater backend
[ 1264.687] (==) intel(0): Backing store disabled
[ 1264.687] (==) intel(0): Silken mouse enabled
[ 1264.687] (II) intel(0): Initializing HW Cursor
[ 1264.687] (II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[ 1264.699] (==) intel(0): DPMS enabled
[ 1264.699] (WW) intel(0): cannot enable XVideo whilst the GPU is wedged
[ 1264.699] (II) intel(0): Overlay video not supported on this hardware
[ 1264.699] (WW) intel(0): Disabling Xv because no adaptors could be initialized.
[ 1264.699] (WW) intel(0): Option "DRI" is not used
[ 1264.699] (==) intel(0): hotplug detection: "enabled"
[ 1264.699] (--) RandR disabled

And there's nothing in the ouput of glxinfo:
Quote:
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.4

OpenGL vendor string: VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe
OpenGL version string: 2.1 Mesa 7.11
OpenGL shading language version string: 1.2


full Xorg.0.log wrote:
[ 1264.634]
X.Org X Server 1.10.4
Release Date: 2011-08-19
[ 1264.634] X Protocol Version 11, Revision 0
[ 1264.634] Build Operating System: Linux 3.0.3-git x86_64 Gentoo
[ 1264.634] Current Operating System: Linux lufeeo 3.0.3-git #1 SMP PREEMPT Thu Aug 18 18:07:57 UTC 2011 x86_64
[ 1264.634] Kernel command line: BOOT_IMAGE=/boot/kernel-3.0.3-git iroot=urv-root:c:ext4 isqfsd=y,a:lib64 ikroot=gpg:sdb1:/k/luk.g ilvm=urp-sda6 ikmap=fr_l1-amd64.bin: video=uvesafb:ywrap,1680x1050-24@60 max_loop=32 raid=noautodetect zcache
[ 1264.634] Build Date: 13 October 2011 03:00:44AM
[ 1264.634]
[ 1264.634] Current version of pixman: 0.22.2
[ 1264.634] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 1264.634] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 1264.634] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Oct 13 19:40:27 2011
[ 1264.634] (==) Using config directory: "/etc/X11/xorg.conf.d"
[ 1264.634] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 1264.634] (==) No Layout section. Using the first Screen section.
[ 1264.635] (**) |-->Screen "INTEL" (0)
[ 1264.635] (**) | |-->Monitor "LVDS"
[ 1264.635] (**) | |-->Device "GMA-X4500MHD"
[ 1264.635] (==) Automatically adding devices
[ 1264.635] (==) Automatically enabling devices
[ 1264.635] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/misc/".
[ 1264.635] Entry deleted from font path.
[ 1264.635] (Run 'mkfontdir' on "/usr/share/fonts/misc/").
[ 1264.635] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[ 1264.635] Entry deleted from font path.
[ 1264.635] (==) FontPath set to:
/usr/share/fonts/TTF/,
/usr/share/fonts/Type1/,
/usr/share/fonts/100dpi/,
/usr/share/fonts/75dpi/
[ 1264.635] (==) ModulePath set to "/usr/lib64/xorg/modules"
[ 1264.635] (II) The server relies on udev to provide the list of input devices.
If no devices become available, reconfigure udev or disable AutoAddDevices.
[ 1264.635] (II) Loader magic: 0x7d7160
[ 1264.635] (II) Module ABI versions:
[ 1264.635] X.Org ANSI C Emulation: 0.4
[ 1264.635] X.Org Video Driver: 10.0
[ 1264.635] X.Org XInput driver : 12.2
[ 1264.635] X.Org Server Extension : 5.0
[ 1264.636] (--) PCI:*(0:0:2:0) 8086:2a42:17aa:3a02 rev 7, Mem @ 0xe0000000/4194304, 0xd0000000/268435456, I/O @ 0x00006110/8
[ 1264.636] (--) PCI: (0:1:0:0) 1002:95c4:17aa:3d9f rev 0, Mem @ 0xc0000000/268435456, 0xe6500000/65536, I/O @ 0x00005000/256, BIOS @ 0x????????/131072
[ 1264.636] (II) Open ACPI successful (/var/run/acpid.socket)
[ 1264.636] (II) LoadModule: "extmod"
[ 1264.636] (II) Loading /usr/lib64/xorg/modules/extensions/libextmod.so
[ 1264.636] (II) Module extmod: vendor="X.Org Foundation"
[ 1264.636] compiled for 1.10.4, module version = 1.0.0
[ 1264.636] Module class: X.Org Server Extension
[ 1264.636] ABI class: X.Org Server Extension, version 5.0
[ 1264.636] (II) Loading extension MIT-SCREEN-SAVER
[ 1264.636] (II) Loading extension XFree86-VidModeExtension
[ 1264.636] (II) Loading extension XFree86-DGA
[ 1264.636] (II) Loading extension DPMS
[ 1264.636] (II) Loading extension XVideo
[ 1264.636] (II) Loading extension XVideo-MotionCompensation
[ 1264.636] (II) Loading extension X-Resource
[ 1264.636] (II) LoadModule: "dbe"
[ 1264.637] (II) Loading /usr/lib64/xorg/modules/extensions/libdbe.so
[ 1264.637] (II) Module dbe: vendor="X.Org Foundation"
[ 1264.637] compiled for 1.10.4, module version = 1.0.0
[ 1264.637] Module class: X.Org Server Extension
[ 1264.637] ABI class: X.Org Server Extension, version 5.0
[ 1264.637] (II) Loading extension DOUBLE-BUFFER
[ 1264.637] (II) LoadModule: "glx"
[ 1264.637] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[ 1264.637] (II) Module glx: vendor="X.Org Foundation"
[ 1264.637] compiled for 1.10.4, module version = 1.0.0
[ 1264.637] ABI class: X.Org Server Extension, version 5.0
[ 1264.637] (==) AIGLX enabled
[ 1264.637] (II) Loading extension GLX
[ 1264.637] (II) LoadModule: "record"
[ 1264.637] (II) Loading /usr/lib64/xorg/modules/extensions/librecord.so
[ 1264.637] (II) Module record: vendor="X.Org Foundation"
[ 1264.637] compiled for 1.10.4, module version = 1.13.0
[ 1264.637] Module class: X.Org Server Extension
[ 1264.637] ABI class: X.Org Server Extension, version 5.0
[ 1264.637] (II) Loading extension RECORD
[ 1264.637] (II) LoadModule: "dri"
[ 1264.637] (II) Loading /usr/lib64/xorg/modules/extensions/libdri.so
[ 1264.637] (II) Module dri: vendor="X.Org Foundation"
[ 1264.637] compiled for 1.10.4, module version = 1.0.0
[ 1264.637] ABI class: X.Org Server Extension, version 5.0
[ 1264.637] (II) Loading extension XFree86-DRI
[ 1264.638] (II) LoadModule: "dri2"
[ 1264.638] (II) Loading /usr/lib64/xorg/modules/extensions/libdri2.so
[ 1264.638] (II) Module dri2: vendor="X.Org Foundation"
[ 1264.638] compiled for 1.10.4, module version = 1.2.0
[ 1264.638] ABI class: X.Org Server Extension, version 5.0
[ 1264.638] (II) Loading extension DRI2
[ 1264.638] (II) LoadModule: "intel"
[ 1264.638] (II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so
[ 1264.638] (II) Module intel: vendor="X.Org Foundation"
[ 1264.638] compiled for 1.10.4, module version = 2.16.0
[ 1264.638] Module class: X.Org Video Driver
[ 1264.638] ABI class: X.Org Video Driver, version 10.0
[ 1264.638] (II) intel: Driver for Intel Integrated Graphics Chipsets: i810,
i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G, 915G,
E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM, Pineview G,
965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33, GM45,
4 Series, G45/G43, Q45/Q43, G41, B43, B43, Clarkdale, Arrandale,
Sandybridge Desktop (GT1), Sandybridge Desktop (GT2),
Sandybridge Desktop (GT2+), Sandybridge Mobile (GT1),
Sandybridge Mobile (GT2), Sandybridge Mobile (GT2+),
Sandybridge Server, Ivybridge Mobile (GT1), Ivybridge Mobile (GT2),
Ivybridge Desktop (GT1), Ivybridge Desktop (GT2), Ivybridge Server
[ 1264.638] (++) using VT number 7

[ 1264.643] (II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so
[ 1264.643] drmOpenDevice: node name is /dev/dri/card0
[ 1264.643] drmOpenDevice: open result is -1, (Invalid argument)
[ 1264.643] drmOpenByBusid: Searching for BusID pci:0000:00:02.0
[ 1264.643] drmOpenDevice: node name is /dev/dri/card0
[ 1264.643] drmOpenDevice: open result is -1, (Invalid argument)
[ 1264.643] drmOpenByBusid: drmOpenMinor returns -22
[ 1264.643] drmOpenDevice: node name is /dev/dri/card1
[ 1264.643] drmOpenDevice: open result is 9, (OK)
[ 1264.643] drmOpenByBusid: drmOpenMinor returns 9
[ 1264.643] drmOpenByBusid: drmGetBusid reports pci:0000:00:02.0
[ 1264.643] (==) intel(0): Depth 24, (--) framebuffer bpp 32
[ 1264.643] (==) intel(0): RGB weight 888
[ 1264.643] (==) intel(0): Default visual is TrueColor
[ 1264.643] (II) intel(0): Integrated Graphics Chipset: Intel(R) GM45
[ 1264.643] (--) intel(0): Chipset: "GM45"
[ 1264.643] (--) intel(0): Disabling use of vmap
[ 1264.643] (**) intel(0): Framebuffer tiled
[ 1264.643] (**) intel(0): Pixmaps tiled
[ 1264.643] (**) intel(0): 3D buffers tiled
[ 1264.643] (**) intel(0): Throttling enabled
[ 1264.643] (II) intel(0): Output LVDS2 using monitor section LVDS
[ 1264.651] (II) intel(0): found backlight control interface /sys/class/backlight/acpi_video0
[ 1264.668] (II) intel(0): Output VGA2 has no monitor section
[ 1264.669] (II) intel(0): Output DP1 has no monitor section
[ 1264.669] (II) intel(0): EDID for output LVDS2
[ 1264.669] (II) intel(0): Manufacturer: CMO Model: 1313 Serial#: 0
[ 1264.669] (II) intel(0): Year: 2008 Week: 35
[ 1264.669] (II) intel(0): EDID Version: 1.3
[ 1264.669] (II) intel(0): Digital Display Input
[ 1264.669] (II) intel(0): Max Image Size [cm]: horiz.: 29 vert.: 19
[ 1264.669] (II) intel(0): Gamma: 2.20
[ 1264.669] (II) intel(0): No DPMS capabilities specified
[ 1264.669] (II) intel(0): Supported color encodings: RGB 4:4:4 YCrCb 4:4:4
[ 1264.669] (II) intel(0): First detailed timing is preferred mode
[ 1264.669] (II) intel(0): redX: 0.595 redY: 0.345 greenX: 0.319 greenY: 0.555
[ 1264.669] (II) intel(0): blueX: 0.154 blueY: 0.145 whiteX: 0.312 whiteY: 0.328
[ 1264.669] (II) intel(0): Manufacturer's mask: 0
[ 1264.669] (II) intel(0): Supported detailed timing:
[ 1264.669] (II) intel(0): clock: 71.0 MHz Image Size: 286 x 179 mm
[ 1264.669] (II) intel(0): h_active: 1280 h_sync: 1328 h_sync_end 1360 h_blank_end 1440 h_border: 0
[ 1264.669] (II) intel(0): v_active: 800 v_sync: 803 v_sync_end 809 v_blanking: 823 v_border: 0
[ 1264.669] (II) intel(0): N133I6-L0A
[ 1264.669] (II) intel(0): CMO
[ 1264.669] (II) intel(0): N133I6-L0A
[ 1264.669] (II) intel(0): EDID (in hex):
[ 1264.669] (II) intel(0): 00ffffffffffff000daf131300000000
[ 1264.669] (II) intel(0): 23120103801d13780a5c809858518e27
[ 1264.669] (II) intel(0): 25505400000001010101010101010101
[ 1264.669] (II) intel(0): 010101010101bc1b00a0502017303020
[ 1264.669] (II) intel(0): 36001eb310000019000000fe004e3133
[ 1264.669] (II) intel(0): 3349362d4c30410a2020000000fe0043
[ 1264.669] (II) intel(0): 4d4f0a202020202020202020000000fe
[ 1264.669] (II) intel(0): 004e31333349362d4c30410a2020002d
[ 1264.669] (II) intel(0): EDID vendor "CMO", prod id 4883
[ 1264.669] (II) intel(0): Printing DDC gathered Modelines:
[ 1264.669] (II) intel(0): Modeline "1280x800"x0.0 71.00 1280 1328 1360 1440 800 803 809 823 -hsync -vsync (49.3 kHz)
[ 1264.669] (II) intel(0): Not using default mode "320x240" (doublescan mode not supported)
[ 1264.669] (II) intel(0): Not using default mode "400x300" (doublescan mode not supported)
[ 1264.669] (II) intel(0): Not using default mode "400x300" (doublescan mode not supported)
[ 1264.669] (II) intel(0): Not using default mode "512x384" (doublescan mode not supported)
[ 1264.669] (II) intel(0): Not using default mode "640x480" (doublescan mode not supported)
[ 1264.669] (II) intel(0): Not using default mode "640x512" (doublescan mode not supported)
[ 1264.669] (II) intel(0): Not using default mode "800x600" (doublescan mode not supported)
[ 1264.669] (II) intel(0): Not using default mode "896x672" (doublescan mode not supported)
[ 1264.669] (II) intel(0): Not using default mode "928x696" (doublescan mode not supported)
[ 1264.669] (II) intel(0): Not using default mode "960x720" (doublescan mode not supported)
[ 1264.669] (II) intel(0): Not using default mode "700x525" (doublescan mode not supported)
[ 1264.669] (II) intel(0): Not using default mode "1024x768" (doublescan mode not supported)
[ 1264.669] (II) intel(0): Printing probed modes for output LVDS2
[ 1264.669] (II) intel(0): Modeline "1280x800"x59.9 71.00 1280 1328 1360 1440 800 803 809 823 -hsync -vsync (49.3 kHz)
[ 1264.669] (II) intel(0): Modeline "1024x768"x60.0 65.00 1024 1048 1184 1344 768 771 777 806 -hsync -vsync (48.4 kHz)
[ 1264.669] (II) intel(0): Modeline "800x600"x60.3 40.00 800 840 968 1056 600 601 605 628 +hsync +vsync (37.9 kHz)
[ 1264.669] (II) intel(0): Modeline "800x600"x56.2 36.00 800 824 896 1024 600 601 603 625 +hsync +vsync (35.2 kHz)
[ 1264.669] (II) intel(0): Modeline "640x480"x59.9 25.18 640 656 752 800 480 490 492 525 -hsync -vsync (31.5 kHz)
[ 1264.685] (II) intel(0): EDID for output VGA2
[ 1264.686] (II) intel(0): EDID for output DP1
[ 1264.686] (II) intel(0): Output LVDS2 connected
[ 1264.686] (II) intel(0): Output VGA2 disconnected
[ 1264.686] (II) intel(0): Output DP1 disconnected
[ 1264.686] (II) intel(0): Using exact sizes for initial modes
[ 1264.686] (II) intel(0): Output LVDS2 using initial mode 1280x800
[ 1264.686] (II) intel(0): Using default gamma of (1.0, 1.0, 1.0) unless otherwise stated.
[ 1264.686] (**) intel(0): Display dimensions: (290, 190) mm
[ 1264.686] (**) intel(0): DPI set to (112, 106)
[ 1264.686] (II) Loading sub module "fb"
[ 1264.686] (II) LoadModule: "fb"
[ 1264.686] (II) Loading /usr/lib64/xorg/modules/libfb.so
[ 1264.686] (II) Module fb: vendor="X.Org Foundation"
[ 1264.686] compiled for 1.10.4, module version = 1.0.0
[ 1264.686] ABI class: X.Org ANSI C Emulation, version 0.4
[ 1264.686] (II) Loading sub module "dri2"
[ 1264.686] (II) LoadModule: "dri2"
[ 1264.686] (II) Loading /usr/lib64/xorg/modules/extensions/libdri2.so
[ 1264.687] (II) Module dri2: vendor="X.Org Foundation"
[ 1264.687] compiled for 1.10.4, module version = 1.2.0
[ 1264.687] ABI class: X.Org Server Extension, version 5.0
[ 1264.687] (==) Depth 24 pixmap format is 32 bpp
[ 1264.687] (WW) intel(0): cannot enable DRI2 whilst the GPU is wedged
[ 1264.687] (II) intel(0): SNA initialized with Broadwater backend
[ 1264.687] (==) intel(0): Backing store disabled
[ 1264.687] (==) intel(0): Silken mouse enabled
[ 1264.687] (II) intel(0): Initializing HW Cursor
[ 1264.687] (II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[ 1264.699] (==) intel(0): DPMS enabled
[ 1264.699] (WW) intel(0): cannot enable XVideo whilst the GPU is wedged
[ 1264.699] (II) intel(0): Overlay video not supported on this hardware
[ 1264.699] (WW) intel(0): Disabling Xv because no adaptors could be initialized.
[ 1264.699] (WW) intel(0): Option "DRI" is not used
[ 1264.699] (==) intel(0): hotplug detection: "enabled"
[ 1264.699] (--) RandR disabled
[ 1264.699] (II) Initializing built-in extension Generic Event Extension
[ 1264.699] (II) Initializing built-in extension SHAPE
[ 1264.699] (II) Initializing built-in extension MIT-SHM
[ 1264.699] (II) Initializing built-in extension XInputExtension
[ 1264.699] (II) Initializing built-in extension XTEST
[ 1264.699] (II) Initializing built-in extension BIG-REQUESTS
[ 1264.699] (II) Initializing built-in extension SYNC
[ 1264.699] (II) Initializing built-in extension XKEYBOARD
[ 1264.699] (II) Initializing built-in extension XC-MISC
[ 1264.699] (II) Initializing built-in extension XINERAMA
[ 1264.699] (II) Initializing built-in extension XFIXES
[ 1264.699] (II) Initializing built-in extension RENDER
[ 1264.699] (II) Initializing built-in extension RANDR
[ 1264.699] (II) Initializing built-in extension COMPOSITE
[ 1264.699] (II) Initializing built-in extension DAMAGE
[ 1264.705] (II) AIGLX: Screen 0 is not DRI2 capable
[ 1264.705] (II) AIGLX: Screen 0 is not DRI capable
[ 1264.714] (II) AIGLX: Loaded and initialized /usr/lib64/dri/swrast_dri.so
[ 1264.714] (II) GLX: Initialized DRISWRAST GL provider for screen 0
[ 1264.733] (II) intel(0): Setting screen physical size to 338 x 211
[ 1264.798] (II) config/udev: Adding input device Power Button (/dev/input/event4)
[ 1264.799] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[ 1264.799] (**) Power Button: Applying InputClass "eKeyboard"
[ 1264.799] (II) LoadModule: "evdev"
[ 1264.799] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
[ 1264.799] (II) Module evdev: vendor="X.Org Foundation"
[ 1264.799] compiled for 1.10.4, module version = 2.6.0
[ 1264.799] Module class: X.Org XInput Driver
[ 1264.799] ABI class: X.Org XInput driver, version 12.2
[ 1264.799] (II) Using input driver 'evdev' for 'Power Button'
[ 1264.799] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
[ 1264.799] (**) Power Button: always reports core events
[ 1264.799] (**) Power Button: Device: "/dev/input/event4"
[ 1264.799] (--) Power Button: Found keys
[ 1264.799] (II) Power Button: Configuring as keyboard
[ 1264.799] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input4/event4"
[ 1264.799] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
[ 1264.799] (**) Option "xkb_rules" "evdev"
[ 1264.799] (**) Option "xkb_model" "pc105"
[ 1264.799] (**) Option "xkb_layout" "us,fr"
[ 1264.799] (**) Option "xkb_options" "grp:alt_shift_toggle,grp:switch,grp_led:scroll,terminate:ctrl_alt_bksp"
[ 1264.828] (II) config/udev: Adding input device Video Bus (/dev/input/event7)
[ 1264.828] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
[ 1264.828] (**) Video Bus: Applying InputClass "eKeyboard"
[ 1264.828] (II) Using input driver 'evdev' for 'Video Bus'
[ 1264.828] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
[ 1264.828] (**) Video Bus: always reports core events
[ 1264.829] (**) Video Bus: Device: "/dev/input/event7"
[ 1264.829] (--) Video Bus: Found keys
[ 1264.829] (II) Video Bus: Configuring as keyboard
[ 1264.829] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/device:00/PNP0A08:00/LNXVIDEO:00/input/input7/event7"
[ 1264.829] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD)
[ 1264.829] (**) Option "xkb_rules" "evdev"
[ 1264.829] (**) Option "xkb_model" "pc105"
[ 1264.829] (**) Option "xkb_layout" "us,fr"
[ 1264.829] (**) Option "xkb_options" "grp:alt_shift_toggle,grp:switch,grp_led:scroll,terminate:ctrl_alt_bksp"
[ 1264.834] (II) config/udev: Adding input device Lid Switch (/dev/input/event2)
[ 1264.834] (II) No input driver/identifier specified (ignoring)
[ 1264.834] (II) config/udev: Adding input device Sleep Button (/dev/input/event3)
[ 1264.834] (**) Sleep Button: Applying InputClass "evdev keyboard catchall"
[ 1264.834] (**) Sleep Button: Applying InputClass "eKeyboard"
[ 1264.834] (II) Using input driver 'evdev' for 'Sleep Button'
[ 1264.834] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
[ 1264.834] (**) Sleep Button: always reports core events
[ 1264.834] (**) Sleep Button: Device: "/dev/input/event3"
[ 1264.834] (--) Sleep Button: Found keys
[ 1264.834] (II) Sleep Button: Configuring as keyboard
[ 1264.834] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/device:00/PNP0C0E:00/input/input3/event3"
[ 1264.834] (II) XINPUT: Adding extended input device "Sleep Button" (type: KEYBOARD)
[ 1264.834] (**) Option "xkb_rules" "evdev"
[ 1264.834] (**) Option "xkb_model" "pc105"
[ 1264.834] (**) Option "xkb_layout" "us,fr"
[ 1264.834] (**) Option "xkb_options" "grp:alt_shift_toggle,grp:switch,grp_led:scroll,terminate:ctrl_alt_bksp"
[ 1264.838] (II) config/udev: Adding input device Lenovo EasyCamera (/dev/input/event6)
[ 1264.838] (**) Lenovo EasyCamera: Applying InputClass "evdev keyboard catchall"
[ 1264.838] (**) Lenovo EasyCamera: Applying InputClass "eKeyboard"
[ 1264.838] (II) Using input driver 'evdev' for 'Lenovo EasyCamera'
[ 1264.838] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
[ 1264.838] (**) Lenovo EasyCamera: always reports core events
[ 1264.838] (**) Lenovo EasyCamera: Device: "/dev/input/event6"
[ 1264.838] (--) Lenovo EasyCamera: Found keys
[ 1264.838] (II) Lenovo EasyCamera: Configuring as keyboard
[ 1264.838] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1a.7/usb1/1-3/1-3:1.0/input/input6/event6"
[ 1264.838] (II) XINPUT: Adding extended input device "Lenovo EasyCamera" (type: KEYBOARD)
[ 1264.838] (**) Option "xkb_rules" "evdev"
[ 1264.838] (**) Option "xkb_model" "pc105"
[ 1264.838] (**) Option "xkb_layout" "us,fr"
[ 1264.838] (**) Option "xkb_options" "grp:alt_shift_toggle,grp:switch,grp_led:scroll,terminate:ctrl_alt_bksp"
[ 1264.844] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event0)
[ 1264.844] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[ 1264.844] (**) AT Translated Set 2 keyboard: Applying InputClass "eKeyboard"
[ 1264.844] (II) Using input driver 'evdev' for 'AT Translated Set 2 keyboard'
[ 1264.844] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
[ 1264.844] (**) AT Translated Set 2 keyboard: always reports core events
[ 1264.844] (**) AT Translated Set 2 keyboard: Device: "/dev/input/event0"
[ 1264.844] (--) AT Translated Set 2 keyboard: Found keys
[ 1264.844] (II) AT Translated Set 2 keyboard: Configuring as keyboard
[ 1264.844] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input0/event0"
[ 1264.844] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)
[ 1264.844] (**) Option "xkb_rules" "evdev"
[ 1264.844] (**) Option "xkb_model" "pc105"
[ 1264.844] (**) Option "xkb_layout" "us,fr"
[ 1264.844] (**) Option "xkb_options" "grp:alt_shift_toggle,grp:switch,grp_led:scroll,terminate:ctrl_alt_bksp"
[ 1264.844] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/event1)
[ 1264.844] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "evdev touchpad catchall"
[ 1264.844] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad catchall"
[ 1264.844] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "eTouchpad"
[ 1264.844] (II) LoadModule: "synaptics"
[ 1264.844] (II) Loading /usr/lib64/xorg/modules/input/synaptics_drv.so
[ 1264.844] (II) Module synaptics: vendor="X.Org Foundation"
[ 1264.844] compiled for 1.10.4, module version = 1.4.0
[ 1264.844] Module class: X.Org XInput Driver
[ 1264.844] ABI class: X.Org XInput driver, version 12.2
[ 1264.844] (II) Using input driver 'synaptics' for 'SynPS/2 Synaptics TouchPad'
[ 1264.845] (II) Loading /usr/lib64/xorg/modules/input/synaptics_drv.so
[ 1264.845] (**) SynPS/2 Synaptics TouchPad: always reports core events
[ 1264.845] (**) Option "Device" "/dev/input/event1"
[ 1264.871] (--) SynPS/2 Synaptics TouchPad: x-axis range 1472 - 5472
[ 1264.871] (--) SynPS/2 Synaptics TouchPad: y-axis range 1408 - 4448
[ 1264.871] (--) SynPS/2 Synaptics TouchPad: pressure range 0 - 255
[ 1264.871] (--) SynPS/2 Synaptics TouchPad: finger width range 0 - 15
[ 1264.871] (--) SynPS/2 Synaptics TouchPad: buttons: left right
[ 1264.871] (**) Option "VertTwoFingerScroll" "1"
[ 1264.871] (**) Option "TapButton1" "1"
[ 1264.871] (**) Option "TapButton2" "2"
[ 1264.871] (**) Option "TapButton3" "3"
[ 1264.903] (--) SynPS/2 Synaptics TouchPad: touchpad found
[ 1264.903] (**) SynPS/2 Synaptics TouchPad: always reports core events
[ 1264.935] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio2/input/input1/event1"
[ 1264.935] (II) XINPUT: Adding extended input device "SynPS/2 Synaptics TouchPad" (type: TOUCHPAD)
[ 1264.935] (**) SynPS/2 Synaptics TouchPad: (accel) MinSpeed is now constant deceleration 2.5
[ 1264.935] (**) SynPS/2 Synaptics TouchPad: MaxSpeed is now 1.75
[ 1264.935] (**) SynPS/2 Synaptics TouchPad: AccelFactor is now 0.040
[ 1264.935] (**) SynPS/2 Synaptics TouchPad: (accel) keeping acceleration scheme 1
[ 1264.935] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration profile 1
[ 1264.935] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration factor: 2.000
[ 1264.935] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration threshold: 4
[ 1264.935] (--) SynPS/2 Synaptics TouchPad: touchpad found
[ 1264.935] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/mouse0)
[ 1264.935] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad catchall"
[ 1264.935] (II) Using input driver 'synaptics' for 'SynPS/2 Synaptics TouchPad'
[ 1264.936] (II) Loading /usr/lib64/xorg/modules/input/synaptics_drv.so
[ 1264.936] (**) SynPS/2 Synaptics TouchPad: always reports core events
[ 1264.936] (**) Option "Device" "/dev/input/mouse0"
[ 1264.936] (--) SynPS/2 Synaptics TouchPad: invalid x-axis range. defaulting to 1615 - 5685
[ 1264.936] (--) SynPS/2 Synaptics TouchPad: invalid y-axis range. defaulting to 1729 - 4171
[ 1264.936] (--) SynPS/2 Synaptics TouchPad: invalid pressure range. defaulting to 0 - 256
[ 1264.936] (--) SynPS/2 Synaptics TouchPad: invalid finger width range. defaulting to 0 - 16
[ 1264.957] (EE) Query no Synaptics: 6003C8
[ 1264.957] (--) SynPS/2 Synaptics TouchPad: no supported touchpad found
[ 1264.957] (EE) SynPS/2 Synaptics TouchPad Unable to query/initialize Synaptics hardware.
[ 1264.968] (EE) PreInit returned 11 for "SynPS/2 Synaptics TouchPad"
[ 1264.968] (II) UnloadModule: "synaptics"
[ 1264.968] (II) Unloading synaptics
[ 1264.968] (II) config/udev: Adding input device Ideapad extra buttons (/dev/input/event5)
[ 1264.968] (**) Ideapad extra buttons: Applying InputClass "evdev keyboard catchall"
[ 1264.968] (**) Ideapad extra buttons: Applying InputClass "eKeyboard"
[ 1264.968] (II) Using input driver 'evdev' for 'Ideapad extra buttons'
[ 1264.968] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
[ 1264.968] (**) Ideapad extra buttons: always reports core events
[ 1264.968] (**) Ideapad extra buttons: Device: "/dev/input/event5"
[ 1264.968] (--) Ideapad extra buttons: Found keys
[ 1264.968] (II) Ideapad extra buttons: Configuring as keyboard
[ 1264.968] (**) Option "config_info" "udev:/sys/devices/platform/ideapad/input/input5/event5"
[ 1264.968] (II) XINPUT: Adding extended input device "Ideapad extra buttons" (type: KEYBOARD)
[ 1264.968] (**) Option "xkb_rules" "evdev"
[ 1264.968] (**) Option "xkb_model" "pc105"
[ 1264.968] (**) Option "xkb_layout" "us,fr"
[ 1264.968] (**) Option "xkb_options" "grp:alt_shift_toggle,grp:switch,grp_led:scroll,terminate:ctrl_alt_bksp"
[ 1265.148] (II) intel(0): EDID vendor "CMO", prod id 4883
[ 1265.148] (II) intel(0): Printing DDC gathered Modelines:
[ 1265.148] (II) intel(0): Modeline "1280x800"x0.0 71.00 1280 1328 1360 1440 800 803 809 823 -hsync -vsync (49.3 kHz)
[ 1265.166] (II) intel(0): EDID vendor "CMO", prod id 4883
[ 1265.166] (II) intel(0): Printing DDC gathered Modelines:
[ 1265.166] (II) intel(0): Modeline "1280x800"x0.0 71.00 1280 1328 1360 1440 800 803 809 823 -hsync -vsync (49.3 kHz)
[ 1265.184] (II) intel(0): EDID vendor "CMO", prod id 4883
[ 1265.184] (II) intel(0): Printing DDC gathered Modelines:
[ 1265.184] (II) intel(0): Modeline "1280x800"x0.0 71.00 1280 1328 1360 1440 800 803 809 823 -hsync -vsync (49.3 kHz)
[ 1265.202] (II) intel(0): EDID vendor "CMO", prod id 4883
[ 1265.202] (II) intel(0): Printing DDC gathered Modelines:
[ 1265.202] (II) intel(0): Modeline "1280x800"x0.0 71.00 1280 1328 1360 1440 800 803 809 823 -hsync -vsync (49.3 kHz)

Thanks for any input.


Last edited by tclover on Fri Oct 21, 2011 10:17 pm; edited 2 times in total
Back to top
View user's profile Send private message
tclover
Guru
Guru


Joined: 10 Apr 2011
Posts: 516

PostPosted: Fri Oct 21, 2011 10:15 pm    Post subject: Reply with quote

It's a intel driver well know issue for old IGP that cripples DRI/GPU acceleration.
Quote:
So it was a hardware issue with [xf86-video-]intel driver. Maybe it's related to my recent xorg-sever-1.10.4 migration but I cannot remember clearly if it's the case. I have now a "hung GPU" error in Xorg.0.log or in dmesg when using i915 kernel module with drm. So, the hint of being able to run an e17 session without ecomorph was more than a hint, GPU acceleration just fails in this known issue of intel driver.

So I've just roll out a radeon profile (vga swicheroo) back. However the discret card runs very hotter than the IGP, especially with the "default" PM profile. "dynpm" is still unstable which trigger graphic glitches all the time. "low" PM "profile" run 5-10° hotter than with the IGP, well my CPU runs with 5-10° more than when using the IGP, so the discret card is running much more hotter than the IGP. "default" "profile" is simple unusable...

Will look for a 3.1 upgrade asap when Linus release that version in very few days in an attempt to get fixes of the IGP. I know that there's radeon fixes but fail to remember if there're some for i915 and/or KMS/DRM.
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 2152
Location: Berlin, Germany

PostPosted: Fri Oct 21, 2011 11:13 pm    Post subject: Reply with quote

You are using uvesafb which doesn't work with KMS. Follow the kernel configuration instructions at http://www.gentoo.org/doc/en/xorg-config.xml
Back to top
View user's profile Send private message
tclover
Guru
Guru


Joined: 10 Apr 2011
Posts: 516

PostPosted: Sat Oct 22, 2011 2:08 pm    Post subject: Thanks! Reply with quote

Ah yes, thanks chithanh. I tend to forget that... and thanks to you (a post of yours on this same topic: nouveau/i*/radeon/DRM/{,u}vesafb) that I get nouveau working without black screen because of... uvesafb. Well, lets see what I can do because I can run X on top of nouveau/DRM after having booted with uvesafb (a little script take care of that, or it does switch to nvidia if necessary/wanted depending on...).
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum