Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
no response from keyboard and mouse in X
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
ground0
n00b
n00b


Joined: 05 Oct 2010
Posts: 24
Location: Bremen, Germany

PostPosted: Tue Oct 11, 2011 5:16 pm    Post subject: no response from keyboard and mouse in X Reply with quote

I haven't been upgrading my gentoo system for a couple of months. Now, I updated it, everything went fine, except when I login to Gnome ("startx"), the mouse and keyboard don't work. It's a little strange because touchpad is working. I looked at "xorg.conf" file and its log file, but I don't see anything wrong there. Also, as a last resort, I reinstalled xorg-server, but didn't help. So, this makes me believe that the problem must be with config files. Anybody please can help me to pin down the problem.

Here is my xorg.conf file:

Code:


Section "ServerLayout"
   Identifier     "X.org Configured"
   Screen      0  "Screen0" 0 0
   InputDevice    "Mouse0" "CorePointer"
   InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
   ModulePath   "/usr/lib/xorg/modules"
   FontPath     "/usr/share/fonts/misc/"
   FontPath     "/usr/share/fonts/TTF/"
   FontPath     "/usr/share/fonts/OTF"
   FontPath     "/usr/share/fonts/Type1/"
   FontPath     "/usr/share/fonts/100dpi/"
   FontPath     "/usr/share/fonts/75dpi/"
EndSection

Section "Module"
   Load  "record"
   Load  "dri"
   Load  "glx"
   Load  "dbe"
   Load  "extmod"
   Load  "dri2"
EndSection

Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
EndSection

Section "InputDevice"
   Identifier  "Mouse0"
   Driver      "mouse"
   Option       "Protocol" "auto"
   Option       "Device" "/dev/input/mice"
   Option       "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
   Identifier   "Monitor0"
   VendorName   "Monitor Vendor"
   ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "NoAccel"               # [<bool>]
        #Option     "SWcursor"              # [<bool>]
        #Option     "ColorKey"              # <i>
        #Option     "CacheLines"            # <i>
        #Option     "Dac6Bit"               # [<bool>]
        #Option     "DRI"                   # [<bool>]
        #Option     "NoDDC"                 # [<bool>]
        #Option     "ShowCache"             # [<bool>]
        #Option     "XvMCSurfaces"          # <i>
        #Option     "PageFlip"              # [<bool>]
   Identifier  "Card0"
   Driver      "intel"
   VendorName  "Intel Corporation"
   BoardName   "Mobile 915GM/GMS/910GML Express Graphics Controller"
   BusID       "PCI:0:2:0"
EndSection

Section "Screen"
   Identifier "Screen0"
   Device     "Card0"
   Monitor    "Monitor0"
   SubSection "Display"
      Viewport   0 0
      Depth     1
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     4
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     8
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     15
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     16
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection

Section "InputClass"
   Identifier "synaptics-all"
   Driver "synaptics"
   Option "RTCornerButton" "Z"
   Option "HorizEdgeScroll" "true"

   MatchIsTouchpad "on"
EndSection

Section "InputClass"
   Identifier "keyboard-all"
   Driver "evdev"
   Option "XkbLayout" "us"
   Option "XkbVariant" "qwerty"
   Option "XkbOptions" "terminate:ctrl_alt_bksp"

   MatchIsKeyboard "on"
EndSection

Section "InputClass"
   Identifier "mouse-all"
   Driver "evdev"

   MatchIsPointer "on"
EndSection


and this is my Xorg.0.log file:

Code:

[  6262.550]
X.Org X Server 1.10.4
Release Date: 2011-08-19
[  6262.557] X Protocol Version 11, Revision 0
[  6262.559] Build Operating System: Linux 2.6.36-gentoo-r8 i686 Gentoo
[  6262.561] Current Operating System: Linux blizzard 2.6.36-gentoo-r8 #9 Tue Apr 5 23:00:54 CEST 2011 i686
[  6262.563] Kernel command line: BOOT_IMAGE=/boot/kernel-2.6.36-gentoo-r8 root=/dev/sda3 ro acpi=off
[  6262.566] Build Date: 11 October 2011  07:42:07AM
[  6262.568] 
[  6262.571] Current version of pixman: 0.22.2
[  6262.573]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[  6262.578] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  6262.586] (==) Log file: "/var/log/Xorg.0.log", Time: Tue Oct 11 09:18:13 2011
[  6262.589] (==) Using config file: "/etc/X11/xorg.conf"
[  6262.592] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  6262.596] (==) ServerLayout "X.org Configured"
[  6262.596] (**) |-->Screen "Screen0" (0)
[  6262.596] (**) |   |-->Monitor "Monitor0"
[  6262.596] (**) |   |-->Device "Card0"
[  6262.596] (**) |-->Input Device "Mouse0"
[  6262.596] (**) |-->Input Device "Keyboard0"
[  6262.596] (==) Automatically adding devices
[  6262.596] (==) Automatically enabling devices
[  6262.596] (WW) The directory "/usr/share/fonts/misc/" does not exist.
[  6262.596]    Entry deleted from font path.
[  6262.596] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[  6262.596]    Entry deleted from font path.
[  6262.596] (WW) The directory "/usr/share/fonts/OTF" does not exist.
[  6262.596]    Entry deleted from font path.
[  6262.596] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[  6262.596]    Entry deleted from font path.
[  6262.597] (WW) The directory "/usr/share/fonts/100dpi/" does not exist.
[  6262.597]    Entry deleted from font path.
[  6262.597] (WW) The directory "/usr/share/fonts/75dpi/" does not exist.
[  6262.597]    Entry deleted from font path.
[  6262.597] (WW) The directory "/usr/share/fonts/misc/" does not exist.
[  6262.597]    Entry deleted from font path.
[  6262.597] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[  6262.597]    Entry deleted from font path.
[  6262.597] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[  6262.597]    Entry deleted from font path.
[  6262.597] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[  6262.597]    Entry deleted from font path.
[  6262.597] (WW) The directory "/usr/share/fonts/100dpi/" does not exist.
[  6262.597]    Entry deleted from font path.
[  6262.597] (WW) The directory "/usr/share/fonts/75dpi/" does not exist.
[  6262.597]    Entry deleted from font path.
[  6262.597] (**) FontPath set to:
   
[  6262.597] (**) ModulePath set to "/usr/lib/xorg/modules"
[  6262.597] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[  6262.597] (WW) Disabling Mouse0
[  6262.597] (WW) Disabling Keyboard0
[  6262.597] (II) Loader magic: 0x81f5d00
[  6262.597] (II) Module ABI versions:
[  6262.597]    X.Org ANSI C Emulation: 0.4
[  6262.597]    X.Org Video Driver: 10.0
[  6262.597]    X.Org XInput driver : 12.2
[  6262.597]    X.Org Server Extension : 5.0
[  6262.598] (--) PCI:*(0:0:2:0) 8086:2592:1179:ff10 rev 3, Mem @ 0xd0000000/524288, 0xa0000000/268435456, 0xd0080000/262144, I/O @ 0x0000e000/8
[  6262.599] (--) PCI: (0:0:2:1) 8086:2792:1179:ff10 rev 3, Mem @ 0xd0100000/524288
[  6262.599] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[  6262.599] (II) "extmod" will be loaded. This was enabled by default and also specified in the config file.
[  6262.599] (II) "dbe" will be loaded. This was enabled by default and also specified in the config file.
[  6262.599] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
[  6262.599] (II) "record" will be loaded. This was enabled by default and also specified in the config file.
[  6262.599] (II) "dri" will be loaded. This was enabled by default and also specified in the config file.
[  6262.599] (II) "dri2" will be loaded. This was enabled by default and also specified in the config file.
[  6262.599] (II) LoadModule: "record"
[  6262.599] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[  6262.599] (II) Module record: vendor="X.Org Foundation"
[  6262.599]    compiled for 1.10.4, module version = 1.13.0
[  6262.599]    Module class: X.Org Server Extension
[  6262.600]    ABI class: X.Org Server Extension, version 5.0
[  6262.600] (II) Loading extension RECORD
[  6262.600] (II) LoadModule: "dri"
[  6262.600] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
[  6262.600] (II) Module dri: vendor="X.Org Foundation"
[  6262.600]    compiled for 1.10.4, module version = 1.0.0
[  6262.600]    ABI class: X.Org Server Extension, version 5.0
[  6262.600] (II) Loading extension XFree86-DRI
[  6262.600] (II) LoadModule: "glx"
[  6262.600] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[  6262.601] (II) Module glx: vendor="X.Org Foundation"
[  6262.601]    compiled for 1.10.4, module version = 1.0.0
[  6262.601]    ABI class: X.Org Server Extension, version 5.0
[  6262.601] (==) AIGLX enabled
[  6262.601] (II) Loading extension GLX
[  6262.601] (II) LoadModule: "dbe"
[  6262.601] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
[  6262.601] (II) Module dbe: vendor="X.Org Foundation"
[  6262.601]    compiled for 1.10.4, module version = 1.0.0
[  6262.601]    Module class: X.Org Server Extension
[  6262.601]    ABI class: X.Org Server Extension, version 5.0
[  6262.601] (II) Loading extension DOUBLE-BUFFER
[  6262.601] (II) LoadModule: "extmod"
[  6262.601] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
[  6262.602] (II) Module extmod: vendor="X.Org Foundation"
[  6262.602]    compiled for 1.10.4, module version = 1.0.0
[  6262.602]    Module class: X.Org Server Extension
[  6262.602]    ABI class: X.Org Server Extension, version 5.0
[  6262.602] (II) Loading extension MIT-SCREEN-SAVER
[  6262.602] (II) Loading extension XFree86-VidModeExtension
[  6262.602] (II) Loading extension XFree86-DGA
[  6262.602] (II) Loading extension DPMS
[  6262.602] (II) Loading extension XVideo
[  6262.602] (II) Loading extension XVideo-MotionCompensation
[  6262.602] (II) Loading extension X-Resource
[  6262.602] (II) LoadModule: "dri2"
[  6262.602] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[  6262.602] (II) Module dri2: vendor="X.Org Foundation"
[  6262.602]    compiled for 1.10.4, module version = 1.2.0
[  6262.602]    ABI class: X.Org Server Extension, version 5.0
[  6262.602] (II) Loading extension DRI2
[  6262.602] (II) LoadModule: "intel"
[  6262.603] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[  6262.603] (II) Module intel: vendor="X.Org Foundation"
[  6262.603]    compiled for 1.10.4, module version = 2.15.0
[  6262.603]    Module class: X.Org Video Driver
[  6262.603]    ABI class: X.Org Video Driver, version 10.0
[  6262.603] (II) intel: Driver for Intel Integrated Graphics Chipsets: i810,
   i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G, 915G,
   E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM, Pineview G,
   965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33, GM45,
   4 Series, G45/G43, Q45/Q43, G41, B43, B43, Clarkdale, Arrandale,
   Sandybridge, Sandybridge, Sandybridge, Sandybridge, Sandybridge,
   Sandybridge, Sandybridge
[  6262.604] (--) using VT number 7

[  6262.623] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[  6262.623] drmOpenDevice: node name is /dev/dri/card0
[  6262.623] drmOpenDevice: open result is 8, (OK)
[  6262.623] drmOpenByBusid: Searching for BusID pci:0000:00:02.0
[  6262.623] drmOpenDevice: node name is /dev/dri/card0
[  6262.623] drmOpenDevice: open result is 8, (OK)
[  6262.623] drmOpenByBusid: drmOpenMinor returns 8
[  6262.623] drmOpenByBusid: drmGetBusid reports pci:0000:00:02.0
[  6262.623] (==) intel(0): Depth 24, (--) framebuffer bpp 32
[  6262.623] (==) intel(0): RGB weight 888
[  6262.623] (==) intel(0): Default visual is TrueColor
[  6262.623] (II) intel(0): Integrated Graphics Chipset: Intel(R) 915GM
[  6262.623] (--) intel(0): Chipset: "915GM"
[  6262.624] (**) intel(0): Relaxed fencing disabled
[  6262.624] (**) intel(0): Framebuffer tiled
[  6262.624] (**) intel(0): Pixmaps tiled
[  6262.624] (**) intel(0): 3D buffers tiled
[  6262.624] (**) intel(0): SwapBuffers wait enabled
[  6262.624] (==) intel(0): video overlay key set to 0x101fe
[  6262.734] (II) intel(0): Output LVDS1 using monitor section Monitor0
[  6262.841] (II) intel(0): Output VGA1 has no monitor section
[  6263.129] (II) intel(0): Output TV1 has no monitor section
[  6263.235] (II) intel(0): EDID for output LVDS1
[  6263.235] (II) intel(0): Manufacturer: SEC  Model: 3633  Serial#: 0
[  6263.235] (II) intel(0): Year: 2005  Week: 0
[  6263.235] (II) intel(0): EDID Version: 1.3
[  6263.235] (II) intel(0): Digital Display Input
[  6263.235] (II) intel(0): Max Image Size [cm]: horiz.: 33  vert.: 21
[  6263.235] (II) intel(0): Gamma: 2.20
[  6263.236] (II) intel(0): No DPMS capabilities specified
[  6263.236] (II) intel(0): Supported color encodings: RGB 4:4:4 YCrCb 4:4:4
[  6263.236] (II) intel(0): First detailed timing is preferred mode
[  6263.236] (II) intel(0): redX: 0.580 redY: 0.340   greenX: 0.310 greenY: 0.550
[  6263.236] (II) intel(0): blueX: 0.155 blueY: 0.155   whiteX: 0.313 whiteY: 0.329
[  6263.236] (II) intel(0): Manufacturer's mask: 0
[  6263.236] (II) intel(0): Supported detailed timing:
[  6263.236] (II) intel(0): clock: 68.9 MHz   Image Size:  331 x 207 mm
[  6263.236] (II) intel(0): h_active: 1280  h_sync: 1296  h_sync_end 1344 h_blank_end 1408 h_border: 0
[  6263.236] (II) intel(0): v_active: 800  v_sync: 801  v_sync_end 804 v_blanking: 816 v_border: 0
[  6263.236] (II) intel(0): Unknown vendor-specific block f
[  6263.236] (II) intel(0):  SAMSUNG
[  6263.236] (II) intel(0):  LTN154X3-L06
[  6263.236] (II) intel(0): EDID (in hex):
[  6263.236] (II) intel(0):    00ffffffffffff004ca3333600000000
[  6263.236] (II) intel(0):    000f0103802115780a87f594574f8c27
[  6263.236] (II) intel(0):    27505400000001010101010101010101
[  6263.236] (II) intel(0):    010101010101ee1a0080502010301030
[  6263.236] (II) intel(0):    13004bcf100000190000000f00000000
[  6263.236] (II) intel(0):    00000000002387026402000000fe0053
[  6263.236] (II) intel(0):    414d53554e470a2020202020000000fe
[  6263.236] (II) intel(0):    004c544e31353458332d4c30360a0070
[  6263.236] (II) intel(0): EDID vendor "SEC", prod id 13875
[  6263.236] (II) intel(0): Printing DDC gathered Modelines:
[  6263.236] (II) intel(0): Modeline "1280x800"x0.0   68.94  1280 1296 1344 1408  800 801 804 816 -hsync -vsync (49.0 kHz)
[  6263.236] (II) intel(0): Not using default mode "320x240" (doublescan mode not supported)
[  6263.237] (II) intel(0): Not using default mode "400x300" (doublescan mode not supported)
[  6263.237] (II) intel(0): Not using default mode "400x300" (doublescan mode not supported)
[  6263.237] (II) intel(0): Not using default mode "512x384" (doublescan mode not supported)
[  6263.237] (II) intel(0): Not using default mode "640x480" (doublescan mode not supported)
[  6263.237] (II) intel(0): Not using default mode "640x512" (doublescan mode not supported)
[  6263.237] (II) intel(0): Not using default mode "800x600" (doublescan mode not supported)
[  6263.237] (II) intel(0): Not using default mode "896x672" (doublescan mode not supported)
[  6263.237] (II) intel(0): Not using default mode "928x696" (doublescan mode not supported)
[  6263.237] (II) intel(0): Not using default mode "960x720" (doublescan mode not supported)
[  6263.237] (II) intel(0): Not using default mode "700x525" (doublescan mode not supported)
[  6263.237] (II) intel(0): Not using default mode "1024x768" (doublescan mode not supported)
[  6263.237] (II) intel(0): Printing probed modes for output LVDS1
[  6263.237] (II) intel(0): Modeline "1280x800"x60.0   68.94  1280 1296 1344 1408  800 801 804 816 -hsync -vsync (49.0 kHz)
[  6263.237] (II) intel(0): Modeline "1024x768"x60.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz)
[  6263.237] (II) intel(0): Modeline "800x600"x60.3   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz)
[  6263.237] (II) intel(0): Modeline "800x600"x56.2   36.00  800 824 896 1024  600 601 603 625 +hsync +vsync (35.2 kHz)
[  6263.237] (II) intel(0): Modeline "640x480"x59.9   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz)
[  6263.344] (II) intel(0): EDID for output VGA1
[  6263.645] (II) intel(0): EDID for output TV1
[  6263.645] (II) intel(0): Output LVDS1 connected
[  6263.645] (II) intel(0): Output VGA1 disconnected
[  6263.645] (II) intel(0): Output TV1 disconnected
[  6263.645] (II) intel(0): Using exact sizes for initial modes
[  6263.645] (II) intel(0): Output LVDS1 using initial mode 1280x800
[  6263.645] (II) intel(0): Using default gamma of (1.0, 1.0, 1.0) unless otherwise stated.
[  6263.645] (II) intel(0): Kernel page flipping support detected, enabling
[  6263.645] (**) intel(0): Display dimensions: (330, 210) mm
[  6263.645] (**) intel(0): DPI set to (98, 96)
[  6263.645] (II) Loading sub module "fb"
[  6263.645] (II) LoadModule: "fb"
[  6263.645] (II) Loading /usr/lib/xorg/modules/libfb.so
[  6263.646] (II) Module fb: vendor="X.Org Foundation"
[  6263.646]    compiled for 1.10.4, module version = 1.0.0
[  6263.646]    ABI class: X.Org ANSI C Emulation, version 0.4
[  6263.646] (II) Loading sub module "dri2"
[  6263.646] (II) LoadModule: "dri2"
[  6263.646] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[  6263.646] (II) Module dri2: vendor="X.Org Foundation"
[  6263.646]    compiled for 1.10.4, module version = 1.2.0
[  6263.646]    ABI class: X.Org Server Extension, version 5.0
[  6263.646] (==) Depth 24 pixmap format is 32 bpp
[  6263.646] (II) intel(0): [DRI2] Setup complete
[  6263.646] (II) intel(0): [DRI2]   DRI driver: i915
[  6263.646] (II) intel(0): Allocated new frame buffer 1280x800 stride 8192, tiled
[  6263.647] (II) UXA(0): Driver registered support for the following operations:
[  6263.647] (II)         solid
[  6263.647] (II)         copy
[  6263.647] (II)         composite (RENDER acceleration)
[  6263.647] (II)         put_image
[  6263.647] (II)         get_image
[  6263.647] (==) intel(0): Backing store disabled
[  6263.647] (==) intel(0): Silken mouse enabled
[  6263.647] (II) intel(0): Initializing HW Cursor
[  6263.675] (II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[  6263.675] (==) intel(0): DPMS enabled
[  6263.675] (==) intel(0): Intel XvMC decoder disabled
[  6263.675] (II) intel(0): Set up textured video
[  6263.675] (II) intel(0): Set up overlay video
[  6263.676] (II) intel(0): direct rendering: DRI2 Enabled
[  6263.676] (==) intel(0): hotplug detection: "enabled"
[  6263.676] (--) RandR disabled
[  6263.676] (II) Initializing built-in extension Generic Event Extension
[  6263.676] (II) Initializing built-in extension SHAPE
[  6263.676] (II) Initializing built-in extension MIT-SHM
[  6263.676] (II) Initializing built-in extension XInputExtension
[  6263.676] (II) Initializing built-in extension XTEST
[  6263.676] (II) Initializing built-in extension BIG-REQUESTS
[  6263.676] (II) Initializing built-in extension SYNC
[  6263.676] (II) Initializing built-in extension XKEYBOARD
[  6263.676] (II) Initializing built-in extension XC-MISC
[  6263.676] (II) Initializing built-in extension XINERAMA
[  6263.676] (II) Initializing built-in extension XFIXES
[  6263.676] (II) Initializing built-in extension RENDER
[  6263.676] (II) Initializing built-in extension RANDR
[  6263.676] (II) Initializing built-in extension COMPOSITE
[  6263.676] (II) Initializing built-in extension DAMAGE
[  6263.711] (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
[  6263.711] (II) AIGLX: enabled GLX_INTEL_swap_event
[  6263.711] (II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
[  6263.711] (II) AIGLX: enabled GLX_SGI_make_current_read
[  6263.711] (II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
[  6263.712] (II) AIGLX: Loaded and initialized /usr/lib/dri/i915_dri.so
[  6263.712] (II) GLX: Initialized DRI2 GL provider for screen 0
[  6263.713] (II) intel(0): Setting screen physical size to 338 x 211
[  6263.796] (II) config/udev: Adding input device Logitech USB-PS/2 Optical Mouse (/dev/input/event1)
[  6263.796] (**) Logitech USB-PS/2 Optical Mouse: Applying InputClass "evdev pointer catchall"
[  6263.796] (**) Logitech USB-PS/2 Optical Mouse: Applying InputClass "mouse-all"
[  6263.796] (II) LoadModule: "evdev"
[  6263.797] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[  6263.797] (II) Module evdev: vendor="X.Org Foundation"
[  6263.797]    compiled for 1.9.4, module version = 2.6.0
[  6263.797]    Module class: X.Org XInput Driver
[  6263.797]    ABI class: X.Org XInput driver, version 11.0
[  6263.797] (EE) module ABI major version (11) doesn't match the server's version (12)
[  6263.797] (II) UnloadModule: "evdev"
[  6263.797] (II) Unloading evdev
[  6263.797] (EE) Failed to load module "evdev" (module requirement mismatch, 0)
[  6263.797] (EE) No input driver matching `evdev'
[  6263.798] (II) config/udev: Adding input device Logitech USB-PS/2 Optical Mouse (/dev/input/mouse0)
[  6263.798] (**) Logitech USB-PS/2 Optical Mouse: Applying InputClass "mouse-all"
[  6263.798] (II) LoadModule: "evdev"
[  6263.798] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[  6263.798] (II) Module evdev: vendor="X.Org Foundation"
[  6263.798]    compiled for 1.9.4, module version = 2.6.0
[  6263.798]    Module class: X.Org XInput Driver
[  6263.798]    ABI class: X.Org XInput driver, version 11.0
[  6263.798] (EE) module ABI major version (11) doesn't match the server's version (12)
[  6263.798] (II) UnloadModule: "evdev"
[  6263.798] (II) Unloading evdev
[  6263.798] (EE) Failed to load module "evdev" (module requirement mismatch, 0)
[  6263.798] (EE) No input driver matching `evdev'
[  6263.809] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event0)
[  6263.809] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[  6263.809] (**) AT Translated Set 2 keyboard: Applying InputClass "keyboard-all"
[  6263.809] (II) LoadModule: "evdev"
[  6263.809] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[  6263.809] (II) Module evdev: vendor="X.Org Foundation"
[  6263.809]    compiled for 1.9.4, module version = 2.6.0
[  6263.809]    Module class: X.Org XInput Driver
[  6263.809]    ABI class: X.Org XInput driver, version 11.0
[  6263.810] (EE) module ABI major version (11) doesn't match the server's version (12)
[  6263.810] (II) UnloadModule: "evdev"
[  6263.810] (II) Unloading evdev
[  6263.810] (EE) Failed to load module "evdev" (module requirement mismatch, 0)
[  6263.810] (EE) No input driver matching `evdev'
[  6263.810] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/event2)
[  6263.810] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "evdev touchpad catchall"
[  6263.810] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad catchall"
[  6263.810] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "synaptics-all"
[  6263.810] (II) LoadModule: "synaptics"
[  6263.811] (II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
[  6263.811] (II) Module synaptics: vendor="X.Org Foundation"
[  6263.811]    compiled for 1.10.4, module version = 1.4.0
[  6263.811]    Module class: X.Org XInput Driver
[  6263.811]    ABI class: X.Org XInput driver, version 12.2
[  6263.811] (II) Using input driver 'synaptics' for 'SynPS/2 Synaptics TouchPad'
[  6263.811] (II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
[  6263.811] (**) SynPS/2 Synaptics TouchPad: always reports core events
[  6263.811] (**) Option "Device" "/dev/input/event2"
[  6263.811] (--) SynPS/2 Synaptics TouchPad: x-axis range 1472 - 5472
[  6263.811] (--) SynPS/2 Synaptics TouchPad: y-axis range 1408 - 4448
[  6263.811] (--) SynPS/2 Synaptics TouchPad: pressure range 0 - 255
[  6263.811] (--) SynPS/2 Synaptics TouchPad: finger width range 0 - 15
[  6263.811] (--) SynPS/2 Synaptics TouchPad: buttons: left right double triple
[  6263.811] (**) Option "HorizEdgeScroll" "true"
[  6263.811] (WW) Option "RTCornerButton" requires an integer value
[  6263.812] (--) SynPS/2 Synaptics TouchPad: touchpad found
[  6263.812] (**) SynPS/2 Synaptics TouchPad: always reports core events
[  6263.812] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio1/input/input2/event2"
[  6263.812] (II) XINPUT: Adding extended input device "SynPS/2 Synaptics TouchPad" (type: TOUCHPAD)
[  6263.812] (**) SynPS/2 Synaptics TouchPad: (accel) MinSpeed is now constant deceleration 2.5
[  6263.812] (**) SynPS/2 Synaptics TouchPad: MaxSpeed is now 1.75
[  6263.812] (**) SynPS/2 Synaptics TouchPad: AccelFactor is now 0.040
[  6263.812] (**) SynPS/2 Synaptics TouchPad: (accel) keeping acceleration scheme 1
[  6263.812] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration profile 1
[  6263.812] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration factor: 2.000
[  6263.812] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration threshold: 4
[  6263.812] (--) SynPS/2 Synaptics TouchPad: touchpad found
[  6263.813] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/mouse1)
[  6263.813] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad catchall"
[  6263.813] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "synaptics-all"
[  6263.813] (II) Using input driver 'synaptics' for 'SynPS/2 Synaptics TouchPad'
[  6263.813] (II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
[  6263.813] (**) SynPS/2 Synaptics TouchPad: always reports core events
[  6263.813] (**) Option "Device" "/dev/input/mouse1"
[  6263.813] (--) SynPS/2 Synaptics TouchPad: invalid x-axis range.  defaulting to 1615 - 5685
[  6263.813] (--) SynPS/2 Synaptics TouchPad: invalid y-axis range.  defaulting to 1729 - 4171
[  6263.813] (--) SynPS/2 Synaptics TouchPad: invalid pressure range.  defaulting to 0 - 256
[  6263.813] (--) SynPS/2 Synaptics TouchPad: invalid finger width range.  defaulting to 0 - 16
[  6263.813] (**) Option "HorizEdgeScroll" "true"
[  6263.813] (WW) Option "RTCornerButton" requires an integer value
[  6263.834] (EE) Query no Synaptics: 6003C8
[  6263.834] (--) SynPS/2 Synaptics TouchPad: no supported touchpad found
[  6263.834] (EE) SynPS/2 Synaptics TouchPad Unable to query/initialize Synaptics hardware.
[  6263.834] (EE) PreInit returned 11 for "SynPS/2 Synaptics TouchPad"
[  6263.834] (II) UnloadModule: "synaptics"
[  6263.834] (II) Unloading synaptics
[  6264.511] (II) intel(0): EDID vendor "SEC", prod id 13875
[  6264.511] (II) intel(0): Printing DDC gathered Modelines:
[  6264.511] (II) intel(0): Modeline "1280x800"x0.0   68.94  1280 1296 1344 1408  800 801 804 816 -hsync -vsync (49.0 kHz)
[  6265.016] (II) intel(0): EDID vendor "SEC", prod id 13875
[  6265.016] (II) intel(0): Printing DDC gathered Modelines:
[  6265.016] (II) intel(0): Modeline "1280x800"x0.0   68.94  1280 1296 1344 1408  800 801 804 816 -hsync -vsync (49.0 kHz)
[  6265.531] (II) intel(0): EDID vendor "SEC", prod id 13875
[  6265.531] (II) intel(0): Printing DDC gathered Modelines:
[  6265.531] (II) intel(0): Modeline "1280x800"x0.0   68.94  1280 1296 1344 1408  800 801 804 816 -hsync -vsync (49.0 kHz)
[  6266.044] (II) intel(0): EDID vendor "SEC", prod id 13875
[  6266.052] (II) intel(0): Printing DDC gathered Modelines:
[  6266.052] (II) intel(0): Modeline "1280x800"x0.0   68.94  1280 1296 1344 1408  800 801 804 816 -hsync -vsync (49.0 kHz)
[  6269.052] (II) intel(0): EDID vendor "SEC", prod id 13875
[  6269.053] (II) intel(0): Printing DDC gathered Modelines:
[  6269.053] (II) intel(0): Modeline "1280x800"x0.0   68.94  1280 1296 1344 1408  800 801 804 816 -hsync -vsync (49.0 kHz)
[  6310.046] (II) UnloadModule: "synaptics"
[  6310.046] (II) Unloading synaptics


Also, I have tried adding separate files for keyboard and mouse to "xorg.conf.d" directory, this didn't help too.
(I haven't upgraded my kernel to 2.6.39 yet; I use 2.6.36 at the moment. But I don't think this is what causes the problem, or is it? )

Any help would be much appreciated.
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2665
Location: Slovenia

PostPosted: Tue Oct 11, 2011 5:31 pm    Post subject: Reply with quote

Remove everything but the InputClass sections from your xorg.conf. I don't think that's the problem though, you probably simply need to re-emerge xf86-input-evdev.
Back to top
View user's profile Send private message
ground0
n00b
n00b


Joined: 05 Oct 2010
Posts: 24
Location: Bremen, Germany

PostPosted: Tue Oct 11, 2011 6:14 pm    Post subject: Reply with quote

Thanks a lot Gusar! I just re-emerged xf86-input-evdev, and everything works fine now.

I would have tried this but I didn't know emerge needs full name for "evdev" :)
"emerge evdev" can't even give correct suggestion for this package. So, this made me think that maybe "evdev" is some special thing that cannot be handled like other packages.
Back to top
View user's profile Send private message
golagoda
Tux's lil' helper
Tux's lil' helper


Joined: 18 Jun 2011
Posts: 105
Location: Australia

PostPosted: Thu Oct 13, 2011 12:34 pm    Post subject: Reply with quote

ground0 wrote:
Thanks a lot Gusar! I just re-emerged xf86-input-evdev, and everything works fine now.

I would have tried this but I didn't know emerge needs full name for "evdev" :)
"emerge evdev" can't even give correct suggestion for this package. So, this made me think that maybe "evdev" is some special thing that cannot be handled like other packages.


Every time you update xorg-server make sure to run 'qlist -I -C x11-drivers' and re-emerge the packages it lists.
Back to top
View user's profile Send private message
mattst88
Developer
Developer


Joined: 28 Oct 2004
Posts: 398

PostPosted: Thu Oct 13, 2011 6:12 pm    Post subject: Reply with quote

For reference, the error was right in your log.

Code:
[  6263.796] (II) LoadModule: "evdev"
[  6263.797] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[  6263.797] (II) Module evdev: vendor="X.Org Foundation"
[  6263.797]    compiled for 1.9.4, module version = 2.6.0
[  6263.797]    Module class: X.Org XInput Driver
[  6263.797]    ABI class: X.Org XInput driver, version 11.0
[  6263.797] (EE) module ABI major version (11) doesn't match the server's version (12)
[  6263.797] (II) UnloadModule: "evdev"
[  6263.797] (II) Unloading evdev
[  6263.797] (EE) Failed to load module "evdev" (module requirement mismatch, 0)
[  6263.797] (EE) No input driver matching `evdev'
Back to top
View user's profile Send private message
ground0
n00b
n00b


Joined: 05 Oct 2010
Posts: 24
Location: Bremen, Germany

PostPosted: Sat Oct 15, 2011 5:58 pm    Post subject: Reply with quote

Thank you very much for pointing out the error in the log file. Certainly, useful thing to know. I should have looked at the log file more carefully. And thanks a lot for the suggestion golagoda. I will try that command soon. Good to know ;)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum