Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
VirtualBox 4.0.12 does not work
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
YuriyRusinov
Apprentice
Apprentice


Joined: 21 Jul 2004
Posts: 208
Location: Saint-Petersburg, Russia

PostPosted: Fri Sep 23, 2011 4:25 pm    Post subject: VirtualBox 4.0.12 does not work Reply with quote

Hello, colleagues !

After upgrade virtualbox-4.0.12 I have an error

Code:

Failed to load VMMR0.r0 (VERR_SUPLIB_OWNER_NOT_ROOT).
Unknown error creating VM (VERR_SUPLIB_OWNER_NOT_ROOT).

NS_ERROR_FAILURE (0x80004005)

Console
Interface:
IConsole {515e8e8d-f932-4d8e-9f32-79a52aead882}

on any guest machine launch, permissions of VMMR0.r0 are
Code:

ls -l /usr/lib/virtualbox/VMMR0.r0
-rwxr-x--- 1 root vboxusers 647912 Sep  5 23:54 /usr/lib/virtualbox/VMMR0.r0
,
re-emerging of virtualbox does not help.

Any ideas.

Thanks a lot,
_________________
Best regards,
Yuriy Rusinov.
Back to top
View user's profile Send private message
_brian_
n00b
n00b


Joined: 02 Aug 2011
Posts: 16

PostPosted: Fri Sep 23, 2011 4:45 pm    Post subject: Reply with quote

I would recommend using the version from the official site (version 4.1.2) http://www.virtualbox.org/wiki/Downloads
Back to top
View user's profile Send private message
DaggyStyle
Watchman
Watchman


Joined: 22 Mar 2006
Posts: 5603

PostPosted: Fri Sep 23, 2011 7:18 pm    Post subject: Reply with quote

_brian_ wrote:
I would recommend using the version from the official site (version 4.1.2) http://www.virtualbox.org/wiki/Downloads


I'd recommend against this, this is linux, not windows. use the package manager, there is a reason why it exists.

in addition, the version mentioned is in portage but it is keyworded.
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
Back to top
View user's profile Send private message
Chris W
l33t
l33t


Joined: 25 Jun 2002
Posts: 972
Location: Brisbane, Australia

PostPosted: Sat Sep 24, 2011 9:20 am    Post subject: Reply with quote

Is your user in the group vboxusers?
_________________
Cheers,
Chris W
"Common sense: The collection of prejudices acquired by age 18." -- Einstein
Back to top
View user's profile Send private message
YuriyRusinov
Apprentice
Apprentice


Joined: 21 Jul 2004
Posts: 208
Location: Saint-Petersburg, Russia

PostPosted: Sat Sep 24, 2011 4:34 pm    Post subject: Reply with quote

Chris W wrote:
Is your user in the group vboxusers?

Of course, yes. It was added into vboxusers very very earlier, because it was necessary for VirtualBox-3.0
_________________
Best regards,
Yuriy Rusinov.
Back to top
View user's profile Send private message
YuriyRusinov
Apprentice
Apprentice


Joined: 21 Jul 2004
Posts: 208
Location: Saint-Petersburg, Russia

PostPosted: Mon Sep 26, 2011 4:42 pm    Post subject: Reply with quote

I have upgraded VirtualBox, but this error is persist. Logs are
Code:


Result Code:
NS_ERROR_FAILURE (0x80004005)
Component:
Console
Interface:
IConsole {1968b7d3-e3bf-4ceb-99e0-cb7c913317bb}

Failed to open a session for the virtual machine Windows XP.

Failed to load VMMR0.r0 (VERR_SUPLIB_OWNER_NOT_ROOT).

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: Console
Interface: IConsole {1968b7d3-e3bf-4ceb-99e0-cb7c913317bb}

Error was arisen under root user too.

Any ideas.
_________________
Best regards,
Yuriy Rusinov.
Back to top
View user's profile Send private message
geloo
n00b
n00b


Joined: 29 Mar 2008
Posts: 33

PostPosted: Sun Oct 02, 2011 11:32 am    Post subject: Reply with quote

hi,
just to be clear: Does it solve if you run virtual box as root ?


bests,
Back to top
View user's profile Send private message
jfp
Guru
Guru


Joined: 08 Jul 2007
Posts: 320
Location: Virginia, USA

PostPosted: Sun Oct 02, 2011 2:16 pm    Post subject: Reply with quote

Try and ggogle VERR_SUPLIB_OWNER_NOT_ROOT . There are lots of hits, which all seem to boil down to incorrect (i.e. not root) ownership of various directories.

Also, the virtualbox logs seems to provide more readable messages. On my computer the logs are located in my home directory under the (hidden) directory .VirtualBox
_________________
jfp
Back to top
View user's profile Send private message
urioxis
n00b
n00b


Joined: 02 Oct 2011
Posts: 5

PostPosted: Sun Oct 02, 2011 2:44 pm    Post subject: Reply with quote

Have you loaded the virtualbox modules? Without them you cannot start VMs

You need to load vboxdrv at the very least
Back to top
View user's profile Send private message
YuriyRusinov
Apprentice
Apprentice


Joined: 21 Jul 2004
Posts: 208
Location: Saint-Petersburg, Russia

PostPosted: Sun Oct 02, 2011 4:02 pm    Post subject: Reply with quote

If I run virtualbox as root, problem remains. And virtualbox modules are loaded by default.
_________________
Best regards,
Yuriy Rusinov.
Back to top
View user's profile Send private message
Veldrin
Veteran
Veteran


Joined: 27 Jul 2004
Posts: 1945
Location: Zurich, Switzerland

PostPosted: Sun Oct 02, 2011 8:11 pm    Post subject: Reply with quote

does the same error appear with virtualbox-bin?

are you using any funny cflags, or useflags?

V.
_________________
read the portage output!
If my answer is too concise, ask for an explanation.
Back to top
View user's profile Send private message
YuriyRusinov
Apprentice
Apprentice


Joined: 21 Jul 2004
Posts: 208
Location: Saint-Petersburg, Russia

PostPosted: Thu Oct 06, 2011 6:39 pm    Post subject: Reply with quote

Veldrin wrote:
does the same error appear with virtualbox-bin?

are you using any funny cflags, or useflags?

V.

No, with virtualbox-bin another error is arise.
Code:

Failed to create the VirtualBox COM object.

The application will now terminate.



Callee RC: NS_ERROR_FACTORY_NOT_REGISTERED (0x80040154)

_________________
Best regards,
Yuriy Rusinov.
Back to top
View user's profile Send private message
paulj
Guru
Guru


Joined: 30 Sep 2004
Posts: 449
Location: Wales, UK

PostPosted: Thu Oct 06, 2011 8:06 pm    Post subject: Reply with quote

Have you rebooted or reloaded the kernel modules since emerging the latest version:

Code:

rmmod vboxnetflt
rmmod vboxnetadp
rmmod vboxdrv
modprobe vboxnetflt
modprobe vboxnetadp
modprobe vboxdrv


If not, you will get errors!
Back to top
View user's profile Send private message
YuriyRusinov
Apprentice
Apprentice


Joined: 21 Jul 2004
Posts: 208
Location: Saint-Petersburg, Russia

PostPosted: Mon Oct 10, 2011 6:39 pm    Post subject: Reply with quote

I did it, but error was remained.
_________________
Best regards,
Yuriy Rusinov.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum