Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[libs 64 et 32]G'MIC
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
DuF
Advocate
Advocate


Joined: 09 Dec 2002
Posts: 2671
Location: Paris

PostPosted: Sat Oct 01, 2011 11:19 pm    Post subject: [libs 64 et 32]G'MIC Reply with quote

Bonjour à tous,

Lisant le journal linux sur G'MIC j'ai été tenté de l'installer.

Par contre je suis tombé sur un problème qui me fait tourner en rond.

Je suis en 64 bits et cela semble poser problème. Il y a 2 possibilités d'utiliser G'MIC, en application autonome ou en plug-in GIMP.

Dans le premier cas, le ./configure me renvoi un joli :
Code:
checking for main in -lfftw3... no
***
** Fatal Error : Header or library files for 'libfftw3' are missing but are mandatory to compile G'MIC. **
***

Là il me mets le doute, je vérifie histoire d'être sûr :
Code:

duf@genduf ~/Telechargements/gmic-1.5.0.4 $ locate libfftw3
/usr/lib32/libfftw3f.so.3
/usr/lib32/libfftw3.so.3
/usr/lib32/libfftw3f.so
/usr/lib32/libfftw3l.so
/usr/lib32/libfftw3.so
/usr/lib32/libfftw3l.so.3
/usr/lib32/libfftw3f.so.3.2.4
/usr/lib32/libfftw3l.so.3.2.4
/usr/lib32/libfftw3.so.3.2.4
duf@genduf ~/Telechargements/gmic-1.5.0.4 $ equery belongs /usr/lib32/libfftw3l.so.3
 * Searching for /usr/lib32/libfftw3l.so.3 ...
app-emulation/emul-linux-x86-soundlibs-20110722 (/usr/lib32/libfftw3l.so.3.2.4)
app-emulation/emul-linux-x86-soundlibs-20110722 (/usr/lib32/libfftw3l.so.3 -> libfftw3l.so.3.2.4)


Bon, bien que je n'y crois pas trop, je me dis que je vais le forcer à regarder dans /usr/lib32 plutôt que /usr/lib ou /usr/lib64. Mais rien n'y fait.

Dans le second cas, avec le plug-in compilé 64 bits j'ai l'erreur suivante :
Code:
duf@genduf ~/Telechargements/gmic-1.5.0.4 $ gimp
/home/duf/.gimp-2.6/plug-ins/gmic_gimp: error while loading shared libraries: libfftw3.so.3: cannot open shared object file: No such file or directory


Bon, je me dis ok, je vais tenter avec le plug-in compilé 32 bits, mais là c'est GIMP qui peut pas charger un plug-in 32 bits... C'est logique mais pendant un court instant j'ai eu comme un doute (ai-je bien compiler GIMP en 64 bits :lol: ). Au final ce pourrait être une solution, mais l'impact est loin d'être nul :-) .

J'ai bien des idées pour régler le problème mais c'est du genre crade, sans garanties et une pérennité limité à mon prochain emerge --sync.

Et vous, vous faites quoi dans ces cas là pour faire les choses proprement ?

@+
Back to top
View user's profile Send private message
Poussin
l33t
l33t


Joined: 08 Jun 2007
Posts: 659
Location: Liège

PostPosted: Sat Oct 01, 2011 11:56 pm    Post subject: Reply with quote

Il y a aussi sci-libs/fftw comme bibli non emu pour transformée de fourier, ça n'aiderait pas à faire fonctionner la chose en 64bits?

edit: et c'est slotté en 2.1 et 3.0
Back to top
View user's profile Send private message
fb99
l33t
l33t


Joined: 09 Apr 2003
Posts: 998
Location: Le Locle (Suisse,Neuchâtel)

PostPosted: Sat Oct 01, 2011 11:59 pm    Post subject: Reply with quote

salut,

aucunes idée j'y connais pas grand choses, mais tu equery ne pointe peut-être pas sur le bon prog. Peut.être que sci-libs/fftw est plus intéressant pour toi ou alors j'ai vu q'il y avait ausseî le use fftw (pour les transformé de fourrier), peut-être faut-il l'activer ? pour gimp, imagemagick, ...

bon courage..
_________________
L'ami aime en tout temps, et dans le malheur il se montre un frère ( Prov. 17,17 )
L'insensé même, quand il se tait, passe pour sage ( Prov. 17;28a )
Back to top
View user's profile Send private message
DuF
Advocate
Advocate


Joined: 09 Dec 2002
Posts: 2671
Location: Paris

PostPosted: Sun Oct 02, 2011 12:35 am    Post subject: Reply with quote

C'est vrai que je n'ai absolument pas regarder s'il y avait d'autres paquets susceptibles de fournir cette librairie...

Donc pour cette librairie c'est bon, mais direct il m'embête avec d'autres librairies et l'histoire semblant se répéter je vais aller à la pêche aux paquets !

En tout cas merci pour la solution rapide :D

@+
Back to top
View user's profile Send private message
guilc
Bodhisattva
Bodhisattva


Joined: 15 Nov 2003
Posts: 3326
Location: Paris - France

PostPosted: Sun Oct 02, 2011 6:55 am    Post subject: Reply with quote

Roh lala, et le réflexe d'aller piocher dans BGO alors ???

https://bugs.gentoo.org/buglist.cgi?quicksearch=gmic;list_id=467565

:)
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
DuF
Advocate
Advocate


Joined: 09 Dec 2002
Posts: 2671
Location: Paris

PostPosted: Sun Oct 02, 2011 10:56 am    Post subject: Reply with quote

guilc wrote:
Roh lala, et le réflexe d'aller piocher dans BGO alors ???

https://bugs.gentoo.org/buglist.cgi?quicksearch=gmic;list_id=467565

:)


Ayant rarement des besoins qui sortent de l'ordinaire et donc non couverts par Portage, j'avoue que je n'ai pas du tout le réflexe BGO... En plus il y a les 2, le plugin et la version autonome...

Merci :wink:
Back to top
View user's profile Send private message
brubru
Tux's lil' helper
Tux's lil' helper


Joined: 14 May 2008
Posts: 109
Location: France

PostPosted: Mon Oct 03, 2011 5:17 pm    Post subject: Reply with quote

Pour l'avoir testé, ça marche bien avec sci-libs/fftw-3.2.2
Par contre ma machine est i386 seulement donc pas je peux pas te dire pour les problèmes de multilib.

De mémoire, le binaire sur le site ne fonctionnait pas à cause d'une librairies dans une autre version, je suis donc passé à la version compilée.
C'est assez long car c'est du full template C++...
Back to top
View user's profile Send private message
DuF
Advocate
Advocate


Joined: 09 Dec 2002
Posts: 2671
Location: Paris

PostPosted: Mon Oct 03, 2011 10:19 pm    Post subject: Reply with quote

brubru wrote:
Pour l'avoir testé, ça marche bien avec sci-libs/fftw-3.2.2
Par contre ma machine est i386 seulement donc pas je peux pas te dire pour les problèmes de multilib.

De mémoire, le binaire sur le site ne fonctionnait pas à cause d'une librairies dans une autre version, je suis donc passé à la version compilée.
C'est assez long car c'est du full template C++...


Je confirme que ça a fonctionné avec sci-libs/fftw. J'ai du remettre une libpng12 en plus de la 14 mais ça roule et ça fonctionne.

NB : Par contre suis-je le seul à qui le fait de cliquer sur le bouton répondre de n'importe quel message renvoi à l'accueil du forum ?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum