Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
When will stable firefox move beyond 3.6?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
mhodak
Veteran
Veteran


Joined: 15 Nov 2003
Posts: 1213

PostPosted: Fri Sep 30, 2011 6:30 am    Post subject: When will stable firefox move beyond 3.6? Reply with quote

Guys,

does anybody have an insight into when will stable firefox finally upgrades beyond version 3.6? I know that the new versioning scheme is ridiculous, but it is what it is and stable cannot stick with 3.6 forever. Version 4, which already obsolete, was released over half a year ago. Are there unresolved bugs holding back newer versions of firefox?

I know I can use ~x86 keyword, but I prefer to to stick with stable as much as possible. I do not mind being back a bit, but there are many improvements in newer versions and 3.6 series, which was released in January 2010 (!), is really dated. It can stay as an option in portage, but forcing me to go with the ~ keyword just to move beyond 3.6 is unreasonable IMO. It's time to move on (even for stable)!
Back to top
View user's profile Send private message
Hypnos
Advocate
Advocate


Joined: 18 Jul 2002
Posts: 2889
Location: Omnipresent

PostPosted: Fri Sep 30, 2011 6:57 am    Post subject: Reply with quote

Some packages will never be "stable" in the Gentoo sense because upstream is not stable, either because upstream themselves declare it unstable (e.g, Paludis, wimax) or because the release cycle is too fast (e.g., Firefox).

I just keyword those packages and move on.
_________________
Personal overlay | Simple backup scheme
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 14301

PostPosted: Sat Oct 01, 2011 2:50 am    Post subject: Reply with quote

I rather like that the stable series is still at 3.6. The absolutely terrible release management exhibited by Mozilla for Fx 4+ makes 3.6 a much better choice, at least for as long as it continues to get security fixes.
Back to top
View user's profile Send private message
Polynomial-C
Developer
Developer


Joined: 01 Jun 2003
Posts: 1425
Location: germany

PostPosted: Sat Oct 01, 2011 7:31 am    Post subject: Reply with quote

The plans are to stabilize firefox-7.0.1/thunderbird-7.0.1 in the not too distant future. See bug 381245 if you want to keep track of the progress.
_________________
The manual said "Requires Windows10 or better" so I installed GNU/Linux...

my portage overlay

Need a stage1 tarball? (Unofficial builds)
Back to top
View user's profile Send private message
mhodak
Veteran
Veteran


Joined: 15 Nov 2003
Posts: 1213

PostPosted: Sun Oct 02, 2011 8:33 am    Post subject: Reply with quote

Polynomial-C wrote:
The plans are to stabilize firefox-7.0.1/thunderbird-7.0.1 in the not too distant future. See bug 381245 if you want to keep track of the progress.

Thanks for pointing me to this bug. I have searched for something like this in bugzilla but could not come up with anything.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum