Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] KDE all windows open strangely.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Bob Leny
Apprentice
Apprentice


Joined: 18 Aug 2006
Posts: 189

PostPosted: Fri Sep 30, 2011 11:56 pm    Post subject: [SOLVED] KDE all windows open strangely. Reply with quote

I'm sorry for the vague description, I'm just not sure how else to briefly describe it.

Lets take GIMP for example. When I open GIMP, it opens two windows, a blank main window that is used for image manipulation, and the toolbox.
The problem is, the two windows are maximized to each half of the screen. I know this is a minor thing, but I would still like to fix. Example: http://img835.imageshack.us/img835/2157/gimpopen.png

That's not the only thing it is doing though...
When I transfer files in Konqueror, the transfer dialog opens full screen. Example: http://img196.imageshack.us/img196/8316/konqtrans.png

The thing that bothers me the most is what happens when you change the position or size of a window. I open a program, say fireFox. It opens full screen like I want, but lets say, I need to shrink it, and and move it to the left, so I can see two windows at once or something, like this: http://img577.imageshack.us/img577/176/firefoxscale.png . When I decide the mini window needs to be full screen again, I click the maximize button and the window maximizes. The problem is, as soon as the once mini window looses focus, it goes back to being a mini window. For some reason, I can't get it to stay big again.

This presents a real problem in GIMP, because I am always resizing and moving my windows around, but they never stay where I put them!

Any ideas?

Thanks!


Last edited by Bob Leny on Mon Oct 03, 2011 8:12 pm; edited 1 time in total
Back to top
View user's profile Send private message
Bob Leny
Apprentice
Apprentice


Joined: 18 Aug 2006
Posts: 189

PostPosted: Sat Oct 01, 2011 3:51 pm    Post subject: Reply with quote

Also, creating a new behavior rule seems to have no effect...

I also noticed when you maximize a mini window, then minimize it, once you reopen the window by selecting it in the task bar, you can actually the window resize from maximized to mini.

It is like something is forcing it to be small.
Back to top
View user's profile Send private message
Cruel
n00b
n00b


Joined: 25 Jun 2011
Posts: 54

PostPosted: Sun Oct 02, 2011 8:59 am    Post subject: Reply with quote

I would suggest you to try gnome. Helps me a lot.
Back to top
View user's profile Send private message
wjb
Guru
Guru


Joined: 10 Jul 2005
Posts: 449
Location: Fife, Scotland

PostPosted: Sun Oct 02, 2011 12:10 pm    Post subject: Reply with quote

Try creating a new user account, then login as that user - check if this has the same problems. This should confirm if its your personal configs or something to do with the install.

If the problem does go away in the new account, then its probably something under ~/.kde4 in your usual account. Possibly ~/.kde4/share/config/kwinrc, where a lot of funny settings live - delete or rename it while kde isn't running and it will be recreated with clean settings next time you login.
Back to top
View user's profile Send private message
khumba
n00b
n00b


Joined: 16 Jun 2011
Posts: 43

PostPosted: Mon Oct 03, 2011 4:14 am    Post subject: Reply with quote

Do you perhaps have window tiling enabled? That could at least explain the side-by-side GIMP windows. Check System Settings > Window Behaviour > Window Behaviour > Advanced > Tiling and make sure it's disabled. The shortcut that toggles tiling is Alt+Shift+F11.

I wish KWin's tiling mode would get more love, but until then, gonna keep switching back to a tiling WM frequently :).
Back to top
View user's profile Send private message
Bob Leny
Apprentice
Apprentice


Joined: 18 Aug 2006
Posts: 189

PostPosted: Mon Oct 03, 2011 8:11 pm    Post subject: Reply with quote

wjb wrote:
Try creating a new user account, then login as that user - check if this has the same problems. This should confirm if its your personal configs or something to do with the install.

If the problem does go away in the new account, then its probably something under ~/.kde4 in your usual account. Possibly ~/.kde4/share/config/kwinrc, where a lot of funny settings live - delete or rename it while kde isn't running and it will be recreated with clean settings next time you login.


Thanks for the suggestion, I think that may help with my compositing issue.


khumba wrote:
Do you perhaps have window tiling enabled? That could at least explain the side-by-side GIMP windows. Check System Settings > Window Behaviour > Window Behaviour > Advanced > Tiling and make sure it's disabled. The shortcut that toggles tiling is Alt+Shift+F11.

I wish KWin's tiling mode would get more love, but until then, gonna keep switching back to a tiling WM frequently :).


Yes, tiling was enabled. Disabling it solved ALL of my behavioral issues! Thanks for the suggestion, you have saved me a lot of frustration!

Thanks again to both of you!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum