Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
No numlock (no X event for that key)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Kobboi
l33t
l33t


Joined: 29 Jul 2005
Posts: 662
Location: Belgium

PostPosted: Mon Sep 26, 2011 2:45 pm    Post subject: No numlock (no X event for that key) Reply with quote

I am lacking numlock functionality on my keyboard (Logitech Media Elite)

x11-base/xorg-drivers-1.10
x11-base/xorg-server-1.10.4
x11-drivers/xf86-input-evdev-2.6.0
x11-drivers/xf86-input-keyboard-1.6.0

Opening an xev test window and pressing the key does not result in an event. I doubt the key is broken, but don't have an immediate clue on what to check next. Is there something I can check at the kernel level?
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7447

PostPosted: Mon Sep 26, 2011 2:53 pm    Post subject: Re: No numlock (no X event for that key) Reply with quote

start by removing that old crappy xf86-input-keyboard
Back to top
View user's profile Send private message
Kobboi
l33t
l33t


Joined: 29 Jul 2005
Posts: 662
Location: Belgium

PostPosted: Mon Sep 26, 2011 3:03 pm    Post subject: Reply with quote

I will try that. Assuming it works, how do I prevent its re-emergence? xorg-drivers wants to install it again based on INPUT_DEVICES="keyboard", but I don't use that in my make.conf.

Edit: here it is: base/make.defaults:INPUT_DEVICES="keyboard mouse"
Should we have it removed from the base profile then?
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7447

PostPosted: Mon Sep 26, 2011 3:23 pm    Post subject: Reply with quote

switch to INPUT_DEVICES="evdev"
emerge -aC xf86-input-mouse xf86-input-keyboard
emerge -av $(qlist -IC x11-drivers)
Back to top
View user's profile Send private message
Kobboi
l33t
l33t


Joined: 29 Jul 2005
Posts: 662
Location: Belgium

PostPosted: Mon Sep 26, 2011 3:26 pm    Post subject: Reply with quote

I have tried the above suggestion by specifying my own INPUT_DEVICES, but that does not solve anything, so I again removed the INPUT_DEVICES from my make.conf.

As a sidenote, I was still not using xorg.conf.d files, so I removed all references to keyboards and mice from my xorg.conf and created an entry in xorg.conf.d to match all keyboards where I set their layout to "be". I now have "be" layout in GDM, which I did not have before (well I used to have it, years ago, but I guess I missed an upgrade guide).

The original problem remains though :(
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7447

PostPosted: Mon Sep 26, 2011 3:36 pm    Post subject: Reply with quote

Do as you wish, but you better follow the manual http://www.gentoo.org/proj/en/desktop/x/x11/xorg-server-1.10-upgrade-guide.xml

and because you use gdm, check Systeme->Preferences->Clavier->Touches de la souris->Permettre le control du pointeur...(i suppose it's written as-is in your gnome) is not check.
Back to top
View user's profile Send private message
Kobboi
l33t
l33t


Joined: 29 Jul 2005
Posts: 662
Location: Belgium

PostPosted: Mon Sep 26, 2011 3:48 pm    Post subject: Reply with quote

krinn wrote:
Do as you wish, but you better follow the manual http://www.gentoo.org/proj/en/desktop/x/x11/xorg-server-1.10-upgrade-guide.xml

and because you use gdm, check Systeme->Preferences->Clavier->Touches de la souris->Permettre le control du pointeur...(i suppose it's written as-is in your gnome) is not check.


I didn't mean to give the impression of disregarding your advice. I just wanted to adhere to the base profile. Based on the X upgrade guide you mention, maybe "evdev" should be the only INPUT_DEVICE in the base profile then.

I will look into the issue a bit deeper. You and all others are still free to point me in a certain direction.

I also appreciate your attempt to be very clear in your GDM remark but I have never understood why:
* people would want to internationalize their desktop, since it makes <insert your favorite search engine>'ing for error messages a lot harder
* people assume your native language is French when you say you're from Belgium, even when over 60% of Belgians speak Dutch. Same goes for all those internet ads that attempt to address you in your language using geoip
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7447

PostPosted: Mon Sep 26, 2011 4:02 pm    Post subject: Reply with quote

i just assume be for french, i know belguim use dutch, german and french, but i was thinking <be> was french/belgium and that dutch users pick a kind of dutch layout (dunno the code, something like nl ). It wasn't to hurt you, just that i'm french and it was then easier to tell you the correct option instead of an english translation that might be wrong: and should look like : System->Preferences->Keyboard->Mouse keys-> Allow mouse to be control by numpad

(and i tell you that because that option disable the numlock as the numpad then always == to arrows keys, this gave the effect when you push numlock nothing happen and the key looks dead, just because it must keep arrow keys working to emulate a mouse movment)
Back to top
View user's profile Send private message
Kobboi
l33t
l33t


Joined: 29 Jul 2005
Posts: 662
Location: Belgium

PostPosted: Mon Sep 26, 2011 5:32 pm    Post subject: Reply with quote

Thanks for your reply. I can't check the setting right now, but I assume it is disabled since the numpad arrow keys still move my text cursor on things like input boxes and terminal shell prompts.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum