Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[kernel] Kernel panic "unable to mount root"
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
NoDataFound
n00b
n00b


Joined: 01 Aug 2011
Posts: 30

PostPosted: Tue Sep 20, 2011 10:09 pm    Post subject: [kernel] Kernel panic "unable to mount root" Reply with quote

Bonjour,

J'ai de temps à autres un kernel panic au démarrage de mon serveur avec le kernel 2.6.39-gentoo-r3 en architecture amd64 :

Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(8,2)

Elle se produit juste après ce qui semble être un listing des disques durs. Lorsque j'essaye de brancher un clavier pour remonter sur la console, ce dernier est inactif (aucune touche ne fonctionne que ce soit via un clavier en P/S2 ou via un clavier USB) et vu qu'aucun disque n'a semble t'il été reconnu, je n'ai pas non plus la trace exacte stocké dans les logs. Aussi unknown-block(8,2) correspond à /dev/sda2 d'après lsblk.



Au niveau du serveur, il dispose d'une carte mère ASRock H67-ITX/HT avec un Core i3 2120 et 8 GiO Corsair XMS3 DDR3-1333 CL9 8Go (2x4Go). J'ai également une carte contrôleur Sata - une
Adaptec 1430SA Raid.
J'ai 7 disques durs :
  • un SSD Intel postville 40G sur lequel sont installés /dev/sda1 (boot), /dev/sda2 (système)
  • un vieux disque Seagate qui sert pour /var, /tmp, /home et la swap
  • 5 x WD 2To S-ATA II 64Mo (Caviar Green) montés en RAID5 formant /dev/md0


Ce dernier est relié à mon PC sous Win7 en ethernet (câble croisé) et est également connecté en Wifi. J'ai l'impression que ce problème survient (sans en être convaincu) principalement quand le serveur est démarré avant mon PC.

Est-ce quelqu'un a une idée de comment je peux le résoudre sachant qu'il apparaît de temps à autre et que le peu d'informations que j'ai pu trouver concerne des cas où les PC ne fonctionnent pas du tout alors que dans mon cas, c'est plutôt aléatoire.

Je n'ai pas encore eu l'occasion de tester la RAM avec memtest (memtest86+ ne se lance tout simplement pas quand je tente de le mettre dans grub) mais j'ai du mal à voir comment cela peut faire déconner le boot que dans certains (rares) cas.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum