Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] xorg: configuration failed
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
asp
n00b
n00b


Joined: 09 Sep 2011
Posts: 6

PostPosted: Sun Sep 11, 2011 7:40 pm    Post subject: [SOLVED] xorg: configuration failed Reply with quote

hello folks

i try to configure xorg server,but i take "configuration failed"

pls tell me if you want to give you more info,...

#Xorg -configure

Code:

X.Org X Server 1.10.4
Release Date: 2011-08-19
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.39-gentoo-r3 i686 Gentoo
Current Operating System: Linux thegnome 2.6.39-gentoo-r3 #1 SMP Wed Sep 7 21:45:02 EEST 2011 i686
Kernel command line: root=/dev/sda4
Build Date: 12 September 2011  12:57:04AM
 
Current version of pixman: 0.22.2
   Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Sep 12 01:26:32 2011
List of video drivers:
   intel
   fbdev
   vesa
(++) Using config file: "/root/xorg.conf.new"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
WARNING: Error inserting cfbimgblt (/lib/modules/2.6.39-gentoo-r3/kernel/drivers/video/cfbimgblt.ko): Invalid module format
WARNING: Error inserting thermal_sys (/lib/modules/2.6.39-gentoo-r3/kernel/drivers/thermal/thermal_sys.ko): Invalid module format
WARNING: Error inserting backlight (/lib/modules/2.6.39-gentoo-r3/kernel/drivers/video/backlight/backlight.ko): Invalid module format
WARNING: Error inserting video (/lib/modules/2.6.39-gentoo-r3/kernel/drivers/acpi/video.ko): Invalid module format
WARNING: Error inserting i2c_core (/lib/modules/2.6.39-gentoo-r3/kernel/drivers/i2c/i2c-core.ko): Invalid module format
WARNING: Error inserting agpgart (/lib/modules/2.6.39-gentoo-r3/kernel/drivers/char/agp/agpgart.ko): Invalid module format
WARNING: Error inserting intel_gtt (/lib/modules/2.6.39-gentoo-r3/kernel/drivers/char/agp/intel-gtt.ko): Invalid module format
WARNING: Error inserting button (/lib/modules/2.6.39-gentoo-r3/kernel/drivers/acpi/button.ko): Invalid module format
WARNING: Error inserting cfbcopyarea (/lib/modules/2.6.39-gentoo-r3/kernel/drivers/video/cfbcopyarea.ko): Invalid module format
WARNING: Error inserting i2c_algo_bit (/lib/modules/2.6.39-gentoo-r3/kernel/drivers/i2c/algos/i2c-algo-bit.ko): Invalid module format
WARNING: Error inserting intel_agp (/lib/modules/2.6.39-gentoo-r3/kernel/drivers/char/agp/intel-agp.ko): Invalid module format
WARNING: Error inserting drm (/lib/modules/2.6.39-gentoo-r3/kernel/drivers/gpu/drm/drm.ko): Invalid module format
WARNING: Error inserting drm_kms_helper (/lib/modules/2.6.39-gentoo-r3/kernel/drivers/gpu/drm/drm_kms_helper.ko): Invalid module format
FATAL: Error inserting i915 (/lib/modules/2.6.39-gentoo-r3/kernel/drivers/gpu/drm/i915/i915.ko): Invalid module format
(EE) open /dev/fb0: No such file or directory
Number of created screens does not match number of detected devices.
  Configuration failed.


a desperate man,
Thanks in advance.


Last edited by asp on Thu Sep 15, 2011 8:36 pm; edited 1 time in total
Back to top
View user's profile Send private message
whiteghost
Guru
Guru


Joined: 26 Jul 2009
Posts: 374
Location: north dakota

PostPosted: Sun Sep 11, 2011 7:56 pm    Post subject: Reply with quote

have you followed these directions?
http://www.gentoo.org/doc/en/xorg-config.xml
_________________
www.informationclearinghouse.info
May you re-discover what the poor in 18th century France discovered, that rich people's heads can be mechanically separated from their shoulders if they refuse to listen to reason.
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2665
Location: Slovenia

PostPosted: Sun Sep 11, 2011 8:08 pm    Post subject: Reply with quote

X is not your problem, you have kernel issues. Make sure your kernel and it's modules are installed correctly.
Back to top
View user's profile Send private message
whiteghost
Guru
Guru


Joined: 26 Jul 2009
Posts: 374
Location: north dakota

PostPosted: Sun Sep 11, 2011 8:24 pm    Post subject: Reply with quote

Main: http://www.kernel-seeds.org
Mirror: http://62.3.120.141/~pappy/
Mirror 2: http://kernel-seeds.bloodnoc.org/
Mirror 3: http://kernel-seeds.audiodef.com/
Mirror 4: http://www.elilabs.com/~pappy/

http://swift.siphos.be/linux_sea/ch07.html


for help with your kernel
_________________
www.informationclearinghouse.info
May you re-discover what the poor in 18th century France discovered, that rich people's heads can be mechanically separated from their shoulders if they refuse to listen to reason.
Back to top
View user's profile Send private message
asp
n00b
n00b


Joined: 09 Sep 2011
Posts: 6

PostPosted: Sun Sep 11, 2011 9:22 pm    Post subject: Reply with quote

i had done genkernel all.... and i have read the manual...but not luck..

i will give a try to build manual a kernel,and i hope...

thanks for sources.
Back to top
View user's profile Send private message
asp
n00b
n00b


Joined: 09 Sep 2011
Posts: 6

PostPosted: Thu Sep 15, 2011 10:43 am    Post subject: Reply with quote

hello ...

well,no luck..

i followed kernel-seed site,i made my own .config using lspci and cpuinfo and when i give Xorg -configure my /var/log/Xorg.0.log and when i give startx my /var/log/Xorg.0.log
i don't know what other i must do..i just ask for help ...


EDIT
dmesg


Last edited by asp on Thu Sep 15, 2011 2:05 pm; edited 1 time in total
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Thu Sep 15, 2011 1:15 pm    Post subject: Reply with quote

Do you still have those odd module insertion problems ?
You probably should turn CONFIG_FB_VESA off.

Other than that, check dmesg for anything of interest.
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7635
Location: Goose Creek SC

PostPosted: Thu Sep 15, 2011 4:31 pm    Post subject: Reply with quote

try
Code:
emerge xorg-server xf86-video-intel xf86-input-evdev xf86-input-synaptics
X -retro
if a black and white stipple screen with a movable mouse cursor results, X works. If not, run
Code:
emerge pciutils
lspci -k | wgetpaste
emerge --info | wgetpaste
wgetpaste /usr/src/linux/.config
ls /etc/X11/Sessions | wgetpaste
Post the url's returned
_________________
Defund the FCC.
Back to top
View user's profile Send private message
asp
n00b
n00b


Joined: 09 Sep 2011
Posts: 6

PostPosted: Thu Sep 15, 2011 8:01 pm    Post subject: Reply with quote

DONAHUE wrote:
try
Code:
emerge xorg-server xf86-video-intel xf86-input-evdev xf86-input-synaptics
X -retro
if a black and white stipple screen with a movable mouse cursor results, X works.



yes it works !


Thank you very mutch from my heart .
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7635
Location: Goose Creek SC

PostPosted: Thu Sep 15, 2011 8:12 pm    Post subject: Reply with quote

Have you emerged a display manager/window manager/desktop ?

it sounds like you are seeing twm/xterm and may not have configured the keyboard/keymap?

From http://www.gentoo.org/doc/en/xorg-config.xml :
Quote:
Configuring your keyboard

To setup X to use an international keyboard, you just have to create the appropriate config file in /etc/X11/xorg.conf.d/. This example features a Czech keyboard layout:

Code Listing 4.3: Using an international keyboard
# nano -w /etc/X11/xorg.conf.d/30-keyboard.conf

Section "InputClass"
Identifier "keyboard-all"
Driver "evdev"
Option "XkbLayout" "us,cz"
Option "XkbModel" "logitech_g15"
Option "XkbRules" "xorg"
Option "XkbOptions" "grp:alt_shift_toggle,grp:switch,grp_led:scroll,compose:rwin,terminate:ctrl_alt_bksp"
Option "XkbVariant" ",qwerty"
MatchIsKeyboard "on"
EndSection
The "terminate" command (terminate:ctrl_alt_bksp) lets you kill the X session by using the Ctrl-Alt-Backspace key combination. This will, however, make X exit disgracefully -- something that you might not always want. It can be useful when programs have frozen your display entirely, or when you're configuring and tweaking your Xorg environment. Be careful when killing your desktop with this key combination -- most programs really don't like it when you end them this way, and you may lose some (or all) of what you were working on.

_________________
Defund the FCC.
Back to top
View user's profile Send private message
asp
n00b
n00b


Joined: 09 Sep 2011
Posts: 6

PostPosted: Thu Sep 15, 2011 8:35 pm    Post subject: Reply with quote

finally it wasn't problem,i did a reboot and it was solved.

thank you for your time again.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum