Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Come risolvo questi blocchi in emerge -uDN world?
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
rb34
Guru
Guru


Joined: 03 Oct 2004
Posts: 361
Location: Rome, italy

PostPosted: Sat Sep 10, 2011 4:35 pm    Post subject: Come risolvo questi blocchi in emerge -uDN world? Reply with quote

Ogni volta che emergo world ho dei blocchi che non so bene come risolvere, stavolta ho quanto sotto. Come risolvo? (ogni volta faccio qualche casino e sono costretto a emerge tutto, anche se vorrei prima sistemare i problemi e poi aggiornare tra un po').

Io per esempio per hal/upower pensavo di togliere upower, emergere e rimetterlo (se non si rimette da solo). Ma più che altro, quale è la procedura generale e più sicura per risolvere i blocchi?
Code:
[blocks B      ] sys-auth/policykit ("sys-auth/policykit" is blocking sys-auth/polkit-0.101-r1)
[blocks B      ] sys-apps/hal ("sys-apps/hal" is blocking sys-power/upower-0.9.12)

 (sys-apps/hal-0.5.14-r2::gentoo, installed) pulled in by
    >=sys-apps/hal-0.5.10 required by (app-misc/hal-info-20091130::gentoo, installed)
    sys-apps/hal required by @selected

  (sys-auth/polkit-0.101-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-auth/polkit-0.97 required by (sys-fs/udisks-1.0.3-r1::gentoo, ebuild scheduled for merge)
    >=sys-auth/polkit-0.91 required by (gnome-base/gnome-settings-daemon-2.32.1-r1::gentoo, ebuild scheduled for merge)
    sys-auth/polkit required by (net-print/hplip-3.11.5::gentoo, ebuild scheduled for merge)
    >=sys-auth/polkit-0.101-r1 required by (sys-auth/consolekit-0.4.5-r1::gentoo, ebuild scheduled for merge)
    sys-auth/polkit required by (gnome-base/gconf-2.32.3::gentoo, ebuild scheduled for merge)
    >=sys-auth/polkit-0.99 required by (sys-auth/polkit-qt-0.99.0::gentoo, ebuild scheduled for merge)
    >=sys-auth/polkit-0.92 required by (gnome-base/gnome-applets-2.32.1.1::gentoo, ebuild scheduled for merge)
    >=sys-auth/polkit-0.101 required by (gnome-extra/polkit-gnome-0.101-r1::gentoo, ebuild scheduled for merge)
    >=sys-auth/polkit-0.101-r1 required by (sys-power/upower-0.9.12::gentoo, ebuild scheduled for merge)

  (sys-power/upower-0.9.12::gentoo, ebuild scheduled for merge) pulled in by
    sys-power/upower required by (kde-base/kdelibs-4.6.5-r1::gentoo, ebuild scheduled for merge)
    >=sys-power/upower-0.9.0 required by (gnome-base/gnome-session-2.32.1-r2::gentoo, ebuild scheduled for merge)
    >=sys-power/upower-0.9.1 required by (gnome-extra/gnome-power-manager-2.32.0-r1::gentoo, ebuild scheduled for merge)

_________________
rb


Last edited by rb34 on Sat Sep 10, 2011 7:47 pm; edited 2 times in total
Back to top
View user's profile Send private message
marziods
Tux's lil' helper
Tux's lil' helper


Joined: 25 Jun 2009
Posts: 121
Location: <Roma>par lavor | Udine | Friul | Italie

PostPosted: Sat Sep 10, 2011 4:50 pm    Post subject: Reply with quote

mmmm guarda che hal è stato deprecato... hai veramente la necessità di averlo???
altrimenti toglilo dai un bel
Code:
revdep-rebuild
e tutto dovrebbe sistemarsi...
Mandi
_________________
linux user #493115
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Sat Sep 10, 2011 4:57 pm    Post subject: Reply with quote

Code:
echo USE=\"$\{USE\} -hal udev\" >> /etc/make.conf
oppure
Code:
emerge gentoolkit
euse -D hal
euse -E udev
e dopo
Code:
emerge -C hal hal-info
emerge -DNu @world
se il sistema è vecchiotto è il caso di dare anche un
Code:
revdep-rebuild -i
hal è deprecato e va eliminato ma se cancelli solo hal c'è hal-info che rompe le scatole. Tutto qui.
Il segreto è nella riga
emerge -aDNUtv @world wrote:
[blocks B ] sys-apps/hal ("sys-apps/hal" is blocking sys-power/upower-0.9.12)
e nella riga
emerge -aDNUtv @world wrote:
>=sys-apps/hal-0.5.10 required by (app-misc/hal-info-20091130::gentoo, installed)


La faccenda è spiegata nella guida di aggiornamento di xorg e basta una rapida ricerca sul forum per trovare la soluzione (il problema non è nuovo) ma, visto che chiedi come cavarsela con i blocchi a partire da questo caso, ti rigiro la domanda:
in cosa non ti è chiaro l'output di emerge?
Non capisci come arrivare al da farsi?
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
rb34
Guru
Guru


Joined: 03 Oct 2004
Posts: 361
Location: Rome, italy

PostPosted: Sat Sep 10, 2011 5:18 pm    Post subject: Reply with quote

marziods wrote:
mmmm guarda che hal è stato deprecato... hai veramente la necessità di averlo???


Ho perso un po' di news, non sapevo nemmeno che fosse stato deprecato. Perfetto, quindi in fase di emerge world lo toglierò e quello ok. Per policy kit hai qualche suggerimento?

edit: come non detto, equery depends policykit mi dice che lo richiede solo hal, quindi tolto hal potrò emerge tutto. Più facile del previsto. E' che altre volte ho avuto dei casini a togliere dei pacchetti, e volevo essere sicuro di non distruggermi il sistema. Grazie dell'assistenza
_________________
rb


Last edited by rb34 on Sat Sep 10, 2011 5:42 pm; edited 1 time in total
Back to top
View user's profile Send private message
rb34
Guru
Guru


Joined: 03 Oct 2004
Posts: 361
Location: Rome, italy

PostPosted: Sat Sep 10, 2011 5:31 pm    Post subject: Reply with quote

djinnZ wrote:
visto che chiedi come cavarsela con i blocchi a partire da questo caso, ti rigiro la domanda:
in cosa non ti è chiaro l'output di emerge?
Non capisci come arrivare al da farsi?


Ottima domanda: "in cosa non ti è chiaro l'output di emerge?"
L'output di emerge mi è per lo più chiaro, ma a volte non riesco a risolvere i blocchi.
Ad esempio leggendo il solo output di emerge, non mi pare ci sia scritto che hal è deprecato, e io non seguo più le news gentoo come una volta. Quindi mi sono chiesto se togliere upower o hal per far emergere.

Uso Gentoo da vari anni, forse prima avevo meno pacchetti installati e non avevo questi problemi di blocchi, forse è cambiato portage o forse adesso aggiorno di rado e mi scordo le procedure... Ho l'impressione Gentoo non faccia più per me, e un po' mi dispiace.
_________________
rb
Back to top
View user's profile Send private message
rb34
Guru
Guru


Joined: 03 Oct 2004
Posts: 361
Location: Rome, italy

PostPosted: Sat Sep 10, 2011 7:47 pm    Post subject: Reply with quote

aggiornamento: non è così semplice come sembra. equery depends hal mi dà
Code:
app-cdr/k3b-2.0.0 (sys-apps/hal)
app-misc/hal-info-20091130 (>=sys-apps/hal-0.5.10)
gnome-base/gnome-volume-manager-2.24.1 (>=sys-apps/hal-0.5.9)
gnome-extra/gnome-power-manager-2.30.1 (>=sys-apps/hal-0.5.9)
gnome-extra/nautilus-cd-burner-2.24.0 (>=sys-apps/hal-0.5.7)
kde-base/kdebase-kioslaves-3.5.10-r1 (hal? =sys-apps/hal-0.5*)


Allora, questo significa che tutti questi pacchetti installati dipendono da hal, e che quindi in teoria non lo potrei rimuovere
Ora vedo che gnome-volume-manager non è più in portage, e quello lo tolgo.
Ma per esempio ho lo gnome-power-manager che ha la use flag hal, e non ricordo perché è attiva. Come capisco se posso toglierla? E lo stesso vale per kdebase-kioslaves
_________________
rb
Back to top
View user's profile Send private message
darkmanPPT
Veteran
Veteran


Joined: 13 Apr 2006
Posts: 1069
Location: vi/bo

PostPosted: Sun Sep 11, 2011 8:52 am    Post subject: Reply with quote

Code:
kde-base/kdebase-kioslaves-3.5.10-r1 (hal? =sys-apps/hal-0.5*)
gnome-extra/gnome-power-manager-2.30.1 (>=sys-apps/hal-0.5.9)


si, vabbè, ma qui si sta parlando di un sistema aggiornato.
tu hai ancora kde 3.5
kde 3.5 vuole hal, non c'è dubbio.
Code:
eix gnome-power-manager
* gnome-extra/gnome-power-manager
     Available versions:  2.32.0!t 2.32.0-r1!t ~2.32.0-r2!t [M]~3.0.2-r1!t {+applet doc policykit test}
     Homepage:            http://www.gnome.org/projects/gnome-power-manager/
     Description:         Gnome Power Manager


 eix kioslaves
[I] kde-base/kdebase-kioslaves
     Available versions:  (4) 4.6.3!t 4.6.5!t ~4.7.0!t ~4.7.0-r1!t
        {aqua +bzip2 debug exif +handbook kdeenablefinal kdeprefix lzma openexr samba +sftp}
     Installed versions:  4.6.5(4)!t(12:32:36 02/09/2011)(bzip2 exif handbook openexr sftp -aqua -debug -kdeenablefinal -lzma -samba)
     Homepage:            http://www.kde.org/
     Description:         kioslave: the kde VFS framework - kioslave plugins present a filesystem-like view of arbitrary data

_________________
Darkman
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum