Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
postgresql-9.1, uninstalled 9.0, both appear as eselect slot
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
jeffk
l33t
l33t


Joined: 13 Sep 2003
Posts: 661

PostPosted: Fri Sep 09, 2011 1:06 am    Post subject: postgresql-9.1, uninstalled 9.0, both appear as eselect slot Reply with quote

I have updated an ~amd64 server with postgresql-{base,server}-9.1rc1. I uninstalled 9.0 just prior to emerging 9.1. Both 9.0 and 9.1 show up in eselect slots, why is that?
Code:
$ sudo eselect postgresql list                                                                                   
Password:
Available PostgreSQL Slots
  9.0                       
  9.1 *                      server-9.1_rc1 base-9.1_rc1

I have removed /etc/postgresql-9.0, and /var/lib/postgresql/9.0.

Thanks for any suggestions.
Back to top
View user's profile Send private message
titanofold
Developer
Developer


Joined: 30 Dec 2003
Posts: 235
Location: Bryson City, NC USA

PostPosted: Fri Sep 09, 2011 11:01 pm    Post subject: Reply with quote

Because for some reason /usr/lib/postgresql-9.0 still exists.
_________________
The best things in life are free.
Guy-1: Surely, you will fold with me...
Guy-2: Alright, but don't call me Shirley
Back to top
View user's profile Send private message
jeffk
l33t
l33t


Joined: 13 Sep 2003
Posts: 661

PostPosted: Fri Sep 09, 2011 11:28 pm    Post subject: Reply with quote

Thank you, the package still holding files in /usr/lib/postgresql-9.0 was postgis. Re-emerged, fixed.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum