Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problemi a passare a root [RISOLTO]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
bi-andrea
Apprentice
Apprentice


Joined: 09 Mar 2010
Posts: 171
Location: cesenatico

PostPosted: Tue Aug 30, 2011 10:51 pm    Post subject: Problemi a passare a root [RISOLTO] Reply with quote

Ciao,
utilizzo xfce4 con logger slim, ho aggiornato World e System però ho dei problemi quando mi loggio da utente normale, se apro un terminale e digito

Code:

su
<passowrd>


mi compare

Code:
manuel@Manuel ~ $ su
Password:
su: Authentication failure
manuel@Manuel ~ $


allora ho provato digitando

Code:

da root
gpasswd -a nome-utente wheel


lui continua a dare lo stesso problema
_________________
Quando arrivi a Linux è un trauma, abituati a Windows, quando arrivi a Gentoo è uno spavento col brivido , però quando lo capisci sei uscito dall'università "GNU/Linux" ;)


Last edited by bi-andrea on Mon Sep 12, 2011 6:39 pm; edited 1 time in total
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1518
Location: Cosenza, Italy

PostPosted: Wed Aug 31, 2011 8:34 am    Post subject: Reply with quote

Code:
su -
o
Code:
su - root
?
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
bi-andrea
Apprentice
Apprentice


Joined: 09 Mar 2010
Posts: 171
Location: cesenatico

PostPosted: Fri Sep 02, 2011 8:45 pm    Post subject: Reply with quote

durante questa assenza ho provato a capire il problema, ho provato anche di eliminare l'utente e poi ricrearlo, ma il risulato è lo stesso anche con i comandi suggeriti
Un utente per accedere a root che passaggio deve fare?
Cioè cosa determina il permesso di diventare root, forse c'è qualcosa che non è sistemato bene.......
mia ipotesi
_________________
Quando arrivi a Linux è un trauma, abituati a Windows, quando arrivi a Gentoo è uno spavento col brivido , però quando lo capisci sei uscito dall'università "GNU/Linux" ;)
Back to top
View user's profile Send private message
bi-andrea
Apprentice
Apprentice


Joined: 09 Mar 2010
Posts: 171
Location: cesenatico

PostPosted: Sat Sep 03, 2011 7:10 pm    Post subject: Reply with quote

Alla fine mi può star bene anche così, perchè in fondo se mi manca qualcosa uso portato, lui mi chiede la password di root e non ha problemi di riconoscimento, il sistema mi funziona bene.......

Quote:
il mio sistema è così
gcc-4.4.5
binutils-2.20.1-r1
portage-2.1.10.3
xfce4-panel-4.8.3
xfce4-session-4.8.1
gentoo-sources-3.0.1
slim-1.3.2-r3

_________________
Quando arrivi a Linux è un trauma, abituati a Windows, quando arrivi a Gentoo è uno spavento col brivido , però quando lo capisci sei uscito dall'università "GNU/Linux" ;)
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1518
Location: Cosenza, Italy

PostPosted: Sat Sep 03, 2011 7:16 pm    Post subject: Reply with quote

ti ho postato delle soluzioni, almeno una risposta se funzionano o no?
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
bi-andrea
Apprentice
Apprentice


Joined: 09 Mar 2010
Posts: 171
Location: cesenatico

PostPosted: Sat Sep 03, 2011 7:29 pm    Post subject: Reply with quote

Scusami ago, il risutato coi comandi che mi hai citato sono

Quote:
manuel@Manuel ~ $ su
Password:
su: Authentication failure
manuel@Manuel ~ $


con

Quote:
su -


mi chiede la passowrd di -
_________________
Quando arrivi a Linux è un trauma, abituati a Windows, quando arrivi a Gentoo è uno spavento col brivido , però quando lo capisci sei uscito dall'università "GNU/Linux" ;)
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1518
Location: Cosenza, Italy

PostPosted: Sat Sep 03, 2011 7:48 pm    Post subject: Reply with quote

Code:
ago@devil ~ $ su -
Password:
devil ~ # whoami
root

_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
bi-andrea
Apprentice
Apprentice


Joined: 09 Mar 2010
Posts: 171
Location: cesenatico

PostPosted: Sat Sep 03, 2011 8:37 pm    Post subject: Reply with quote

si presenta così

Quote:
manuel@Manuel ~ $ su -
Password:
su: Authentication failure
manuel@Manuel ~ $ whoami
manuel
manuel@Manuel ~ $

_________________
Quando arrivi a Linux è un trauma, abituati a Windows, quando arrivi a Gentoo è uno spavento col brivido , però quando lo capisci sei uscito dall'università "GNU/Linux" ;)
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1518
Location: Cosenza, Italy

PostPosted: Sun Sep 04, 2011 12:42 am    Post subject: Reply with quote

hai provato a ricompilare sys-libs/pam ?
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
bi-andrea
Apprentice
Apprentice


Joined: 09 Mar 2010
Posts: 171
Location: cesenatico

PostPosted: Sun Sep 04, 2011 2:06 pm    Post subject: Reply with quote

no ma posso provare
_________________
Quando arrivi a Linux è un trauma, abituati a Windows, quando arrivi a Gentoo è uno spavento col brivido , però quando lo capisci sei uscito dall'università "GNU/Linux" ;)
Back to top
View user's profile Send private message
allxsan
n00b
n00b


Joined: 11 Aug 2010
Posts: 49

PostPosted: Sun Sep 04, 2011 4:19 pm    Post subject: Re: Problemi a passare a root Reply with quote

bi-andrea wrote:
Ciao,
utilizzo xfce4 con logger slim, ho aggiornato World e System però ho dei problemi quando mi loggio da utente normale, se apro un terminale e digito

Code:

su
<passowrd>


mi compare

Code:
manuel@Manuel ~ $ su
Password:
su: Authentication failure
manuel@Manuel ~ $


allora ho provato digitando

Code:

da root
gpasswd -a nome-utente wheel


lui continua a dare lo stesso problema


il problema e' (quasi) sicuramente dovuto a slim e al suo modo (gli script) di apire la sessione xfce4 (ma anche gnome, lxde...)
Avevo scelto anche io slim (dopo inutili peripezie mi sono stufato e ho provato anche con lightdm ), in origine avevo deciso di fare una nuova installazione pensando a xorg+slim+xfce4. Una volta terminato senza alcun problema, inizio ad utilizzare l'ambiente xfce ma vado subito incontro a "stramberie" varie, per esempio non mi permetteva di effetttuare il mount di un bel niente, se non da console con "sudo bla bla bla....", l'ambiente grafico era curiosamente "monco" di piccole parti, non memorizzava la password della connessione wireless... pensavo a qualcosa di andato male durante la compilazione, qualche flag USE di troppo... per sicurezza vado a verificare ( come al solito, e non ne posso piu' ) e trovo una serie di messaggi (e 3d) che parlano proprio di questo problema. Solo che non si cita l'esatta soluzione e "devi cercartela da solo" procedendo per tentativi ! Dicono di modificare script, modificare questa e quella configurazione, evitare che, fare in modo di...
beh, dico ! no, basta. Slim e' normalmente disponibile in portage e non ho "emerso" versioni mascherate, per cui non e' possibile andare incontro (purtroppo ancora una volta ) a problemi "succhiatempo" di questo genere.
Ho "emerso" gdm e ho risolto tutto in un minuto
Back to top
View user's profile Send private message
bi-andrea
Apprentice
Apprentice


Joined: 09 Mar 2010
Posts: 171
Location: cesenatico

PostPosted: Sun Sep 04, 2011 5:46 pm    Post subject: Reply with quote

grazie allxsan per la tua testimonianza, ho voluto usare xorg-x11+xfce4+slim per avere un sistema diverso e mi trovo bene, c'è l'esenziale perchè per esempio con xfburn se non installi diversi plugin lui non legge molte cose anche per montare i dischi dove dipende poi dal kernel.
Ho provato dal renvel 3 a fare la stessa cosa e vedo che il problema persiste quindi il problema è altrove non in ambiente X

Per ago, ho provato a ricompilarlo

Code:

sys-libs/pam-1.1.3
use=audit berkdb cracklib nls vim-syntax


però continua a dare lo stesso problema
_________________
Quando arrivi a Linux è un trauma, abituati a Windows, quando arrivi a Gentoo è uno spavento col brivido , però quando lo capisci sei uscito dall'università "GNU/Linux" ;)
Back to top
View user's profile Send private message
table
Apprentice
Apprentice


Joined: 17 Feb 2007
Posts: 279
Location: Gazzaniga (BG) Italy

PostPosted: Mon Sep 05, 2011 12:20 pm    Post subject: Reply with quote

Ciao,

controlla se l'utente è nel gruppo wheel
_________________
Pulisci l'html con:
Code:
sed 's/<[Bb][Rr][ \t]*\/*>/\n/g;s/<\/*[^>]\+\/*>//g'

skype: matteopinguino
Back to top
View user's profile Send private message
bi-andrea
Apprentice
Apprentice


Joined: 09 Mar 2010
Posts: 171
Location: cesenatico

PostPosted: Tue Sep 06, 2011 7:52 pm    Post subject: Reply with quote

sì table infatti ho rigiditato il comando per avere l'utente anche nel gruppo whell, però non sono riuscito come mi hai suggerito
Code:

sed 's/<[Bb][Rr][ \t]*\/*>/\n/g;s/<\/*[^>]\+\/*>//g'


dove il terminale mi rimane in attesa di comandi, forse devo spezzarre la stringa che mi hai suggerito?
_________________
Quando arrivi a Linux è un trauma, abituati a Windows, quando arrivi a Gentoo è uno spavento col brivido , però quando lo capisci sei uscito dall'università "GNU/Linux" ;)
Back to top
View user's profile Send private message
table
Apprentice
Apprentice


Joined: 17 Feb 2007
Posts: 279
Location: Gazzaniga (BG) Italy

PostPosted: Wed Sep 07, 2011 7:16 am    Post subject: Reply with quote

bi-andrea wrote:
sì table infatti ho rigiditato il comando per avere l'utente anche nel gruppo whell, però non sono riuscito come mi hai suggerito
Code:

sed 's/<[Bb][Rr][ \t]*\/*>/\n/g;s/<\/*[^>]\+\/*>//g'


dove il terminale mi rimane in attesa di comandi, forse devo spezzarre la stringa che mi hai suggerito?

Quella è la mia firma, non c'entra nulla con il tuo problema :D


Ma loggandoti all'ambiente direttamente con l'utente root ti funziona? Cioè sei sicuro che la passwrod di root sia corretta?
Verfica anche il corretto mapping della tastiera poichè spesso siamo convinti di scrivere una password, ma poichè il mapping della tastiera è americano (ad esempio) ne scriviamo un'altra :lol:
_________________
Pulisci l'html con:
Code:
sed 's/<[Bb][Rr][ \t]*\/*>/\n/g;s/<\/*[^>]\+\/*>//g'

skype: matteopinguino
Back to top
View user's profile Send private message
bi-andrea
Apprentice
Apprentice


Joined: 09 Mar 2010
Posts: 171
Location: cesenatico

PostPosted: Wed Sep 07, 2011 5:43 pm    Post subject: Reply with quote

Bene una riga in meno da digitare :D

Sì, guarda table, quel dubbio lo avevo avuto pure io, infatti con tea ho provato a editare tutte le password, però non è neanche quello e poi quando mi loggio nel sistema a renlevel 3 sono root (che ormai ho sistemato tutto) e lancio slim.
da quì riesco sia a loggiarmi da root che da utente normale, quindi non saprei, magari provare con sudo, però ho un sistema regolare come volevo io, quindi magari posso sorvolare questo strano comportamento, forse al prossimo aggiornamento riesco a loggiarmi anche dall'ambiente utente in root
_________________
Quando arrivi a Linux è un trauma, abituati a Windows, quando arrivi a Gentoo è uno spavento col brivido , però quando lo capisci sei uscito dall'università "GNU/Linux" ;)
Back to top
View user's profile Send private message
bi-andrea
Apprentice
Apprentice


Joined: 09 Mar 2010
Posts: 171
Location: cesenatico

PostPosted: Mon Sep 12, 2011 6:45 pm    Post subject: Reply with quote

ho messo risolto perchè per passare a root non proprio risolto che non ho bene capito cosa possa essere, però installando

Code:
emerge sudo

per impostare dopo

Code:
# visudo


il mio /etc/sudoers ora si presenta così
Code:

## sudoers file.
##
## This file MUST be edited with the 'visudo' command as root.
## Failure to use 'visudo' may result in syntax or file permission errors
## that prevent sudo from running.
##
## See the sudoers man page for the details on how to write a sudoers file.
##

##
## Host alias specification
##
## Groups of machines. These may include host names (optionally with wildcards),
## IP addresses, network numbers or netgroups.
# Host_Alias   WEBSERVERS = www1, www2, www3

##
## User alias specification
##
## Groups of users.  These may consist of user names, uids, Unix groups,
## or netgroups.
# User_Alias   ADMINS = millert, dowdy, mikef

##
## Cmnd alias specification
##
## Groups of commands.  Often used to group related commands together.
# Cmnd_Alias   PROCESSES = /usr/bin/nice, /bin/kill, /usr/bin/renice, \
#              /usr/bin/pkill, /usr/bin/top

##
## Defaults specification
##
## You may wish to keep some of the following environment variables
## when running commands via sudo.
##
## Locale settings
# Defaults env_keep += "LANG LANGUAGE LINGUAS LC_* _XKB_CHARSET"
##
## Run X applications through sudo; HOME is used to find the
## .Xauthority file.  Note that other programs use HOME to find   
## configuration files and this may lead to privilege escalation!
# Defaults env_keep += "HOME"
##
## X11 resource path settings
# Defaults env_keep += "XAPPLRESDIR XFILESEARCHPATH XUSERFILESEARCHPATH"
##
## Desktop path settings
# Defaults env_keep += "QTDIR KDEDIR"
##
## Allow sudo-run commands to inherit the callers' ConsoleKit session
# Defaults env_keep += "XDG_SESSION_COOKIE"
##
## Uncomment to enable special input methods.  Care should be taken as
## this may allow users to subvert the command being run via sudo.
# Defaults env_keep += "XMODIFIERS GTK_IM_MODULE QT_IM_MODULE QT_IM_SWITCHER"
##
## Uncomment to enable logging of a command's output, except for
## sudoreplay and reboot.  Use sudoreplay to play back logged sessions.
# Defaults log_output
# Defaults!/usr/bin/sudoreplay !log_output
# Defaults!/usr/local/bin/sudoreplay !log_output
# Defaults!/sbin/reboot !log_output

##
## Runas alias specification
##

##
## User privilege specification
##
root ALL=(ALL) ALL
manuel  Manuel = /usr/bin/terminal

## Uncomment to allow members of group wheel to execute any command
#%wheel ALL=(ALL) ALL
%wheel  localhost = /usr/bin/thunar

## Same thing without a password
%wheel ALL=(ALL) NOPASSWD: ALL

## Uncomment to allow members of group sudo to execute any command
%sudo   ALL=(ALL) ALL

## Uncomment to allow any user to run sudo if they know the password
## of the user they are running the command as (root by default).
# Defaults targetpw  # Ask for the password of the target user
# ALL ALL=(ALL) ALL  # WARNING: only use this together with 'Defaults targetpw'

## Read drop-in files from /etc/sudoers.d
## (the '#' here does not indicate a comment)
#includedir /etc/sudoers.d


così posso loggiarmi a root e fare le operazioni di root nella sessione dell'utente, perlomeno c'è un rimedio. :D
_________________
Quando arrivi a Linux è un trauma, abituati a Windows, quando arrivi a Gentoo è uno spavento col brivido , però quando lo capisci sei uscito dall'università "GNU/Linux" ;)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum