Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
kmail blocked because of Akonadi pim not operational [Solved
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
aCOSwt
Bodhisattva
Bodhisattva


Joined: 19 Oct 2007
Posts: 2537
Location: Hilbert space

PostPosted: Tue Aug 30, 2011 7:26 am    Post subject: kmail blocked because of Akonadi pim not operational [Solved Reply with quote

Using kmail 1.13.7 under kde 4.6.5

Since yesterday whenever I try to open kmail, I get a message telling :
- Personal Information Management Service is starting.
After some time, it get replaced by the following message :
- The Akonadi personal Information Management service is not operational.
And I cannot get access to kmail.

I understand well why Akonadi PIMS is not operational. At least I did not configure any MySql server.
But I never cared about this since my first kde 4.

What has changed, how can I workaround this without making Akonadi's PIM operational ?

BTW I cannot see how what I emerged yesterday could be involved in this :
(babl - freetype - busybox - networkmanager - binutils - a bunch of emul-linux-x86)
_________________


Last edited by aCOSwt on Sun Sep 04, 2011 4:45 pm; edited 1 time in total
Back to top
View user's profile Send private message
tomtom69
Apprentice
Apprentice


Joined: 09 Nov 2010
Posts: 212
Location: Bavaria

PostPosted: Sat Sep 03, 2011 5:36 pm    Post subject: Reply with quote

Hi,

had the same issue here today.
typing "akonadictl start" gave some error messages because of mysql driver, but AFAIK the standard database driver in KDE4.6.5 is SQLITE.
So I changed within the ~/.config/akonadi/akonadiserverrc driver settings:
Driver=QSQLITE
(The driver was set to QMYSQL before).
I don't know why the setting was changed to QMYSQL but changing it back cured the problem here. Last rebuild was qt-sql which may have caused this (however I etc-update did not show the akonadiserverrc file)

tom
Back to top
View user's profile Send private message
iss
Tux's lil' helper
Tux's lil' helper


Joined: 30 Oct 2006
Posts: 134
Location: Poland/Bydgoszcz

PostPosted: Sun Sep 04, 2011 9:42 am    Post subject: Reply with quote

If your problem is like posted here - https://forums.gentoo.org/viewtopic-p-6801140.html - try rebuilding akonadi-server. It worked for me.
Back to top
View user's profile Send private message
aCOSwt
Bodhisattva
Bodhisattva


Joined: 19 Oct 2007
Posts: 2537
Location: Hilbert space

PostPosted: Sun Sep 04, 2011 4:39 pm    Post subject: Reply with quote

tomtom69 wrote:

typing "akonadictl start" gave some error messages because of mysql driver, but AFAIK the standard database driver in KDE4.6.5 is SQLITE.
So I changed within the ~/.config/akonadi/akonadiserverrc driver settings:
Driver=QSQLITE
(The driver was set to QMYSQL before).
I don't know why the setting was changed to QMYSQL but changing it back cured the problem here. Last rebuild was qt-sql which may have caused this (however I etc-update did not show the akonadiserverrc file)
tom

Thank you tom for answering.
You are right that Gentoo's Akonadi defaults on sqlite. (IUSE: mysql, postgres, +sqlite, test) so if you emerged akonadi-server as is, yes indeed, it is strange that the driver changed to QMYSQL.
But, I had emerged akonadi +mysql -sqlite. :wink:
So... QMYSQL is OK for me.

BTW, I managed to put things back in order... automagically... I cannot tell how... I had managed for the first time to screw completely my Gentoo up ! (Even gcc was implied in the mess... :roll: )
As I was in a hurry... and as I frequently backup... I decided that it would be more efficient restoring the entire system from backup.
Fortunately, it has been. :D
_________________
Back to top
View user's profile Send private message
iss
Tux's lil' helper
Tux's lil' helper


Joined: 30 Oct 2006
Posts: 134
Location: Poland/Bydgoszcz

PostPosted: Mon Sep 05, 2011 1:28 pm    Post subject: Reply with quote

I am an idiot!

Both topics are posted by you - aCOSwt.

Sorry for directing you to your own posts.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum