Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[emerge] xorg-server (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
giims
Tux's lil' helper
Tux's lil' helper


Joined: 16 Aug 2011
Posts: 86

PostPosted: Fri Aug 26, 2011 8:18 pm    Post subject: [emerge] xorg-server (résolu) Reply with quote

Bonjour, j’installe xorg-server pour ensuite installer gnome, je suis le guide qui est sur le site de gentoo.org maisje n'arrive pas a l'installer, voicie le log de /var/tmp/portage/x11-proto/xproto-7.0.21/work/xproto-7.0.21_build/config.log :
Code:
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

It was created by Xproto configure 7.0.21, which was
generated by GNU Autoconf 2.66.  Invocation command line was

  $ /var/tmp/portage/x11-proto/xproto-7.0.21/work/xproto-7.0.21/configure --prefix=/usr --build=x86_64-pc-linux-gnu --host=x86_64-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --libdir=/usr/lib64 --disable-dependency-tracking --disable-dependency-tracking --disable-specs --without-xmlto --without-fop

## --------- ##
## Platform. ##
## --------- ##

hostname = srv-gentux
uname -m = x86_64
uname -r = 2.6.39-gentoo-r3
uname -s = Linux
uname -v = #1 SMP Wed Aug 24 20:34:22 CEST 2011

/usr/bin/uname -p = Intel(R) Core(TM)2 Quad CPU @ 2.40GHz
/bin/uname -X     = unknown

/bin/arch              = unknown
/usr/bin/arch -k       = unknown
/usr/convex/getsysinfo = unknown
/usr/bin/hostinfo      = unknown
/bin/machine           = unknown
/usr/bin/oslevel       = unknown
/bin/universe          = unknown

PATH: /usr/lib64/portage/bin/ebuild-helpers/4
PATH: /usr/lib64/portage/bin/ebuild-helpers
PATH: /usr/local/sbin
PATH: /usr/local/bin
PATH: /usr/sbin
PATH: /usr/bin
PATH: /sbin
PATH: /bin
PATH: /opt/bin
PATH: /usr/x86_64-pc-linux-gnu/gcc-bin/4.4.5


## ----------- ##
## Core tests. ##
## ----------- ##

configure:2303: checking for a BSD-compatible install
configure:2371: result: /usr/bin/install -c
configure:2382: checking whether build environment is sane
configure:2429: error: newly created file is older than distributed files!
Check your system clock

## ---------------- ##
## Cache variables. ##
## ---------------- ##

ac_cv_env_CC_set=
ac_cv_env_CC_value=
ac_cv_env_CFLAGS_set=set
ac_cv_env_CFLAGS_value='-O2 -march=nocona -pipe'
ac_cv_env_CPPFLAGS_set=
ac_cv_env_CPPFLAGS_value=
ac_cv_env_CPP_set=
ac_cv_env_CPP_value=
ac_cv_env_FOP_set=
ac_cv_env_FOP_value=
ac_cv_env_LDFLAGS_set=set
ac_cv_env_LDFLAGS_value='-Wl,-O1 -Wl,--as-needed'
ac_cv_env_LIBS_set=
ac_cv_env_LIBS_value=
ac_cv_env_PKG_CONFIG_LIBDIR_set=
ac_cv_env_PKG_CONFIG_LIBDIR_value=
ac_cv_env_PKG_CONFIG_PATH_set=set
ac_cv_env_PKG_CONFIG_PATH_value=/usr/lib64/pkgconfig
ac_cv_env_PKG_CONFIG_set=
ac_cv_env_PKG_CONFIG_value=
ac_cv_env_XMLTO_set=
ac_cv_env_XMLTO_value=
ac_cv_env_build_alias_set=set
ac_cv_env_build_alias_value=x86_64-pc-linux-gnu
ac_cv_env_host_alias_set=set
ac_cv_env_host_alias_value=x86_64-pc-linux-gnu
ac_cv_env_target_alias_set=
ac_cv_env_target_alias_value=
ac_cv_path_install='/usr/bin/install -c'

## ----------------- ##
## Output variables. ##
## ----------------- ##

ACLOCAL=''
ADMIN_MAN_DIR=''
ADMIN_MAN_SUFFIX=''
AMDEPBACKSLASH=''
AMDEP_FALSE=''
AMDEP_TRUE=''
AMTAR=''
AM_BACKSLASH=''
AM_DEFAULT_VERBOSITY=''
APP_MAN_DIR=''
APP_MAN_SUFFIX=''
AUTOCONF=''
AUTOHEADER=''
AUTOMAKE=''
AWK=''
CC=''
CCDEPMODE=''
CFLAGS='-O2 -march=nocona -pipe'
CHANGELOG_CMD=''
CPP=''
CPPFLAGS=''
CWARNFLAGS=''
CYGPATH_W=''
DEFS=''
DEPDIR=''
DRIVER_MAN_DIR=''
DRIVER_MAN_SUFFIX=''
ECHO_C=''
ECHO_N='-n'
ECHO_T=''
EGREP=''
ENABLE_SPECS_FALSE=''
ENABLE_SPECS_TRUE=''
EXEEXT=''
FILE_MAN_DIR=''
FILE_MAN_SUFFIX=''
FOP=''
GREP=''
HAVE_FOP_FALSE=''
HAVE_FOP_TRUE=''
HAVE_STYLESHEETS_FALSE=''
HAVE_STYLESHEETS_TRUE=''
HAVE_XMLTO_FALSE=''
HAVE_XMLTO_TEXT_FALSE=''
HAVE_XMLTO_TEXT_TRUE=''
HAVE_XMLTO_TRUE=''
INSTALL_CMD=''
INSTALL_DATA='${INSTALL} -m 644'
INSTALL_PROGRAM='${INSTALL}'
INSTALL_SCRIPT='${INSTALL}'
INSTALL_STRIP_PROGRAM=''
LDFLAGS='-Wl,-O1 -Wl,--as-needed'
LIBOBJS=''
LIBS=''
LIB_MAN_DIR=''
LIB_MAN_SUFFIX=''
LTLIBOBJS=''
MAINT=''
MAINTAINER_MODE_FALSE=''
MAINTAINER_MODE_TRUE=''
MAKEINFO=''
MAN_SUBSTS=''
MISC_MAN_DIR=''
MISC_MAN_SUFFIX=''
MKDIR_P=''
OBJEXT=''
PACKAGE=''
PACKAGE_BUGREPORT='https://bugs.freedesktop.org/enter_bug.cgi?product=xorg'
PACKAGE_NAME='Xproto'
PACKAGE_STRING='Xproto 7.0.21'
PACKAGE_TARNAME='xproto'
PACKAGE_URL=''
PACKAGE_VERSION='7.0.21'
PATH_SEPARATOR=':'
PKG_CONFIG=''
PKG_CONFIG_LIBDIR=''
PKG_CONFIG_PATH='/usr/lib64/pkgconfig'
SED=''
SET_MAKE=''
SHELL='/bin/sh'
STRIP=''
STYLESHEET_SRCDIR=''
USE_FDS_BITS=''
VERSION=''
XMLTO=''
XORG_MAN_PAGE=''
XORG_SGML_PATH=''
XSL_STYLESHEET=''
ac_ct_CC=''
am__EXEEXT_FALSE=''
am__EXEEXT_TRUE=''
am__fastdepCC_FALSE=''
am__fastdepCC_TRUE=''
am__include=''
am__isrc=''
am__leading_dot=''
am__quote=''
am__tar=''
am__untar=''
bindir='${exec_prefix}/bin'
build='x86_64-pc-linux-gnu'
build_alias='x86_64-pc-linux-gnu'
build_cpu=''
build_os=''
build_vendor=''
datadir='/usr/share'
datarootdir='${prefix}/share'
docdir='${datarootdir}/doc/${PACKAGE_TARNAME}'
dvidir='${docdir}'
exec_prefix='NONE'
host='x86_64-pc-linux-gnu'
host_alias='x86_64-pc-linux-gnu'
host_cpu=''
host_os=''
host_vendor=''
htmldir='${docdir}'
includedir='${prefix}/include'
infodir='/usr/share/info'
install_sh=''
libdir='/usr/lib64'
libexecdir='${exec_prefix}/libexec'
localedir='${datarootdir}/locale'
localstatedir='/var/lib'
mandir='/usr/share/man'
mkdir_p=''
oldincludedir='/usr/include'
pdfdir='${docdir}'
prefix='/usr'
program_transform_name='s,x,x,'
psdir='${docdir}'
sbindir='${exec_prefix}/sbin'
sharedstatedir='${prefix}/com'
sysconfdir='/etc'
target_alias=''

## ----------- ##
## confdefs.h. ##
## ----------- ##

/* confdefs.h */
#define PACKAGE_NAME "Xproto"
#define PACKAGE_TARNAME "xproto"
#define PACKAGE_VERSION "7.0.21"
#define PACKAGE_STRING "Xproto 7.0.21"
#define PACKAGE_BUGREPORT "https://bugs.freedesktop.org/enter_bug.cgi?product=xorg"
#define PACKAGE_URL ""

configure: exit 1


J'ai retenue cette erreur :
Code:
configure:2429: error: newly created file is older than distributed files!
Check your system clock

Je comprend qu'il y a un problème en rapport avec l'horloge du système mais pas plus :(.


Last edited by giims on Sat Aug 27, 2011 4:49 pm; edited 1 time in total
Back to top
View user's profile Send private message
Poussin
l33t
l33t


Joined: 08 Jun 2007
Posts: 659
Location: Liège

PostPosted: Fri Aug 26, 2011 8:28 pm    Post subject: Reply with quote

il te demande de mettre ton heure à jour (edit: et ta date bien évidemment)
Back to top
View user's profile Send private message
giims
Tux's lil' helper
Tux's lil' helper


Joined: 16 Aug 2011
Posts: 86

PostPosted: Fri Aug 26, 2011 8:32 pm    Post subject: Reply with quote

ok il y a t-il un moyen de regler l'heure en UTC et non en local ? car j'ai vu que sa avait changer depuis baselayout2.
Back to top
View user's profile Send private message
Poussin
l33t
l33t


Joined: 08 Jun 2007
Posts: 659
Location: Liège

PostPosted: Fri Aug 26, 2011 9:03 pm    Post subject: Reply with quote

bah euh oui, enfin, je ne comprends pas trop la question. Tu as vu dans le guide de migration d'openrc que ça avait changer et en quoi, donc tu as lu comment ça fonctionnait maintenant. Je ne vois pas trop ce que tu veux dire
Back to top
View user's profile Send private message
giims
Tux's lil' helper
Tux's lil' helper


Joined: 16 Aug 2011
Posts: 86

PostPosted: Fri Aug 26, 2011 9:20 pm    Post subject: Reply with quote

en fait comme j'ai régler l'heure avec la commande date 082623152011 je me demandais si aprés l'heure était UTC ou local?
Concernant xorg lorsque je le lance avec startx X ne se lance pas et j'ai un message me disant commande not found pour twm xclock xterm exec, ensuite" xinit: connection to X server lost" et pour finir "waiting for X server to shut down erro setting MTRR (base=0xd0000000, size 0x007f0000, type= 1) invalid argument (22)".
et voici le log :
Code:
 
(**) Option "xkb_model" "evdev"
[  7252.510] (**) Option "xkb_layout" "us"
[  7252.516] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event0)
[  7252.516] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[  7252.516] (II) Using input driver 'evdev' for 'AT Translated Set 2 keyboard'
[  7252.516] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
[  7252.516] (**) AT Translated Set 2 keyboard: always reports core events
[  7252.517] (**) AT Translated Set 2 keyboard: Device: "/dev/input/event0"
[  7252.600] (--) AT Translated Set 2 keyboard: Found keys
[  7252.600] (II) AT Translated Set 2 keyboard: Configuring as keyboard
[  7252.600] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input0/event0"
[  7252.600] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)
[  7252.600] (**) Option "xkb_rules" "evdev"
[  7252.600] (**) Option "xkb_model" "evdev"
[  7252.600] (**) Option "xkb_layout" "us"
[  7252.600] (II) config/udev: Adding input device ImExPS/2 Logitech MX Mouse (/dev/input/event1)
[  7252.600] (**) ImExPS/2 Logitech MX Mouse: Applying InputClass "evdev pointer catchall"
[  7252.600] (II) Using input driver 'evdev' for 'ImExPS/2 Logitech MX Mouse'
[  7252.600] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
[  7252.600] (**) ImExPS/2 Logitech MX Mouse: always reports core events
[  7252.600] (**) ImExPS/2 Logitech MX Mouse: Device: "/dev/input/event1"
[  7252.670] (--) ImExPS/2 Logitech MX Mouse: Found 12 mouse buttons
[  7252.670] (--) ImExPS/2 Logitech MX Mouse: Found scroll wheel(s)
[  7252.670] (--) ImExPS/2 Logitech MX Mouse: Found relative axes
[  7252.670] (--) ImExPS/2 Logitech MX Mouse: Found x and y relative axes
[  7252.670] (II) ImExPS/2 Logitech MX Mouse: Configuring as mouse
[  7252.670] (II) ImExPS/2 Logitech MX Mouse: Adding scrollwheel support
[  7252.670] (**) ImExPS/2 Logitech MX Mouse: YAxisMapping: buttons 4 and 5
[  7252.670] (**) ImExPS/2 Logitech MX Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[  7252.670] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio1/input/input1/event1"
[  7252.670] (II) XINPUT: Adding extended input device "ImExPS/2 Logitech MX Mouse" (type: MOUSE)
[  7252.670] (II) ImExPS/2 Logitech MX Mouse: initialized for relative axes.
[  7252.670] (**) ImExPS/2 Logitech MX Mouse: (accel) keeping acceleration scheme 1
[  7252.670] (**) ImExPS/2 Logitech MX Mouse: (accel) acceleration profile 0
[  7252.670] (**) ImExPS/2 Logitech MX Mouse: (accel) acceleration factor: 2.000
[  7252.670] (**) ImExPS/2 Logitech MX Mouse: (accel) acceleration threshold: 4
[  7252.670] (II) config/udev: Adding input device ImExPS/2 Logitech MX Mouse (/dev/input/mouse0)
[  7252.670] (II) No input driver/identifier specified (ignoring)
[  7252.670] (II) config/udev: Adding input device PC Speaker (/dev/input/event4)
[  7252.670] (II) No input driver/identifier specified (ignoring)
[  7252.790] (II) Power Button: Close
[  7252.790] (II) UnloadModule: "evdev"
[  7252.790] (II) Unloading evdev
[  7252.900] (II) Power Button: Close
[  7252.900] (II) UnloadModule: "evdev"
[  7252.900] (II) Unloading evdev
[  7253.060] (II) AT Translated Set 2 keyboard: Close
[  7253.060] (II) UnloadModule: "evdev"
[  7253.060] (II) Unloading evdev
[  7253.220] (II) ImExPS/2 Logitech MX Mouse: Close
[  7253.220] (II) UnloadModule: "evdev"
[  7253.220] (II) Unloading evdev


Edit : j'ai pu me connecter en ssh donc je peut copier ici le retour de "startx" :
Code:
srv-gentux ~ # startx
xauth:  file /root/.serverauth.16668 does not exist


X.Org X Server 1.10.2
Release Date: 2011-05-28
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.39-gentoo-r3 x86_64 Gentoo
Current Operating System: Linux srv-gentux 2.6.39-gentoo-r3 #1 SMP Wed Aug 24 20:34:22 CEST 2011 x86_64
Kernel command line: root=/dev/md3 dolvm dodmraid rootfstype=ext3
Build Date: 27 August 2011  01:05:41AM

Current version of pixman: 0.22.0
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Dec  2 19:52:12 2008
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
/etc/X11/xinit/xinitrc: line 59: twm: command not found
/etc/X11/xinit/xinitrc: line 63: exec: xterm: not found
/etc/X11/xinit/xinitrc: line 60: xclock: command not found
/etc/X11/xinit/xinitrc: line 61: xterm: command not found
/etc/X11/xinit/xinitrc: line 62: xterm: command not found
xinit: connection to X server lost

waiting for X server to shut down error setting MTRR (base = 0xd0000000, size = 0x007f0000, type = 1) Invalid argument (22)


Edit : il fallait simplement installer les paquet twm et xterm.
Back to top
View user's profile Send private message
mp342
Apprentice
Apprentice


Joined: 03 Aug 2010
Posts: 165
Location: France

PostPosted: Sat Aug 27, 2011 5:19 pm    Post subject: Reply with quote

giims wrote:
en fait comme j'ai régler l'heure avec la commande date 082623152011 je me demandais si aprés l'heure était UTC ou local?

Par défaut, date configure/donne l'heure locale, tu dois utiliser 'date -u ...' pour travailler directement en heure UTC.
.
Back to top
View user's profile Send private message
giims
Tux's lil' helper
Tux's lil' helper


Joined: 16 Aug 2011
Posts: 86

PostPosted: Sat Aug 27, 2011 6:24 pm    Post subject: Reply with quote

Merci pour ta réponse car celà fait déjà 2 fois en 2 jours que je règle l'heure.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum