Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Chromium fonts
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
microchiroptera
n00b
n00b


Joined: 23 Jul 2011
Posts: 26
Location: Russia

PostPosted: Mon Aug 22, 2011 3:13 pm    Post subject: [SOLVED] Chromium fonts Reply with quote

I have ugly fonts rendering in Chromium 13.0.782.107. In Firefox everything is fine. I know that my case isn't unique (for example, http://code.google.com/p/chromium/issues/detail?id=13185), but all the solutions that I've found are very different (patches, ~/.fonts.conf editing, something else) and seem to be outdated (solutions that I've found were written in 2009 or 2010). Can anybody offer an up-to-date solution?

Last edited by microchiroptera on Mon Aug 22, 2011 5:09 pm; edited 1 time in total
Back to top
View user's profile Send private message
Kollin
Veteran
Veteran


Joined: 25 Feb 2006
Posts: 1137
Location: Sofia/Bulgaria

PostPosted: Mon Aug 22, 2011 4:19 pm    Post subject: Reply with quote

Do you have all fonts like elog recommends :

Code:
Some web pages may require additional fonts to display properly.
Try installing some of the following packages if some characters
are not displayed properly:
 - media-fonts/arphicfonts
 - media-fonts/bitstream-cyberbit
 - media-fonts/droid
 - media-fonts/ipamonafont
 - media-fonts/ja-ipafonts
 - media-fonts/takao-fonts
 - media-fonts/wqy-microhei
 - media-fonts/wqy-zenhei

_________________
"Dear Enemy: may the Lord hate you and all your kind, may you be turned orange in hue, and may your head fall off at an awkward moment."
"Linux is like a wigwam - no windows, no gates, apache inside..."
Back to top
View user's profile Send private message
microchiroptera
n00b
n00b


Joined: 23 Jul 2011
Posts: 26
Location: Russia

PostPosted: Mon Aug 22, 2011 5:09 pm    Post subject: Reply with quote

Thank you for your answer!

I hadn't them. Installation didn't help, but when I was enabling its' fontconfig configuration files, I saw this:
Code:
# eselect fontconfig list
Available fontconfig .conf files  ( * is enabled ):
  [1]   10-autohint.conf
  [2]   10-no-sub-pixel.conf
  [3]   10-sub-pixel-bgr.conf
  [4]   10-sub-pixel-rgb.conf
  [5]   10-sub-pixel-vbgr.conf
  [6]   10-sub-pixel-vrgb.conf
  [7]   10-unhinted.conf
  [8]   20-fix-globaladvance.conf *
  [9]   20-unhint-small-dejavu-sans.conf
  [10]  20-unhint-small-dejavu-sans-mono.conf
  [11]  20-unhint-small-dejavu-serif.conf
  [12]  20-unhint-small-vera.conf *
  [13]  25-ttf-arphic-ukai-render.conf
  [14]  25-ttf-arphic-uming-bitmaps.conf
  [15]  25-ttf-arphic-uming-render.conf
  [16]  25-unhint-nonlatin.conf
  [17]  30-metric-aliases.conf *
  [18]  30-urw-aliases.conf *
  [19]  35-ttf-arphic-ukai-aliases.conf
  [20]  35-ttf-arphic-uming-aliases.conf
  [21]  40-nonlatin.conf *
  [22]  41-ttf-arphic-ukai.conf
  [23]  41-ttf-arphic-uming.conf
  [24]  44-wqy-zenhei.conf
  [25]  45-latin.conf *
  [26]  49-sansserif.conf *
  [27]  50-user.conf *
  [28]  51-local.conf *
  [29]  57-dejavu-sans.conf
  [30]  57-dejavu-sans-mono.conf
  [31]  57-dejavu-serif.conf
  [32]  60-latin.conf *
  [33]  64-ttf-arphic-uming.conf
  [34]  65-fonts-persian.conf *
  [35]  65-khmer.conf
  [36]  65-nonlatin.conf *
  [37]  66-ja-ipafonts.conf
  [38]  66-takao-fonts.conf
  [39]  66-wqy-zenhei-sharp.conf
  [40]  66-wqy-zenhei-sharp-no13px.conf
  [41]  69-unifont.conf *
  [42]  70-no-bitmaps.conf
  [43]  70-yes-bitmaps.conf
  [44]  75-ttf-arphic-ukai-select.conf
  [45]  80-delicious.conf *
  [46]  90-synthetic.conf *
  [47]  90-ttf-arphic-ukai-embolden.conf
  [48]  90-ttf-arphic-uming-embolden.conf

I seemed strange. Now I have
Code:
# eselect fontconfig list
  [1]   10-autohint.conf *
  [2]   10-no-sub-pixel.conf
  [3]   10-sub-pixel-bgr.conf
  [4]   10-sub-pixel-rgb.conf *
  [5]   10-sub-pixel-vbgr.conf
  [6]   10-sub-pixel-vrgb.conf
  [7]   10-unhinted.conf
  [8]   20-fix-globaladvance.conf *
  [9]   20-unhint-small-dejavu-sans.conf *
  [10]  20-unhint-small-dejavu-sans-mono.conf *
  [11]  20-unhint-small-dejavu-serif.conf *
  [12]  20-unhint-small-vera.conf *
  [13]  25-ttf-arphic-ukai-render.conf *
  [14]  25-ttf-arphic-uming-bitmaps.conf *
  [15]  25-ttf-arphic-uming-render.conf *
  [16]  25-unhint-nonlatin.conf *
  [17]  30-metric-aliases.conf *
  [18]  30-urw-aliases.conf *
  [19]  35-ttf-arphic-ukai-aliases.conf *
  [20]  35-ttf-arphic-uming-aliases.conf *
  [21]  40-nonlatin.conf *
  [22]  41-ttf-arphic-ukai.conf *
  [23]  41-ttf-arphic-uming.conf *
  [24]  44-wqy-zenhei.conf *
  [25]  45-latin.conf *
  [26]  49-sansserif.conf *
  [27]  50-user.conf *
  [28]  51-local.conf *
  [29]  57-dejavu-sans.conf *
  [30]  57-dejavu-sans-mono.conf *
  [31]  57-dejavu-serif.conf *
  [32]  60-latin.conf *
  [33]  64-ttf-arphic-uming.conf
  [34]  65-fonts-persian.conf *
  [35]  65-khmer.conf
  [36]  65-nonlatin.conf *
  [37]  66-ja-ipafonts.conf
  [38]  66-takao-fonts.conf
  [39]  66-wqy-zenhei-sharp.conf
  [40]  66-wqy-zenhei-sharp-no13px.conf
  [41]  69-unifont.conf *
  [42]  70-no-bitmaps.conf
  [43]  70-yes-bitmaps.conf *
  [44]  75-ttf-arphic-ukai-select.conf *
  [45]  80-delicious.conf *
  [46]  90-synthetic.conf *
  [47]  90-ttf-arphic-ukai-embolden.conf *
  [48]  90-ttf-arphic-uming-embolden.conf *

and everything is fine.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum