Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] X.org crashes on init, after migrating to fglrx
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Spidey
Apprentice
Apprentice


Joined: 07 Sep 2006
Posts: 269

PostPosted: Sat Aug 13, 2011 5:00 pm    Post subject: [SOLVED] X.org crashes on init, after migrating to fglrx Reply with quote

I used to have a KMS + radeon open source driver and everything worked flawlessly. Instant switching between ttys, high resolution console, and everything, but I'd like to play StarCraft II and Team Fortress 2 under Gentoo with Wine, and the open source drivers just can't deliver that. In that case, I've disabled KMS and DRM completely from my kernel. I actually used a kernel without module support, the first time this was the problem (ati-drivers wouldn't even merge). Recompiled it with module support, re-emerged the drivers, did an emerge --sync and emerge --update --verbose --ask --deep --newuse world (-uavDN world), everything alright. Did a depclean, a prune, a revdep-rebuild, everything ok and shining.
Rebooted, and then X.org just hangs. I'm using KDM and KDE 4.7, but I don't think this is relevant. I can reboot my box using SSH, but even if I kill KDM, I can't see the console login prompt in my monitor.

Really, the only thing that makes sense is that fglrx is incompatible with kernel series 3, specifically with kernel 3.0.1. Anyone with the same problem? I'll come back later with better logs (emerge --info, Xorg.0.log, .config).


Last edited by Spidey on Sun Aug 14, 2011 10:44 pm; edited 1 time in total
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 6714

PostPosted: Sat Aug 13, 2011 5:15 pm    Post subject: Reply with quote

I've had this problem with every fglrx since 11.2, still don't know why.
Back to top
View user's profile Send private message
Spidey
Apprentice
Apprentice


Joined: 07 Sep 2006
Posts: 269

PostPosted: Sat Aug 13, 2011 6:43 pm    Post subject: Reply with quote

I've used fglrx before, with kernel 2.6.2X, but after I discovered KMS I felt in love with it, it's just beautiful having a free framebuffer console, with fast switching, and all using open source drivers. Too bad 3D performance sucks, and I'd like to play these two games, so I can use Gentoo as my primary OS.
Back to top
View user's profile Send private message
Spidey
Apprentice
Apprentice


Joined: 07 Sep 2006
Posts: 269

PostPosted: Sun Aug 14, 2011 10:43 pm    Post subject: Reply with quote

Here are my logs:
/var/log/Xorg.0.log: http://paste.pocoo.org/show/458400/
emerge --info: http://paste.pocoo.org/show/458403/
/etc/X11/xorg.conf: http://paste.pocoo.org/show/458404/
/usr/src/linux/.config: http://paste.pocoo.org/show/458406/

Anyways, I've solved the problem. I've rebuilt mesa, xorg-server, added vesa to VIDEO_CARDS (as fallback), recompiled ati-drivers, eselected ati as the opengl renderer, and also merged module-rebuild to help me during kernel updates.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum