Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
CUPS 1.4.6 web management needs cookies??
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
Cyker
Veteran
Veteran


Joined: 15 Jun 2006
Posts: 1746

PostPosted: Wed Aug 10, 2011 6:29 pm    Post subject: CUPS 1.4.6 web management needs cookies?? Reply with quote

Is it me or does the web interface for cups-1.4.6 need cookies enabled to work??
Back to top
View user's profile Send private message
Apheus
Guru
Guru


Joined: 12 Jul 2008
Posts: 422

PostPosted: Thu Aug 11, 2011 10:46 am    Post subject: Reply with quote

I had to whitelist "localhost" in NoScript :sigh:

Cannot tell about cookies, I have them enabled anyway (not at the machine atm)
Back to top
View user's profile Send private message
Cyker
Veteran
Veteran


Joined: 15 Jun 2006
Posts: 1746

PostPosted: Thu Aug 11, 2011 3:55 pm    Post subject: Reply with quote

I had to revert to 1.3.11; For some reason the configs for the printer settings work for my HP but not my Canon. Also the 1.3 UI is sooo much less ugly and horrid!
Back to top
View user's profile Send private message
Apheus
Guru
Guru


Joined: 12 Jul 2008
Posts: 422

PostPosted: Thu Aug 11, 2011 4:06 pm    Post subject: Reply with quote

I have just checked: Yes, for administrative actions cookies must be enabled. If they are not, the password dialog does not appear and any changes are silently discarded.
Back to top
View user's profile Send private message
Cyker
Veteran
Veteran


Joined: 15 Jun 2006
Posts: 1746

PostPosted: Fri Aug 12, 2011 12:00 pm    Post subject: Reply with quote

I do wonder why they have done that...
Back to top
View user's profile Send private message
Apheus
Guru
Guru


Joined: 12 Jul 2008
Posts: 422

PostPosted: Fri Aug 12, 2011 12:05 pm    Post subject: Reply with quote

This intransparent and "stealth" behaviour sounds to me like programmers who do not think enough about corner cases, and test only with standard browsers and standard settings. Maybe third-party software was used for authentication.

I would expect at least a message to enable javascript and cookies.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum