Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] Invisible gnome-panels
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
dobbs
Tux's lil' helper
Tux's lil' helper


Joined: 20 Aug 2005
Posts: 103
Location: Wenatchee, WA

PostPosted: Sat Aug 06, 2011 1:12 am    Post subject: [solved] Invisible gnome-panels Reply with quote

Ok, yet another long-term issue I have yet to solve, gnome-panels are apparently invisible. The gnome-panel process is running, I've done revdep-rebuild numerous times, rebuilt the direct dependencies of gnome-panel (including gtk+, glib, glibc...) by hand, upgraded to the ~ppc gnome-base/gnome-panel, synced and updated world a few times. The panels prevent windows from moving to the top of the screen, windows snap to the expected panel border areas, the desktop icons move up when I kill the process and back down when I restart it... all acting like the panels are really there. Deleting ~/{.gconf,gnome2*,config} doesn't help, and even newly created users have the problem. I initially thought maybe they managed to fall behind the desktop so the desktop would intercept any click events (I'm grasping at straws here), but I now notice minimizing a window draws the animated rectangle flying to the bottom of the screen, but off to the right -- past the right edge of the screen.

Is it possible the panels are placing themselves off screen? If so, how would I fix that? I didn't see anything in gconf-editor.

This is on an Apple PowerBook G4 (last model), running mostly ppc stable. All system and world packages are up-to-date as of today (and when it initially started over two months ago too). I'm running standard GDM/metacity and not compiz, because I can't get OpenGL off of software rasterizing (yet another long-term annoyances). None of the other topics I found were relevant to my situation, but I did try resetting my locale as suggested in this one.

Code:
Portage 2.1.10.3 (default/linux/powerpc/ppc32/10.0/desktop/gnome, gcc-4.4.5, glibc-2.12.2-r0, 2.6.38-gentoo-r6-vertigo ppc)
=================================================================
System uname: Linux-2.6.38-gentoo-r6-vertigo-ppc-7447A,_altivec_supported-with-gentoo-2.0.3
Timestamp of tree: Tue, 02 Aug 2011 21:45:01 +0000
distcc 3.1 powerpc-unknown-linux-gnu [disabled]
ccache version 2.4 [enabled]
app-shells/bash:          4.1_p9
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.1-r1, 3.1.3-r1
dev-util/ccache:          2.4-r9
dev-util/cmake:           2.8.4-r1
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.8.3-r1
sys-apps/sandbox:         2.4
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:       2.20.1-r1
sys-devel/gcc:            4.4.5, 4.5.1-r1
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82
sys-kernel/linux-headers: 2.6.36.1 (virtual/os-headers)
sys-libs/glibc:           2.12.2
Repositories: gentoo my_local_overlay
ACCEPT_KEYWORDS="ppc"
ACCEPT_LICENSE="* -@EULA"
CBUILD="powerpc-unknown-linux-gnu"
CFLAGS="-O2 -mcpu=7450 -mtune=7450 -fno-strict-aliasing -pipe -maltivec -mabi=altivec"
CHOST="powerpc-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /var/spool/torque"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -mcpu=7450 -mtune=7450 -fno-strict-aliasing -pipe -maltivec -mabi=altivec"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs ccache distlocks ebuild-locks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://gentoo.llarian.net/ http://gentoo.gossamerhost.com http://mirror.its.uidaho.edu/pub/gentoo/"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en_US en"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync21.us.gentoo.org/gentoo-portage"
USE="X a52 aac acl alsa altivec amr avahi bash-completion berkdb bluetooth branding bzip2 cairo cdda cddb cdparanoia cdr cli consolekit cracklib crypt cups cxx dbus dga dirac dri dts dv dvb dvd dvdr emboss encode evo exif expat faac faad fam fbcon ffmpeg fftw firefox flac fortran fuse gdbm gdu gif gnome gnome-keyring gnutls gpm gsm gstreamer gtk gtk2 iconv icu ieee1394 ipv6 java jpeg jpeg2k laptop lcms libcaca libnotify mad mmap mng modules mp3 mp4 mpeg mpi mudflap nautilus ncurses networkmanager nls nptl nptlonly nut offensive ogg opengl openmp pam pango pcre pdf perl png policykit ppc ppds pppd python qt3support quicktime readline rtc samba sdl session speex spell sqlite sqlite3 ssl startup-notification svg sysfs tcpd theora threads tiff truetype twolame udev unicode usb v4l v4l2 vorbis xcb xinerama xml xorg xulrunner xv xvid zlib" ALSA_CARDS="aoa aoa-fabric-layout aoa-onyx aoa-soundbus aoa-soundbus-i2s aoa-tas aoa-toonie powermac usb-audio via82xx" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="braindump flow karbon kexi kpresenter krita tables words" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev wacom synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_US en" PHP_TARGETS="php5-3" QEMU_SOFTMMU_TARGETS="arm i386 m68k ppc ppc64 sparc sparc64 x86_64" QEMU_USER_TARGETS="i386 m68k ppc ppc64 ppc64abi32 x86_64" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="radeon fbdev v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Last edited by dobbs on Sat Aug 06, 2011 9:40 pm; edited 1 time in total
Back to top
View user's profile Send private message
dobbs
Tux's lil' helper
Tux's lil' helper


Joined: 20 Aug 2005
Posts: 103
Location: Wenatchee, WA

PostPosted: Sat Aug 06, 2011 9:39 pm    Post subject: Reply with quote

Well, while I waited for more ideas to strike me, I ran an "emerge -eva1 gnome" just in case. The emerge failed on net-libs/webkit-gtk because it couldn't find libwebkitgtk-1.0.la, a file installed by net-libs/webkit-gtk. That's also despite my policy of running lafilefixer after every world update... ANYWAY, one of the 465 packages that did rebuild must have been the problem as my gnome-panels are now back.

So there you go. In may case, it was a deep dependency issue.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum