Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] Problem starting X
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
bawig1
n00b
n00b


Joined: 03 Aug 2011
Posts: 62
Location: Melbourne, Australia

PostPosted: Thu Aug 04, 2011 12:43 pm    Post subject: [solved] Problem starting X Reply with quote

Hi guys',

I have been following the instructions below to try and install xorg.

http://www.gentoo.org/doc/en/xorg-config.xml

I have an nvidia graphics card on my lenovo G560. I chose to use the nouveau driver instead of the proprietary ones.

I have configured and re-built my kernel as per the instructions and placed the following in /etc/make.conf

Code:

VIDEO_CARDS="nouveau"
INPUT_DEVICES="evdev synaptics"


Once I install and then try to run startx, it fails. I've looked at the output on the terminal and in the log files and the only thing I could think would be a problem are the following;

Code:

(EE) Failed to load module "nouveau" (module does not exist, 0)
(EE) Failed to load module "vesa" (module does not exist, 0)
(EE) Failed to load module "fbdev" (module does not exist, 0)
(EE) No drivers found

Fatal server error:
no screens found.


I even tried to remove xorg and change the VIDEO_CARDS variable to;

Code:

VIDEO_CARDS="nouveau fbdev vesa"


Then I re-installed it and still no luck. I even tried

Code:

emerge xorg-drivers


but nothing changed. I still cannot boot into X. According to the documentation that I have been following, xorg should just work out of the box.

cheers.


Last edited by bawig1 on Sun Aug 07, 2011 2:34 pm; edited 1 time in total
Back to top
View user's profile Send private message
mark_alec
Bodhisattva
Bodhisattva


Joined: 11 Sep 2004
Posts: 6066
Location: Melbourne, Australia

PostPosted: Thu Aug 04, 2011 1:28 pm    Post subject: Reply with quote

Can you confirm that you have the nouveau drivers installed by posting the output of 'emerge -pv xf86-video-nouveau'. Also can you post your /var/log/Xorg.0.log.
_________________
www.gentoo.org.au || #gentoo-au
Back to top
View user's profile Send private message
Thistled
Guru
Guru


Joined: 06 Jan 2011
Posts: 548
Location: Scotland

PostPosted: Thu Aug 04, 2011 11:48 pm    Post subject: Reply with quote

I may be wrong, but do you not ALSO have to make sure this is taken care of in your kernel config?

Also.....

It might be worthwhile going with proprietary drivers and see if it works then?
Then at least you can narrow the process of elimination.

Hey, it is Gentoo after all. lol.
_________________
Whatever you do, do it properly!
Back to top
View user's profile Send private message
bawig1
n00b
n00b


Joined: 03 Aug 2011
Posts: 62
Location: Melbourne, Australia

PostPosted: Sat Aug 06, 2011 4:03 am    Post subject: Reply with quote

Thanks for replying guys'

emerge -pv xf86-video-nouveau produces;

Code:

[ebuild R    ] x11-drivers/xf86-video-nouveau-0.0.16_pre20110323


and /var/log/Xorg.0.log is listed below

Code:

[  6275.660]
X.Org X Server 1.10.2
Release Date: 2011-05-28
[  6275.662] X Protocol Version 11, Revision 0
[  6275.662] Build Operating System: Linux 2.6.39-gentoo-r3 x86_64 Gentoo
[  6275.663] Current Operating System: Linux localhost 2.6.39-gentoo-r3 #4 SMP Thu Aug 4 18:39:14 UTC 2011 x86_64
[  6275.663] Kernel command line: root=/dev/sda3
[  6275.664] Build Date: 04 August 2011  08:08:11PM
[  6275.664] 
[  6275.665] Current version of pixman: 0.22.0
[  6275.665]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[  6275.666] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  6275.668] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Aug  4 20:26:47 2011
[  6275.669] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  6275.669] (==) No Layout section.  Using the first Screen section.
[  6275.669] (==) No screen section available. Using defaults.
[  6275.669] (**) |-->Screen "Default Screen Section" (0)
[  6275.669] (**) |   |-->Monitor "<default monitor>"
[  6275.670] (==) No monitor specified for screen "Default Screen Section".
   Using a default monitor configuration.
[  6275.670] (==) Automatically adding devices
[  6275.670] (==) Automatically enabling devices
[  6275.670] (==) FontPath set to:
   /usr/share/fonts/misc/,
   /usr/share/fonts/TTF/,
   /usr/share/fonts/OTF/,
   /usr/share/fonts/Type1/,
   /usr/share/fonts/100dpi/,
   /usr/share/fonts/75dpi/
[  6275.670] (==) ModulePath set to "/usr/lib64/xorg/modules"
[  6275.670] (II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
[  6275.670] (II) Loader magic: 0x7cd160
[  6275.670] (II) Module ABI versions:
[  6275.670]    X.Org ANSI C Emulation: 0.4
[  6275.670]    X.Org Video Driver: 10.0
[  6275.670]    X.Org XInput driver : 12.2
[  6275.670]    X.Org Server Extension : 5.0
[  6275.671] (--) PCI:*(0:1:0:0) 10de:0a70:17aa:396d rev 162, Mem @ 0xd2000000/16777216, 0xc0000000/268435456, 0xd0000000/33554432, I/O @ 0x00005000/128, BIOS @ 0x????????/524288
[  6275.671] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[  6275.671] (II) LoadModule: "extmod"
[  6275.672] (II) Loading /usr/lib64/xorg/modules/extensions/libextmod.so
[  6275.672] (II) Module extmod: vendor="X.Org Foundation"
[  6275.672]    compiled for 1.10.2, module version = 1.0.0
[  6275.672]    Module class: X.Org Server Extension
[  6275.672]    ABI class: X.Org Server Extension, version 5.0
[  6275.672] (II) Loading extension MIT-SCREEN-SAVER
[  6275.672] (II) Loading extension XFree86-VidModeExtension
[  6275.672] (II) Loading extension XFree86-DGA
[  6275.672] (II) Loading extension DPMS
[  6275.672] (II) Loading extension XVideo
[  6275.672] (II) Loading extension XVideo-MotionCompensation
[  6275.672] (II) Loading extension X-Resource
[  6275.672] (II) LoadModule: "dbe"
[  6275.672] (II) Loading /usr/lib64/xorg/modules/extensions/libdbe.so
[  6275.672] (II) Module dbe: vendor="X.Org Foundation"
[  6275.672]    compiled for 1.10.2, module version = 1.0.0
[  6275.672]    Module class: X.Org Server Extension
[  6275.672]    ABI class: X.Org Server Extension, version 5.0
[  6275.672] (II) Loading extension DOUBLE-BUFFER
[  6275.672] (II) LoadModule: "glx"
[  6275.672] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[  6275.673] (II) Module glx: vendor="X.Org Foundation"
[  6275.673]    compiled for 1.10.2, module version = 1.0.0
[  6275.673]    ABI class: X.Org Server Extension, version 5.0
[  6275.673] (==) AIGLX enabled
[  6275.673] (II) Loading extension GLX
[  6275.673] (II) LoadModule: "record"
[  6275.673] (II) Loading /usr/lib64/xorg/modules/extensions/librecord.so
[  6275.673] (II) Module record: vendor="X.Org Foundation"
[  6275.673]    compiled for 1.10.2, module version = 1.13.0
[  6275.673]    Module class: X.Org Server Extension
[  6275.673]    ABI class: X.Org Server Extension, version 5.0
[  6275.673] (II) Loading extension RECORD
[  6275.673] (II) LoadModule: "dri"
[  6275.673] (II) Loading /usr/lib64/xorg/modules/extensions/libdri.so
[  6275.673] (II) Module dri: vendor="X.Org Foundation"
[  6275.673]    compiled for 1.10.2, module version = 1.0.0
[  6275.673]    ABI class: X.Org Server Extension, version 5.0
[  6275.673] (II) Loading extension XFree86-DRI
[  6275.673] (II) LoadModule: "dri2"
[  6275.674] (II) Loading /usr/lib64/xorg/modules/extensions/libdri2.so
[  6275.674] (II) Module dri2: vendor="X.Org Foundation"
[  6275.674]    compiled for 1.10.2, module version = 1.2.0
[  6275.674]    ABI class: X.Org Server Extension, version 5.0
[  6275.674] (II) Loading extension DRI2
[  6275.674] (==) Matched nouveau as autoconfigured driver 0
[  6275.674] (==) Matched vesa as autoconfigured driver 1
[  6275.674] (==) Matched fbdev as autoconfigured driver 2
[  6275.674] (==) Assigned the driver to the xf86ConfigLayout
[  6275.674] (II) LoadModule: "nouveau"
[  6275.674] (WW) Warning, couldn't open module nouveau
[  6275.674] (II) UnloadModule: "nouveau"
[  6275.674] (II) Unloading nouveau
[  6275.674] (EE) Failed to load module "nouveau" (module does not exist, 0)
[  6275.675] (II) LoadModule: "vesa"
[  6275.675] (WW) Warning, couldn't open module vesa
[  6275.675] (II) UnloadModule: "vesa"
[  6275.675] (II) Unloading vesa
[  6275.675] (EE) Failed to load module "vesa" (module does not exist, 0)
[  6275.676] (II) LoadModule: "fbdev"
[  6275.676] (WW) Warning, couldn't open module fbdev
[  6275.676] (II) UnloadModule: "fbdev"
[  6275.676] (II) Unloading fbdev
[  6275.676] (EE) Failed to load module "fbdev" (module does not exist, 0)
[  6275.677] (EE) No drivers available.
[  6275.677]
Fatal server error:
[  6275.678] no screens found
[  6275.679]
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[  6275.680] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[  6275.681]
Back to top
View user's profile Send private message
Spidey
Apprentice
Apprentice


Joined: 07 Sep 2006
Posts: 269

PostPosted: Sat Aug 06, 2011 5:44 am    Post subject: Reply with quote

You seem to not have installed the nouveau module in the kernel. I'm not sure, but I guess it's CONFIG_FB_NVIDIA.
Back to top
View user's profile Send private message
bawig1
n00b
n00b


Joined: 03 Aug 2011
Posts: 62
Location: Melbourne, Australia

PostPosted: Sat Aug 06, 2011 10:56 am    Post subject: Reply with quote

I compiled support for Nouveau into the kernel as per the instructions, I did not make it as a module. using menuconfig under

Device Drivers---->
Staging drivers---->
<*> Nouveau (nVidia) cards
[*] support for backlight control
[*] Build in Nouveau's debugfs support

Do I need to use the M - module and build it as a module instead?

This may seem like a stupid question, but what is CONFIG_FB_NVIDIA is it something to go in make.conf?

thanks.
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2665
Location: Slovenia

PostPosted: Sat Aug 06, 2011 12:04 pm    Post subject: Reply with quote

Do *not* enable CONFIG_FB_NVIDIA, that's completely false advice.

Compiling nouveau into the kernel is perfectly ok. Do you get a high resolution console? That would be confirmation that the kernel part works and the problem is in userspace. Which graphic card exactly is it anyway?
Back to top
View user's profile Send private message
bawig1
n00b
n00b


Joined: 03 Aug 2011
Posts: 62
Location: Melbourne, Australia

PostPosted: Sat Aug 06, 2011 12:55 pm    Post subject: Reply with quote

I get a high resolution console at boot with four tux images at the top. My graphics card is an nVidia Geforce with cuda running on a lenovo G560 i5 laptop

uname -a

Code:

2.6.39-gentoo-r3
Back to top
View user's profile Send private message
HangFire
n00b
n00b


Joined: 06 Aug 2011
Posts: 1

PostPosted: Sat Aug 06, 2011 2:06 pm    Post subject: Reply with quote

I'm wondering if the kernel sources you're building nouveau under are different than the kernel you're running.

-HF
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2665
Location: Slovenia

PostPosted: Sat Aug 06, 2011 4:24 pm    Post subject: Reply with quote

bawig1 wrote:
My graphics card is an nVidia Geforce
Err, *which* Geforce? There's a lot of them. Ok, I googled, apparently it's a 310M. That's good, there's full support for it in 2.6.39.

Anyway, if you get a high res console, the kernel part is ok. Have you tried re-emerging xf86-video-nouveau? X can't load it, but your log doesn't say why, just that it failed. Hmm, wait, you get penguins? I remember reading KMS drivers don't show penguins anymore. Do you by any chance have vga= or video= in your bootloader configuration? If so, remove that. And remove vesafb or uvesafb from your kernel, if you have them there.

Also, are you in the video group?
Back to top
View user's profile Send private message
bawig1
n00b
n00b


Joined: 03 Aug 2011
Posts: 62
Location: Melbourne, Australia

PostPosted: Sun Aug 07, 2011 7:33 am    Post subject: Reply with quote

I've followed your instructions'.

- root bawig1 are in group video
- re-emergerd nouveau with
Code:

emerge xf86-video-nouveau


- no video or vga in my /boot/grub/grub.conf
- vesafb and uvesafb are not compiled into the kernel or compiled as a module. I unselected them as per the instructions

Now when I run startx there is no mention of nouveau failing. The screen actually goes black for a second then goes back to the console with some error messages and when I check
/var/log/Xorg.0.log it shows that the nouveau driver is working. Below is the logfile. it looks like there are still problems with evdev and synaptics.

Code:

[  2563.432]
X.Org X Server 1.10.2
Release Date: 2011-05-28
[  2563.432] X Protocol Version 11, Revision 0
[  2563.432] Build Operating System: Linux 2.6.39-gentoo-r3 x86_64 Gentoo
[  2563.432] Current Operating System: Linux localhost 2.6.39-gentoo-r3 #6 SMP Sun Aug 7 14:07:07 UTC 2011 x86_64
[  2563.432] Kernel command line: root=/dev/sda3
[  2563.432] Build Date: 04 August 2011  08:08:11PM
[  2563.432] 
[  2563.433] Current version of pixman: 0.22.0
[  2563.433]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[  2563.433] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  2563.433] (==) Log file: "/var/log/Xorg.0.log", Time: Sun Aug  7 14:58:03 2011
[  2563.434] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  2563.434] (==) No Layout section.  Using the first Screen section.
[  2563.434] (==) No screen section available. Using defaults.
[  2563.434] (**) |-->Screen "Default Screen Section" (0)
[  2563.434] (**) |   |-->Monitor "<default monitor>"
[  2563.434] (==) No monitor specified for screen "Default Screen Section".
   Using a default monitor configuration.
[  2563.434] (==) Automatically adding devices
[  2563.434] (==) Automatically enabling devices
[  2563.434] (==) FontPath set to:
   /usr/share/fonts/misc/,
   /usr/share/fonts/TTF/,
   /usr/share/fonts/OTF/,
   /usr/share/fonts/Type1/,
   /usr/share/fonts/100dpi/,
   /usr/share/fonts/75dpi/
[  2563.434] (==) ModulePath set to "/usr/lib64/xorg/modules"
[  2563.434] (II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
[  2563.434] (II) Loader magic: 0x7cd160
[  2563.434] (II) Module ABI versions:
[  2563.434]    X.Org ANSI C Emulation: 0.4
[  2563.434]    X.Org Video Driver: 10.0
[  2563.434]    X.Org XInput driver : 12.2
[  2563.434]    X.Org Server Extension : 5.0
[  2563.435] (--) PCI:*(0:1:0:0) 10de:0a70:17aa:396d rev 162, Mem @ 0xd2000000/16777216, 0xc0000000/268435456, 0xd0000000/33554432, I/O @ 0x00005000/128, BIOS @ 0x????????/524288
[  2563.435] (II) Open ACPI successful (/var/run/acpid.socket)
[  2563.435] (II) LoadModule: "extmod"
[  2563.435] (II) Loading /usr/lib64/xorg/modules/extensions/libextmod.so
[  2563.435] (II) Module extmod: vendor="X.Org Foundation"
[  2563.435]    compiled for 1.10.2, module version = 1.0.0
[  2563.435]    Module class: X.Org Server Extension
[  2563.435]    ABI class: X.Org Server Extension, version 5.0
[  2563.435] (II) Loading extension MIT-SCREEN-SAVER
[  2563.435] (II) Loading extension XFree86-VidModeExtension
[  2563.435] (II) Loading extension XFree86-DGA
[  2563.435] (II) Loading extension DPMS
[  2563.435] (II) Loading extension XVideo
[  2563.435] (II) Loading extension XVideo-MotionCompensation
[  2563.435] (II) Loading extension X-Resource
[  2563.435] (II) LoadModule: "dbe"
[  2563.435] (II) Loading /usr/lib64/xorg/modules/extensions/libdbe.so
[  2563.435] (II) Module dbe: vendor="X.Org Foundation"
[  2563.435]    compiled for 1.10.2, module version = 1.0.0
[  2563.435]    Module class: X.Org Server Extension
[  2563.435]    ABI class: X.Org Server Extension, version 5.0
[  2563.435] (II) Loading extension DOUBLE-BUFFER
[  2563.435] (II) LoadModule: "glx"
[  2563.435] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[  2563.436] (II) Module glx: vendor="X.Org Foundation"
[  2563.436]    compiled for 1.10.2, module version = 1.0.0
[  2563.436]    ABI class: X.Org Server Extension, version 5.0
[  2563.436] (==) AIGLX enabled
[  2563.436] (II) Loading extension GLX
[  2563.436] (II) LoadModule: "record"
[  2563.436] (II) Loading /usr/lib64/xorg/modules/extensions/librecord.so
[  2563.436] (II) Module record: vendor="X.Org Foundation"
[  2563.436]    compiled for 1.10.2, module version = 1.13.0
[  2563.436]    Module class: X.Org Server Extension
[  2563.436]    ABI class: X.Org Server Extension, version 5.0
[  2563.436] (II) Loading extension RECORD
[  2563.436] (II) LoadModule: "dri"
[  2563.436] (II) Loading /usr/lib64/xorg/modules/extensions/libdri.so
[  2563.436] (II) Module dri: vendor="X.Org Foundation"
[  2563.436]    compiled for 1.10.2, module version = 1.0.0
[  2563.436]    ABI class: X.Org Server Extension, version 5.0
[  2563.436] (II) Loading extension XFree86-DRI
[  2563.436] (II) LoadModule: "dri2"
[  2563.436] (II) Loading /usr/lib64/xorg/modules/extensions/libdri2.so
[  2563.436] (II) Module dri2: vendor="X.Org Foundation"
[  2563.436]    compiled for 1.10.2, module version = 1.2.0
[  2563.436]    ABI class: X.Org Server Extension, version 5.0
[  2563.436] (II) Loading extension DRI2
[  2563.436] (==) Matched nouveau as autoconfigured driver 0
[  2563.436] (==) Matched vesa as autoconfigured driver 1
[  2563.436] (==) Matched fbdev as autoconfigured driver 2
[  2563.436] (==) Assigned the driver to the xf86ConfigLayout
[  2563.436] (II) LoadModule: "nouveau"
[  2563.436] (II) Loading /usr/lib64/xorg/modules/drivers/nouveau_drv.so
[  2563.436] (II) Module nouveau: vendor="X.Org Foundation"
[  2563.436]    compiled for 1.10.2, module version = 0.0.16
[  2563.436]    Module class: X.Org Video Driver
[  2563.436]    ABI class: X.Org Video Driver, version 10.0
[  2563.436] (II) LoadModule: "vesa"
[  2563.436] (WW) Warning, couldn't open module vesa
[  2563.437] (II) UnloadModule: "vesa"
[  2563.437] (II) Unloading vesa
[  2563.437] (EE) Failed to load module "vesa" (module does not exist, 0)
[  2563.437] (II) LoadModule: "fbdev"
[  2563.437] (WW) Warning, couldn't open module fbdev
[  2563.437] (II) UnloadModule: "fbdev"
[  2563.437] (II) Unloading fbdev
[  2563.437] (EE) Failed to load module "fbdev" (module does not exist, 0)
[  2563.437] (II) NOUVEAU driver
[  2563.437] (II) NOUVEAU driver for NVIDIA chipset families :
[  2563.437]    RIVA TNT        (NV04)
[  2563.437]    RIVA TNT2       (NV05)
[  2563.437]    GeForce 256     (NV10)
[  2563.437]    GeForce 2       (NV11, NV15)
[  2563.437]    GeForce 4MX     (NV17, NV18)
[  2563.437]    GeForce 3       (NV20)
[  2563.437]    GeForce 4Ti     (NV25, NV28)
[  2563.437]    GeForce FX      (NV3x)
[  2563.437]    GeForce 6       (NV4x)
[  2563.437]    GeForce 7       (G7x)
[  2563.437]    GeForce 8       (G8x)
[  2563.437]    GeForce GTX 200 (NVA0)
[  2563.437]    GeForce GTX 400 (NVC0)
[  2563.437] (--) using VT number 7

[  2563.438] drmOpenDevice: node name is /dev/dri/card0
[  2563.438] drmOpenDevice: open result is 8, (OK)
[  2563.438] drmOpenByBusid: Searching for BusID pci:0000:01:00.0
[  2563.438] drmOpenDevice: node name is /dev/dri/card0
[  2563.439] drmOpenDevice: open result is 8, (OK)
[  2563.439] drmOpenByBusid: drmOpenMinor returns 8
[  2563.439] drmOpenByBusid: drmGetBusid reports pci:0000:01:00.0
[  2563.439] (II) [drm] nouveau interface version: 0.0.16
[  2563.439] (II) Loading /usr/lib64/xorg/modules/drivers/nouveau_drv.so
[  2563.439] (II) Loading sub module "dri"
[  2563.439] (II) LoadModule: "dri"
[  2563.439] (II) Loading /usr/lib64/xorg/modules/extensions/libdri.so
[  2563.439] (II) Module dri: vendor="X.Org Foundation"
[  2563.439]    compiled for 1.10.2, module version = 1.0.0
[  2563.439]    ABI class: X.Org Server Extension, version 5.0
[  2563.439] (II) NOUVEAU(0): Loaded DRI module
[  2563.439] drmOpenDevice: node name is /dev/dri/card0
[  2563.439] drmOpenDevice: open result is 9, (OK)
[  2563.439] drmOpenDevice: node name is /dev/dri/card0
[  2563.439] drmOpenDevice: open result is 9, (OK)
[  2563.439] drmOpenByBusid: Searching for BusID pci:0000:01:00.0
[  2563.439] drmOpenDevice: node name is /dev/dri/card0
[  2563.439] drmOpenDevice: open result is 9, (OK)
[  2563.439] drmOpenByBusid: drmOpenMinor returns 9
[  2563.439] drmOpenByBusid: drmGetBusid reports pci:0000:01:00.0
[  2563.439] (II) [drm] DRM interface version 1.4
[  2563.439] (II) [drm] DRM open master succeeded.
[  2563.439] (--) NOUVEAU(0): Chipset: "NVIDIA NVa8"
[  2563.439] (II) NOUVEAU(0): Creating default Display subsection in Screen section
   "Default Screen Section" for depth/fbbpp 24/32
[  2563.439] (==) NOUVEAU(0): Depth 24, (--) framebuffer bpp 32
[  2563.439] (==) NOUVEAU(0): RGB weight 888
[  2563.439] (==) NOUVEAU(0): Default visual is TrueColor
[  2563.439] (==) NOUVEAU(0): Using HW cursor
[  2563.439] (==) NOUVEAU(0): GLX sync to VBlank disabled.
[  2563.439] (==) NOUVEAU(0): Page flipping enabled
[  2563.543] (II) NOUVEAU(0): Output LVDS-1 has no monitor section
[  2563.640] (II) NOUVEAU(0): Output VGA-1 has no monitor section
[  2563.648] (II) NOUVEAU(0): Output HDMI-1 has no monitor section
[  2563.752] (II) NOUVEAU(0): EDID for output LVDS-1
[  2563.752] (II) NOUVEAU(0): Manufacturer: CPT  Model: 14c7  Serial#: 0
[  2563.752] (II) NOUVEAU(0): Year: 2010  Week: 48
[  2563.752] (II) NOUVEAU(0): EDID Version: 1.3
[  2563.752] (II) NOUVEAU(0): Digital Display Input
[  2563.752] (II) NOUVEAU(0): Max Image Size [cm]: horiz.: 34  vert.: 19
[  2563.752] (II) NOUVEAU(0): Gamma: 2.20
[  2563.752] (II) NOUVEAU(0): No DPMS capabilities specified
[  2563.752] (II) NOUVEAU(0): Supported color encodings: RGB 4:4:4 YCrCb 4:4:4
[  2563.752] (II) NOUVEAU(0): First detailed timing is preferred mode
[  2563.752] (II) NOUVEAU(0): redX: 0.618 redY: 0.340   greenX: 0.331 greenY: 0.568
[  2563.752] (II) NOUVEAU(0): blueX: 0.149 blueY: 0.059   whiteX: 0.315 whiteY: 0.329
[  2563.752] (II) NOUVEAU(0): Manufacturer's mask: 0
[  2563.752] (II) NOUVEAU(0): Supported detailed timing:
[  2563.752] (II) NOUVEAU(0): clock: 75.4 MHz   Image Size:  344 x 194 mm
[  2563.752] (II) NOUVEAU(0): h_active: 1366  h_sync: 1425  h_sync_end 1464 h_blank_end 1560 h_border: 0
[  2563.752] (II) NOUVEAU(0): v_active: 768  v_sync: 771  v_sync_end 777 v_blanking: 806 v_border: 0
[  2563.752] (II) NOUVEAU(0): Supported detailed timing:
[  2563.752] (II) NOUVEAU(0): clock: 75.4 MHz   Image Size:  344 x 194 mm
[  2563.752] (II) NOUVEAU(0): h_active: 1366  h_sync: 1425  h_sync_end 1464 h_blank_end 1560 h_border: 0
[  2563.752] (II) NOUVEAU(0): v_active: 768  v_sync: 771  v_sync_end 777 v_blanking: 806 v_border: 0
[  2563.752] (II) NOUVEAU(0):  CPT
[  2563.752] (II) NOUVEAU(0): Unknown vendor-specific block 0
[  2563.752] (II) NOUVEAU(0): EDID (in hex):
[  2563.752] (II) NOUVEAU(0):    00ffffffffffff000e14c71400000000
[  2563.752] (II) NOUVEAU(0):    30140103802213780a4e4d9e57549126
[  2563.752] (II) NOUVEAU(0):    0f505400000001010101010101010101
[  2563.752] (II) NOUVEAU(0):    010101010101781d56c2500026303b27
[  2563.753] (II) NOUVEAU(0):    360058c210000018781d56c250002630
[  2563.753] (II) NOUVEAU(0):    3b27360058c210000018000000fe0043
[  2563.753] (II) NOUVEAU(0):    50540a20202020202020202000000000
[  2563.753] (II) NOUVEAU(0):    00434c414131353657423131412000ba
[  2563.753] (II) NOUVEAU(0): EDID vendor "CPT", prod id 5319
[  2563.753] (II) NOUVEAU(0): Printing DDC gathered Modelines:
[  2563.753] (II) NOUVEAU(0): Modeline "1366x768"x0.0   75.44  1366 1425 1464 1560  768 771 777 806 -hsync -vsync (48.4 kHz)
[  2563.753] (II) NOUVEAU(0): Printing probed modes for output LVDS-1
[  2563.753] (II) NOUVEAU(0): Modeline "1366x768"x60.0   75.44  1366 1425 1464 1560  768 771 777 806 -hsync -vsync (48.4 kHz)
[  2563.753] (II) NOUVEAU(0): Modeline "1024x768"x59.9   63.50  1024 1072 1176 1328  768 771 775 798 -hsync +vsync (47.8 kHz)
[  2563.753] (II) NOUVEAU(0): Modeline "800x600"x59.9   38.25  800 832 912 1024  600 603 607 624 -hsync +vsync (37.4 kHz)
[  2563.753] (II) NOUVEAU(0): Modeline "640x480"x59.4   23.75  640 664 720 800  480 483 487 500 -hsync +vsync (29.7 kHz)
[  2563.753] (II) NOUVEAU(0): Modeline "720x400"x59.6   22.25  720 744 808 896  400 403 413 417 -hsync +vsync (24.8 kHz)
[  2563.753] (II) NOUVEAU(0): Modeline "640x400"x60.0   20.00  640 664 720 800  400 403 409 417 -hsync +vsync (25.0 kHz)
[  2563.753] (II) NOUVEAU(0): Modeline "640x350"x59.8   17.50  640 664 720 800  350 353 363 366 -hsync +vsync (21.9 kHz)
[  2563.850] (II) NOUVEAU(0): EDID for output VGA-1
[  2563.858] (II) NOUVEAU(0): EDID for output HDMI-1
[  2563.858] (II) NOUVEAU(0): Output LVDS-1 connected
[  2563.858] (II) NOUVEAU(0): Output VGA-1 disconnected
[  2563.858] (II) NOUVEAU(0): Output HDMI-1 disconnected
[  2563.858] (II) NOUVEAU(0): Using exact sizes for initial modes
[  2563.858] (II) NOUVEAU(0): Output LVDS-1 using initial mode 1366x768
[  2563.858] (II) NOUVEAU(0): Using default gamma of (1.0, 1.0, 1.0) unless otherwise stated.
[  2563.858] (--) NOUVEAU(0): Virtual size is 1366x768 (pitch 0)
[  2563.858] (**) NOUVEAU(0):  Driver mode "1366x768": 75.4 MHz (scaled from 0.0 MHz), 48.4 kHz, 60.0 Hz
[  2563.858] (II) NOUVEAU(0): Modeline "1366x768"x60.0   75.44  1366 1425 1464 1560  768 771 777 806 -hsync -vsync (48.4 kHz)
[  2563.858] (**) NOUVEAU(0):  Driver mode "1024x768": 63.5 MHz (scaled from 0.0 MHz), 47.8 kHz, 59.9 Hz
[  2563.858] (II) NOUVEAU(0): Modeline "1024x768"x59.9   63.50  1024 1072 1176 1328  768 771 775 798 -hsync +vsync (47.8 kHz)
[  2563.858] (**) NOUVEAU(0):  Driver mode "800x600": 38.2 MHz (scaled from 0.0 MHz), 37.4 kHz, 59.9 Hz
[  2563.858] (II) NOUVEAU(0): Modeline "800x600"x59.9   38.25  800 832 912 1024  600 603 607 624 -hsync +vsync (37.4 kHz)
[  2563.858] (**) NOUVEAU(0):  Driver mode "640x480": 23.8 MHz (scaled from 0.0 MHz), 29.7 kHz, 59.4 Hz
[  2563.858] (II) NOUVEAU(0): Modeline "640x480"x59.4   23.75  640 664 720 800  480 483 487 500 -hsync +vsync (29.7 kHz)
[  2563.858] (**) NOUVEAU(0):  Driver mode "720x400": 22.2 MHz (scaled from 0.0 MHz), 24.8 kHz, 59.6 Hz
[  2563.858] (II) NOUVEAU(0): Modeline "720x400"x59.6   22.25  720 744 808 896  400 403 413 417 -hsync +vsync (24.8 kHz)
[  2563.858] (**) NOUVEAU(0):  Driver mode "640x400": 20.0 MHz (scaled from 0.0 MHz), 25.0 kHz, 60.0 Hz
[  2563.858] (II) NOUVEAU(0): Modeline "640x400"x60.0   20.00  640 664 720 800  400 403 409 417 -hsync +vsync (25.0 kHz)
[  2563.858] (**) NOUVEAU(0):  Driver mode "640x350": 17.5 MHz (scaled from 0.0 MHz), 21.9 kHz, 59.8 Hz
[  2563.858] (II) NOUVEAU(0): Modeline "640x350"x59.8   17.50  640 664 720 800  350 353 363 366 -hsync +vsync (21.9 kHz)
[  2563.858] (**) NOUVEAU(0): Display dimensions: (340, 190) mm
[  2563.858] (**) NOUVEAU(0): DPI set to (102, 102)
[  2563.858] (II) Loading sub module "fb"
[  2563.858] (II) LoadModule: "fb"
[  2563.858] (II) Loading /usr/lib64/xorg/modules/libfb.so
[  2563.858] (II) Module fb: vendor="X.Org Foundation"
[  2563.858]    compiled for 1.10.2, module version = 1.0.0
[  2563.858]    ABI class: X.Org ANSI C Emulation, version 0.4
[  2563.858] (II) Loading sub module "exa"
[  2563.858] (II) LoadModule: "exa"
[  2563.858] (II) Loading /usr/lib64/xorg/modules/libexa.so
[  2563.858] (II) Module exa: vendor="X.Org Foundation"
[  2563.858]    compiled for 1.10.2, module version = 2.5.0
[  2563.858]    ABI class: X.Org Video Driver, version 10.0
[  2563.858] (II) Loading sub module "shadowfb"
[  2563.858] (II) LoadModule: "shadowfb"
[  2563.858] (II) Loading /usr/lib64/xorg/modules/libshadowfb.so
[  2563.858] (II) Module shadowfb: vendor="X.Org Foundation"
[  2563.858]    compiled for 1.10.2, module version = 1.0.0
[  2563.858]    ABI class: X.Org ANSI C Emulation, version 0.4
[  2563.858] (--) Depth 24 pixmap format is 32 bpp
[  2563.871] (II) NOUVEAU(0): Opened GPU channel 2
[  2563.871] (II) NOUVEAU(0): [DRI2] Setup complete
[  2563.871] (II) NOUVEAU(0): [DRI2]   DRI driver: nouveau
[  2563.871] (II) NOUVEAU(0): GART: 512MiB available
[  2563.874] (II) NOUVEAU(0): GART: Allocated 16MiB as a scratch buffer
[  2563.874] (II) EXA(0): Driver allocated offscreen pixmaps
[  2563.874] (II) EXA(0): Driver registered support for the following operations:
[  2563.874] (II)         Solid
[  2563.874] (II)         Copy
[  2563.874] (II)         Composite (RENDER acceleration)
[  2563.874] (II)         UploadToScreen
[  2563.874] (II)         DownloadFromScreen
[  2563.874] (==) NOUVEAU(0): Backing store disabled
[  2563.874] (==) NOUVEAU(0): Silken mouse enabled
[  2563.874] (II) NOUVEAU(0): [XvMC] Associated with Nouveau GeForce 8/9 Textured Video.
[  2563.874] (II) NOUVEAU(0): [XvMC] Extension initialized.
[  2563.874] (==) NOUVEAU(0): DPMS enabled
[  2563.874] (II) NOUVEAU(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[  2563.874] (--) RandR disabled
[  2563.874] (II) Initializing built-in extension Generic Event Extension
[  2563.874] (II) Initializing built-in extension SHAPE
[  2563.874] (II) Initializing built-in extension MIT-SHM
[  2563.874] (II) Initializing built-in extension XInputExtension
[  2563.874] (II) Initializing built-in extension XTEST
[  2563.874] (II) Initializing built-in extension BIG-REQUESTS
[  2563.874] (II) Initializing built-in extension SYNC
[  2563.874] (II) Initializing built-in extension XKEYBOARD
[  2563.874] (II) Initializing built-in extension XC-MISC
[  2563.874] (II) Initializing built-in extension XINERAMA
[  2563.874] (II) Initializing built-in extension XFIXES
[  2563.874] (II) Initializing built-in extension RENDER
[  2563.874] (II) Initializing built-in extension RANDR
[  2563.874] (II) Initializing built-in extension COMPOSITE
[  2563.874] (II) Initializing built-in extension DAMAGE
[  2563.893] (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
[  2563.893] (II) AIGLX: enabled GLX_INTEL_swap_event
[  2563.893] (II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
[  2563.893] (II) AIGLX: enabled GLX_SGI_make_current_read
[  2563.893] (II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
[  2563.893] (II) AIGLX: Loaded and initialized /usr/lib64/dri/nouveau_dri.so
[  2563.893] (II) GLX: Initialized DRI2 GL provider for screen 0
[  2563.896] (II) NOUVEAU(0): NVEnterVT is called.
[  2563.900] (II) NOUVEAU(0): Setting screen physical size to 361 x 203
[  2563.900] resize called 1366 768
[  2563.966] (II) config/udev: Adding input device Power Button (/dev/input/event3)
[  2563.966] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[  2563.966] (II) LoadModule: "evdev"
[  2563.967] (WW) Warning, couldn't open module evdev
[  2563.967] (II) UnloadModule: "evdev"
[  2563.967] (II) Unloading evdev
[  2563.967] (EE) Failed to load module "evdev" (module does not exist, 0)
[  2563.967] (EE) No input driver matching `evdev'
[  2563.967] (II) config/udev: Adding input device Video Bus (/dev/input/event4)
[  2563.967] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
[  2563.967] (II) LoadModule: "evdev"
[  2563.967] (WW) Warning, couldn't open module evdev
[  2563.967] (II) UnloadModule: "evdev"
[  2563.967] (II) Unloading evdev
[  2563.967] (EE) Failed to load module "evdev" (module does not exist, 0)
[  2563.968] (EE) No input driver matching `evdev'
[  2563.969] (II) config/udev: Adding input device Power Button (/dev/input/event0)
[  2563.969] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[  2563.969] (II) LoadModule: "evdev"
[  2563.969] (WW) Warning, couldn't open module evdev
[  2563.969] (II) UnloadModule: "evdev"
[  2563.969] (II) Unloading evdev
[  2563.969] (EE) Failed to load module "evdev" (module does not exist, 0)
[  2563.969] (EE) No input driver matching `evdev'
[  2563.969] (II) config/udev: Adding input device Lid Switch (/dev/input/event2)
[  2563.969] (II) No input driver/identifier specified (ignoring)
[  2563.969] (II) config/udev: Adding input device Sleep Button (/dev/input/event1)
[  2563.969] (**) Sleep Button: Applying InputClass "evdev keyboard catchall"
[  2563.969] (II) LoadModule: "evdev"
[  2563.969] (WW) Warning, couldn't open module evdev
[  2563.969] (II) UnloadModule: "evdev"
[  2563.969] (II) Unloading evdev
[  2563.969] (EE) Failed to load module "evdev" (module does not exist, 0)
[  2563.969] (EE) No input driver matching `evdev'
[  2563.976] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event6)
[  2563.976] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[  2563.976] (II) LoadModule: "evdev"
[  2563.976] (WW) Warning, couldn't open module evdev
[  2563.976] (II) UnloadModule: "evdev"
[  2563.976] (II) Unloading evdev
[  2563.976] (EE) Failed to load module "evdev" (module does not exist, 0)
[  2563.976] (EE) No input driver matching `evdev'
[  2563.976] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/event7)
[  2563.976] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "evdev touchpad catchall"
[  2563.976] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad catchall"
[  2563.976] (II) LoadModule: "synaptics"
[  2563.977] (WW) Warning, couldn't open module synaptics
[  2563.977] (II) UnloadModule: "synaptics"
[  2563.977] (II) Unloading synaptics
[  2563.977] (EE) Failed to load module "synaptics" (module does not exist, 0)
[  2563.977] (EE) No input driver matching `synaptics'
[  2563.977] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/mouse0)
[  2563.977] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad catchall"
[  2563.977] (II) LoadModule: "synaptics"
[  2563.977] (WW) Warning, couldn't open module synaptics
[  2563.977] (II) UnloadModule: "synaptics"
[  2563.977] (II) Unloading synaptics
[  2563.977] (EE) Failed to load module "synaptics" (module does not exist, 0)
[  2563.977] (EE) No input driver matching `synaptics'
[  2563.977] (II) config/udev: Adding input device Ideapad extra buttons (/dev/input/event5)
[  2563.977] (**) Ideapad extra buttons: Applying InputClass "evdev keyboard catchall"
[  2563.977] (II) LoadModule: "evdev"
[  2563.977] (WW) Warning, couldn't open module evdev
[  2563.977] (II) UnloadModule: "evdev"
[  2563.977] (II) Unloading evdev
[  2563.977] (EE) Failed to load module "evdev" (module does not exist, 0)
[  2563.977] (EE) No input driver matching `evdev'
[  2564.009] (II) NOUVEAU(0): NVLeaveVT is called.
[  2564.009] (II) NOUVEAU(0): Closed GPU channel 2


Just as a side note I installed twm and xterm just to test X and when I type startx X starts up and shows 2 terminals. But nothing else works (keyboard, touchpad ect) so I have to use the power button to reboot.
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2665
Location: Slovenia

PostPosted: Sun Aug 07, 2011 10:55 am    Post subject: Reply with quote

Ok, graphics now work, but input doesn't. The log shows it, evdev can't load.

So two things:
1) make sure evdev support is in your kernel and that you have /dev/input/event* devices
2) re-emerge xf86-input-evdev. for the touchpad, re-emerge xf86-input-synaptics too

That should do it.
Back to top
View user's profile Send private message
bawig1
n00b
n00b


Joined: 03 Aug 2011
Posts: 62
Location: Melbourne, Australia

PostPosted: Sun Aug 07, 2011 2:33 pm    Post subject: Reply with quote

graphics and input now work evdev is working fine now so is Nouveau, installed twm and xterm to test X. I suppose I can move on to a desktop environment. Thanks guys for helping a n00b.
Back to top
View user's profile Send private message
Thistled
Guru
Guru


Joined: 06 Jan 2011
Posts: 548
Location: Scotland

PostPosted: Tue Aug 30, 2011 12:59 pm    Post subject: Reply with quote

Could you mark this topic as solved then please?
_________________
Whatever you do, do it properly!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum