Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO]incompatibilità tra portage e logrotate
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
marziods
Tux's lil' helper
Tux's lil' helper


Joined: 25 Jun 2009
Posts: 118
Location: <Roma>par lavor | Udine | Friul | Italie

PostPosted: Sun Jul 31, 2011 5:37 pm    Post subject: [RISOLTO]incompatibilità tra portage e logrotate Reply with quote

attualmente uso portage in versione ~. al momento per poter aggiornare alla nuova versione ho dovuto disinstallare logrotate che andava in conflitto con la versione di portage...
Code:
emerge logrotate                     
Calculating dependencies... done!
[ebuild  N     ] app-admin/logrotate-3.7.9-r1  USE="(-selinux)"
[blocks B      ] <app-admin/logrotate-3.8.0 ("<app-admin/logrotate-3.8.0" is blocking sys-apps/portage-2.1.10.9)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-apps/portage-2.1.10.9::gentoo, installed) pulled in by
    sys-apps/portage required by @selected

  (app-admin/logrotate-3.7.9-r1::gentoo, ebuild scheduled for merge) pulled in by
    logrotate


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


esiste un sistema alternativo per ruotare i miei log? oppure esiste la possibilità di reinstallare logrotate?
grazie
_________________
linux user #493115


Last edited by marziods on Sun Jul 31, 2011 7:48 pm; edited 1 time in total
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Sun Jul 31, 2011 7:21 pm    Post subject: Reply with quote

sys-apps/portage-2.1.10.9 è un pacchetto in tilde.

può accadere che preveda, nelle proprie dipendenze, altri pacchetti in tilde.
smaschera app-admin/logrotate-3.7.9-r2 o app-admin/logrotate-3.8.0
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
marziods
Tux's lil' helper
Tux's lil' helper


Joined: 25 Jun 2009
Posts: 118
Location: <Roma>par lavor | Udine | Friul | Italie

PostPosted: Sun Jul 31, 2011 7:48 pm    Post subject: Reply with quote

risolto... stupidamente avevo inserito in tilde la vecchia versione... inserendo in package.keywords la versione 3.8.0 tutto si è risolto!
mandi e grazie
_________________
linux user #493115
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum