Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] Okular - no plugin for mime type application/pdf
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
andorreJr
n00b
n00b


Joined: 05 Nov 2008
Posts: 44
Location: Italy

PostPosted: Wed May 12, 2010 8:37 pm    Post subject: [solved] Okular - no plugin for mime type application/pdf Reply with quote

HI all,
since a few days, after some upgrades (among which kdebase-meta-4.4.3, poppler stuff and okular-4.4.3), I can't open pdf no more.
I usually use Okular, but i also try with Evince and the result is the same.
Here is the output launching okular from command line (root or normal user doesn't change at all):
Code:

user@localhost ~ $ okular /home/user/eBook/book.pdf
okular(3101)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
okular(3101)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
okular(3101)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
okular(3101)/kdecore (services) KMimeTypeFactory::parseMagic: Now parsing  "/usr/share/mime/magic"
okular(3101)/kdecore (services) KMimeTypeFactory::parseMagic: Now parsing  "/home/user/.local/share/mime/magic"
okular(3101)/okular (app) Okular::Document::openDocument: No plugin for mimetype '"application/pdf"'.


Here are the things I've tried so far:
  • update mime database (both /usr/share/mime and /home/user/local/share/mime... don't know really what the update-mime-database command does but I remember once fixed a similar problem)
  • downgrade okular to 4.4.2
  • reinstall all poppler related packages (app-text/poppler, app-text/poppler-qt4 and app-text/poppler-glib) and package dependent to it


any other ideas? :?


Last edited by andorreJr on Mon May 17, 2010 8:11 pm; edited 1 time in total
Back to top
View user's profile Send private message
stim
Tux's lil' helper
Tux's lil' helper


Joined: 21 Jan 2003
Posts: 116
Location: Brisbane, Australia

PostPosted: Fri May 14, 2010 7:42 am    Post subject: Reply with quote

I know it's fairly obvious, but I just want to make sure; you do have the "pdf" use flag enabled for Okular, right?
Back to top
View user's profile Send private message
andorreJr
n00b
n00b


Joined: 05 Nov 2008
Posts: 44
Location: Italy

PostPosted: Fri May 14, 2010 5:11 pm    Post subject: Reply with quote

yes, I've got it!

Code:

localhost ~ # eix okular
[I] kde-base/okular
     Available versions: 
        (4.3)   4.3.3 4.3.5
        (4.4)   (~)4.4.2 (~)4.4.3
        {aqua chm crypt debug djvu ebook +handbook +jpeg kdeenablefinal kdeprefix +pdf +ps +tiff}
     Installed versions:  4.4.3(4.4)(21:58:38 05/12/10)(crypt djvu ebook handbook jpeg pdf ps tiff -aqua -chm -debug -kdeenablefinal -kdeprefix)
     Homepage:            http://www.kde.org/
     Description:         Okular is an universal document viewer based on KPDF for KDE 4.



Anyway thanks for the suggestion, I wasn't aware of a "pdf" use flag :oops:

Andorre
Back to top
View user's profile Send private message
dE_logics
Advocate
Advocate


Joined: 02 Jan 2009
Posts: 2253
Location: $TERM

PostPosted: Sat May 15, 2010 5:39 am    Post subject: Reply with quote

And that flag really doesn't make sense.
_________________
My blog
Back to top
View user's profile Send private message
Aarin
n00b
n00b


Joined: 27 Dec 2008
Posts: 21
Location: Portugal

PostPosted: Sun May 16, 2010 3:57 pm    Post subject: Reply with quote

I'm using GNOME 2.28 and Evince 2.28.2 and I have the same problem.
I tried putting the pdf USE in make.conf, but it didn't make any difference, since no package i have uses that flag.

any idea in how to resolve this?
Back to top
View user's profile Send private message
andorreJr
n00b
n00b


Joined: 05 Nov 2008
Posts: 44
Location: Italy

PostPosted: Mon May 17, 2010 7:58 pm    Post subject: Reply with quote

this doesn't really make sense for me, but apparently I have resolved the issue simply emerging okular without the pdf use flag:
Code:
USE="-pdf" emergekde-base/ okular

and then re-emerging it with iits original use flag (so with pdf included):
Code:
emerge kde-base/okular

I wonder why it didn't work without the first step..
:?
Back to top
View user's profile Send private message
BillyBoy
Tux's lil' helper
Tux's lil' helper


Joined: 26 Nov 2003
Posts: 101
Location: USA

PostPosted: Thu Jul 15, 2010 10:54 pm    Post subject: Reply with quote

andorreJr wrote:
this doesn't really make sense for me, but apparently I have resolved the issue simply emerging okular without the pdf use flag:
Code:
USE="-pdf" emergekde-base/ okular

and then re-emerging it with iits original use flag (so with pdf included):
Code:
emerge kde-base/okular

I wonder why it didn't work without the first step..
:?


I did the above but I'm still getting the following errors:

Code:
okular(24170)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:


every time I start okular. This only started a few days ago.

Leftover detritus from libpng fiasco?

I'm rebuilding all okular's dependencies, so I'll see if that helps. I noticed libXext needs an upgrade.
Back to top
View user's profile Send private message
eipi
n00b
n00b


Joined: 13 Jan 2004
Posts: 14

PostPosted: Tue Oct 11, 2011 7:43 am    Post subject: Reply with quote

sudo update-desktop-database

solved the problem for me.

Regards.
_________________
no one equals eipi : -1 = e^(i*pi)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum